Dashboard

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

Unread Threads

Topic Replies Last Reply

Home Arcade System

3,392

darhgo

My ttx2 cannot access the selection menu in 2.0image!

8

chuckying

Astro City Restoration and Monitor fix

25

Aurich

Sega Dinosaur King Cab Conversion

65

Derick2k

Official Interest list for Namco NA System Multi by Hammy (PCB design by Caius Arcade Repairs & Engineering)

43

Hammy

Recent Activities

  • darhgo -

    Replied to the thread Home Arcade System.

    Post
    Quote from jassin000: “Quote from hoagtech: “@jassin000 I was hoping you could elaborate on the OSSC Compatibility on the different viewlix models since you have a bunch of them. And I'm curious which ones your fave? ” Oh, in that case...Its not…
  • chuckying -

    Replied to the thread My ttx2 cannot access the selection menu in 2.0image!.

    Post
    I downloaded version 2.0 again today. Press and hold the start button to launch my ttx2. As mentioned before, the screen will be black after startup, and the selection menu will not be visible.In the state of black screen, press the button to enter…
  • Aurich -

    Liked brizzo’s post in the thread Reporting Twitter Fake Account.

    Like (Post)
    The reason for banning him and his perception of why he was banned are two different things. As he has demonstrated he doesn't know right and wrong in social situations. His ban pre-dates any talk about modern systems and was due to his behavior towards…
  • Aurich -

    Replied to the thread Astro City Restoration and Monitor fix.

    Post
    Looks solid man! Miss running offline sets with you, waiting for the day I can reopen again. But glad you have your cab in nice shape in the meantime.
  • Aurich -

    Liked BumbleChump’s post in the thread Astro City Restoration and Monitor fix.

    Like (Post)
    Possibly the final update for this machine. I got everything working, finally! 6e5jd1vl.jpg Got those wheels and footplate installed! KSYpNQSl.jpg The issue that took the longest to solve was getting a clean 240p image out of a windows 10 computer.…