Dashboard

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

Unread Threads

Topic Replies Last Reply

Sega bloxeen video jittering issue

9

PekArcadeGamer

Repro New Net City panel - color issue

3

TerakRall

Sega Hikaru / Planet Harriers questions! (report from Hikaru subforum)

10

nem

Need help I'm having a melt down

9

8bitforlife

Taito Vewlix F monitor replaced with LG 1080P monitor

41

Hadouken Arcade

Recent Activities

  • PekArcadeGamer -

    Replied to the thread Sega bloxeen video jittering issue.

    Post
    Quote from ekorz: “Quote from PekArcadeGamer: “System C2. ” That one should be running at 60hz, so I don't think that's the problem then. You could make sure your voltages are good, but I've also had video ground issues, like @xodaraP mentioned, happen…
  • PekArcadeGamer -

    Liked ekorz’s post in the thread Sega bloxeen video jittering issue.

    Like (Post)
    Quote from PekArcadeGamer: “System C2. ” That one should be running at 60hz, so I don't think that's the problem then. You could make sure your voltages are good, but I've also had video ground issues, like @xodaraP mentioned, happen on sega boards so…
  • TerakRall -

    Replied to the thread Repro New Net City panel - color issue.

    Post
    Quote from PascalP: “Isn’t there still a protective film on it? ” No - the protective film was clear, and was removed before the panel was installed.
  • PascalP -

    Replied to the thread Repro New Net City panel - color issue.

    Post
    Isn’t there still a protective film on it?