Dashboard

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

Unread Threads

Topic Replies Last Reply

Is this a bad idea? Switching PSU load question.

0

Candy Cabs Aero City Footrests Showed Up Hoagtech's PLOG.

319

hoagtech

Darksoft Multi - I get audio but no video

3

waali

CPS3 Resistor Array

16

BlinG

Pinned --> Get your CPS2 Multi game here!!!! <--

1,185

TMF68k

Recent Activities

  • Murray -

    Posted the thread Is this a bad idea? Switching PSU load question..

    Thread
    So, I have a groovymame cab that i will be using a lot. It's running video and controls through the JPAC. All works well there. My question is, in my Namco Exceleena cab, with original wiring and PSU, I know i'm not supposed to run the PSU with no load…
  • waali -

    Liked BlinG’s post in the thread CPS3 Resistor Array.

    Like (Post)
    Thanks to XeD sending me some replacement resistors. Replaced the faulty one and sound has been restored.
  • hoagtech -

    Replied to the thread Candy Cabs Aero City Footrests Showed Up Hoagtech's PLOG..

    Post
    The footrests are here. I like the look and feel of them much better. They are not 1:1 to the original though. The medium treads are finer in between the big ribs. I noticed when I removed the old ones, They were randomly cut by Sega so some had…
  • waali -

    Replied to the thread Darksoft Multi - I get audio but no video.

    Post
    As above make sure the boards are mated solidly including the side clips. Check your 5V, going over can cause sound but no video issues.
  • BlinG -

    Replied to the thread CPS3 Resistor Array.

    Post
    Thanks to XeD sending me some replacement resistors. Replaced the faulty one and sound has been restored.