Dashboard

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

Unread Threads

Topic Replies Last Reply

Candy Cabs Aero City Glass Screen Covers and Bezels Hoagtech's PLOG.

271

hoagtech

Naomi 2 NetDIMM blank screen on boot

4

twistedsymphony

Howdy from a Dreamcast veteran

8

piscian18

Astro City Restoration and Monitor fix

17

BumbleChump

UMK3 Top & Bottom Plates From Lions3

9

mugen_ketsueki

Recent Activities

  • hoagtech -

    Replied to the thread Candy Cabs Aero City Glass Screen Covers and Bezels Hoagtech's PLOG..

    Post
    Thanks guys. I was hoping you could afford to get the foot plates chromed. Mine were just redone at the powder coater. They look much better now. I have x2 step downs (I own a sharp X68000 and MSX2+) but they both don't have a ground on the plug or…
  • hoagtech -

    Liked Kavas’s post in the thread Candy Cabs Aero City Glass Screen Covers and Bezels Hoagtech's PLOG..

    Like (Post)
    Quote from Aurich: “Quote from Kavas: “I use a step down converter in all my Japanese consoles and equipment despite there being multiple people claiming it will do them no harm to run on American AC. Doesn't hurt nor cost that much. ” I have 9…
  • hoagtech -

    Liked Aurich’s post in the thread Candy Cabs Aero City Glass Screen Covers and Bezels Hoagtech's PLOG..

    Like (Post)
    Quote from Kavas: “I use a step down converter in all my Japanese consoles and equipment despite there being multiple people claiming it will do them no harm to run on American AC. Doesn't hurt nor cost that much. ” I have 9 Japanese cabs in my…
  • telecommand -

    Liked rocco’s post in the thread Home Arcade System.

    Like (Post)
    Quote from faithful: “Anybody tried this cable? Usually their products are good at least. ” Yeah, I'm using it. Works fine with HAS.
  • twistedsymphony -

    Replied to the thread Naomi 2 NetDIMM blank screen on boot.

    Post
    remove the net-dimm, boot with nothing in the cart slot and see if you get the NAOMI logo. if you do that means either your voltages are too low or your Net DIMM is a problem. my 3.3 line measures 3.36V at the filterboard because that's what it needs…
  • ekorz -

    Replied to the thread Naomi 2 NetDIMM blank screen on boot.

    Post
    Loaded voltage is all that matters, and maybe I'm just paranoid but I'd dial that in at 3.3v on the nose. But being that close I'm not going to say that's the issue... So booting another dimm or cart, the motherboard works fine? If you de-case this…