Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • Bluetear -

    Replied to the thread Greetings from Saskatchewan (CANADA).

    Post
    Love that sweet collection of sticks, @NormanJr911. Not sure if the same is true for you, but my interest in stick collecting and modding was basically the gateway drug that led me into the arcade hobby.
  • Bluetear -

    Liked NormanJr911’s post in the thread Greetings from Saskatchewan (CANADA).

    Like (Post)
    Hi everyone, My name is Norman and working on and learning about arcade projects is slowly becoming my favourite pastime. I am an avid fighting game player and fight stick collector. A few years ago I picked up a Dynamo Street Fighter Alpha 2 cabinet…
  • Escarioth -

    Replied to the thread Greetings from Saskatchewan (CANADA).

    Post
    Where i live theres not much...and I always get dreadful shipping fees *_* lucky to have a blast
  • St4rgalaqtic -

    Posted the thread NAMCO system 10 repair help.

    Thread
    Scored a Mr. Driller G for a great price but the caps are corroded. Have been searching the internet for a schematic and no luck. Hoping someone here can help out.
  • Frank_fjs -

    Replied to the thread Chinese NEOGEO system.

    Post
    If it's a coin cell it's not as likely to leak, and can be replaced with a new one if needed (rechargeable). It's safe to remove and only holds BIOS settings like the date and time etc. Pretty common issue with Neo and OSSC, it has an out of spec…
  • NormanJr911 -

    Replied to the thread Greetings from Saskatchewan (CANADA).

    Post
    Thanks @Escarioth ! I’ve actually got several parts for my blast right here in Canada. Mostly from Quebec. Hoarding all the goods out east looks like :D
  • rewrite -

    Liked benime’s post in the thread G-Net System Error 000542.

    Like (Post)
    System Error 000542 caused by using PCMCIA -> SD adapter. Used a PCMCIA -> CF adapter with CF card instead and it boots games fine now. Just need to sort out the graphic issues.
  • KTD10 -

    Replied to the thread MVH 4 Slot - Green screen and glitching when games load or played.

    Post
    Thanks, I ended up cleaning everything out and putting it back together, seems much better now. I'll check the 5V rail next.
  • benime -

    Replied to the thread G-Net System Error 000542.

    Post
    System Error 000542 caused by using PCMCIA -> SD adapter. Used a PCMCIA -> CF adapter with CF card instead and it boots games fine now. Just need to sort out the graphic issues.