Recent Activities

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • friedpotatoz -

    Liked psykom1’s post in the thread Mortal kombat 2 no audio blast city.

    Like (Post)
    You are correct. You NEED a -5V converter in your cabinet to make this happen. The Blast will not output -5V. I bought this guy's adapter to solve my Blast City power problem. Works perfectly with anything I need -5V on.
  • friedpotatoz -

    Replied to the thread Sengoku Blade / Tengai missing capacitor.

    Post
    Quote from nassekova: “Got this cleaned up now! With new caps it plays, looks and sounds really good ” Great Job, looks awesome!
  • friedpotatoz -

    Liked nassekova’s post in the thread Sengoku Blade / Tengai missing capacitor.

    Like (Post)
    Got this cleaned up now! With new caps it plays, looks and sounds really good 8) That "wet splash" on the back is a new coating of electronics lacquer. That gasoline melted some of the old so I fixed that too. It seems that volume is now higher but not…
  • Fluffy -

    Liked XeD’s post in the thread Any PGM Conversion info out there?.

    Like (Post)
    No dip 1 is not on. When I exit the test screen it does not ask me to flip the switch. I test this by flipping dip1 and exiting. When doing so it tell me to flip it the other way.
  • MudGuts83 -

    Liked hursit’s post in the thread ST-V Custom Metal Case.

    Like (Post)
    Hello people Working on Sega ST-V Custom metal case. I have already finished the drawing last year but i didnt publish it. I need some help about of measurements for 1- Multi System Cartridge measurements 2- LCD game selector. Please share with me…
  • sammargh -

    Replied to the thread A Freeware Taito TypeX2 Multigame..

    Post
    Works fine on my Net City & New Net City
  • Rtl -

    Replied to the thread Nintendo Super System Arcade restoration.

    Post
    Some more updates guys.......did the top part of the cabinet and put new artwork and T Moulding on. This thing is coming up awesome, I really dig the green T Mould on the top What do you guys think?
  • gunblade -

    Replied to the thread Looking for australain guy for help.

    Post
    i doubt flyback is bad, most likely the hv adj pot needs to go back to the correct position there is a possibility the HOT is short circuit the right way to do this is turn the hv adj down and then use a hv probe connected to meter and adjust the hv to…
  • nonosto -

    Replied to the thread Looking for australain guy for help.

    Post
    Quote from xtrasmiley: “I think @rewrite is doing this work now, and check out this guy: retrohacks.net He was recommended via this video I watched the other day: youtube.com/watch?v=mBUeDDuRfmU Welcome to the forums and good luck man! ” thx. in…
  • nonosto -

    Replied to the thread Looking for australain guy for help.

    Post
    when you said shutdown you mean flyback turn off or died? Is it a symptom?
  • nonosto -

    Liked gunblade’s post in the thread Looking for australain guy for help.

    Like (Post)
    no wonder you don't get a picture after adjusting HV.adj, that is for high voltage- its probably going in hv shutdown at least
  • opt2not -

    Liked yuro’s post in the thread UD-USB Decoders.

    Like (Post)
    Quote from opt2not: “one last question, are there recommend screws I can use to secure my decoders to my HAS? I feel they’re too easy to detach from the DB-15 ports. ” I jacked mine from another connecter and use them the same way you're intending.…