Search Results

Search results 1-20 of 26.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    arcade-projects.com/forums/ind…3b19882e3194dd27e9dec4ec2 Here's what I was thinking for Namco - not sure it'll be too tight though. It's going to take 13 hours to print and barely fits in my printer's build area though, so we'll see if it actually works. The idea is the board slides in, and is held in place by the ribbon cable.

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Yup - there's a few reason for the issues you mention With regards to the lack of mounting holes, it was originally intended to plug upright straight into the 573, so the IDE socket itself was meant to hold it up (this is also why it's through hole, for a bit more strength - and being easier to solder). However, that made it harder to fit in certain places like Namco 2x6 cases, and more importantly, I had a terrible time actually sourcing those right angle female connectors. I generally had to b…

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Also, I've just turned on 'general sales', so anyone who wasn't on the waiting list or whatever can now order one, first come first served

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    If there's anything obviously missing from the documentation (such as a diagram of what everything is?) please let me know

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    One notion that amused me was that since the PCB support USB host, it could drive the USB dongle directly (there's already requests it drives a USB LCD/screen directly). It could also use a USB ethernet dongle to be "online" for loading games over LAN or whatever, the main issue at that point is that it doesn't currently have a USB hub driver to plug in more than two things. I am looking into HDD support too, but so far the 2x6 won't even try talking to the PCB with a hard disk game, so I'm not …

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    I did one, you can see it here: issues.tattiebogle.net/dokuwik…:ide_simulator:enclosures It's not great though (mostly due to it being super thin in places, and it's only designed to protect the PCB from shorts/etc.), so I'll design a new one this weekend to make it into a 5.25"-mountable form factor.

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Yeah, a few games behave almost like they're going to boot anyway when there's "no media in the drive", so it was pretty confusing during debugging

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    That's right yup - any standard OTG cable should send the correct signal (really, just shorting a pin to ground) to the micro USB connector on the PCB that tells it to go into USB host mode and provide 5V. Here's a photo demonstrating how you can hook it up (I have a 'charger doctor' just to confirm power is actually coming out, you obviously don't need that in between!) arcade-projects.com/forums/ind…3b19882e3194dd27e9dec4ec2 Note that both USB0 and USB1 can do this, but USB1 is only full speed…

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Glad you received the boards! There's some documentation I update whenever I remember something I missed here: issues.tattiebogle.net/dokuwik…antis:IDE+Simulator:start The idea is that others can contribute too but I haven't yet confirmed the permissions (you log in via the issue tracker) On the docs there I note the SD card issue, where the slot's a little iffy During testing I found it was generally okay if I tried to insert it so that the SD card's left edge 'runs' along the little metal tab …

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Yeah, the 573 I was using for testing is identified by a few of the games as a plain PSX, which is apparently a thing that can happen if they have a slightly different chipset to normal (and it's very ironic to see the game announce that it's not running on a 573, on a 573). The one I was using to test DDR has a bootleg BIOS which makes it look for a different filename, and I haven't tried swapping ROMs (the bootleg BIOS is caked in gluegun glue) or renaming the files in the game disk yet. I hav…

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Quote from twistedsymphony: “@rtw There seems to be at least a few improperly packed discs. Netchuu Pro Yakuu 2002 is one of them. it's a CD game but appears to be packed as a DVD and neither of us have been able to get it to boot from disc. There are a few other CD games packed as DVD but most of them seem to work (though I don't know how accurate the unpacked discs are to the original). I think Smash Court Pro and Ridge Racer V fall into this category. Then there's Super Dragonball Z which I b…

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Small production run is complete (with some tweaks from the prototype a few people have): arcade-projects.com/forums/ind…3b19882e3194dd27e9dec4ec2arcade-projects.com/forums/ind…3b19882e3194dd27e9dec4ec2 I'm going to design a small 3D printed case to protect the PCB, but other than that all that's left is to finish investigating an issue with some Namco games (specifically relating to MAME/CHD behaviour).

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Quote from kuze: “With the current design will it fit internally in a Sys246 or Sys256 where the DVD drive would normally go? I can see using an SD card extension cable to route to the front and make it easy to change cards/games. ” You could also use a USB extension cable with a USB OTG cable and just put the games on a USB flash drive - I'd actually recommend this, as from testing so far USB flash drives seem to run faster than SD cards. Since the card has dual host USB, it's also theoreticall…

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Quote from rtw: “Nice @electric_monk , can you share the technical details on the fix for us curious ? ” Nothing too exciting - a bug in the VHDL on the FPGA was causing it to detect IDE reset requests that didn't actually exist (which was why i was able to identify the issue so quickly - the firmware on the board was reporting "reset requested from IDE interface" whilst the board with the logging firmware indicated no such thing had occurred), so whatever was happening at that moment was droppe…

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    So with the "how to fix the video" thing, I was able to confirm that Tekken 4 ran for 24 hours with my fix for the white screen bug, and I'm currently trying Soul Calibur 3, which has been running for 4 hours without any sign of a glitch so far! Hopefully that has addressed the issue.

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Aha! Thanks for the help, messing with the values randomly didn't help, but finding the instructions and setting it to the "recommended" values of 03/04 seems to have fixed it. They were at 90/95 when I went into that menu (which was also in Chinese, since I hadn't messed with the settings before). I also set it to 1024x768 and it looks a thousand times better! Now I can definitely reproduce the issue ad nauseam It was pretty hard since one of the things that got damaged in the move was the 'men…

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    I am using a cheapy converter, maybe that’s all it is after I moved house it was already malfunctioning pretty badly but still “generally okay” I guess it’s time to try out the framemeister I bought!

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Of course, I’m just wondering if anyone has any pointers on the approximate area such capacitors might be, or if I just need to start repairing the board from scratch

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    On a somewhat related note, I do think there might be something slightly wrong with this 246 - the image slowly turns white, so after ~5 attract cycles it's just totally white. This makes it hard to see 'the screen going white', which sometimes takes more than 5 attract cycles to occur I googled a bit and found a reference to an RGB amplifier IC that might have some bad caps (and I mean, it does seem to be working, just drifting away from the correct gain), so can anyone direct me as to what I n…

  • ATAPI/IDE ODE Testing

    electric_monk - - System 246/256

    Post

    Don't worry - I have a special firmware for the board that turns it into a datalogger so I can see what the drive sent and received from another device on the bus - in this case, I have two of my PCB plugged in via a normal IDE master/slave cable, and I can see that my PCB has reacted weirdly to the 246 transmitting an ordinary ATAPI request