Multi MVS not working at all...

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Multi MVS not working at all...

      Hello there.

      it's quite a story i'm going to tell, so please take a seat...

      I'm gonna start by saying that i already have a Multi CPS2 that is working perfectly fine, and helped a friend of mine with the same piece of hardware.

      I wanted to have the NeoGeo fullset, so I bought the multi MVS on Saveyourgames.it.

      My mentionned friend received it while i was away, and tried it.
      It seems to work? but with some glitches.

      I tried it at home later.
      I have 3 MVS Slots : 2 MV1FZ and 1 MV1FZS

      one was perfectly fine, working with my unibios, the other MV1FZ is working well but it adds credit 2P all the time (annoying but not fatal)
      the last one is in Z80 error... and I know no one who knows how to fix it.

      I tried to start the multi on the "perfect" slot........ and it never worked : the picture is glitchy as hell ! and now, even an original MVS has this problem on this slot...

      on the second one, the image was ok, but some games had issues (samurai shodown 4 was almost entirely red, Baseball Stars 2 missed all the players faces etc...)

      on the third one, Baseball Stars worked better but then : black screen, and Z80 shit... ||

      I stayed on the second one and decided to do an update with the last files available.

      The firmware part went ok, but then i tried to update the menu.. the cartridge is not working since.

      My 3 slots, 3 differents slots at my friend's... none of them seems to launch the cartridge.
      every time we tried, we have the grid on screen.

      we tried to format the SD card again and start over, but nothing worked.

      What can I do ?

      I sold my MVS games to fund this, I have only 1 game left... I'm kinda depressed this isn't working ;(

      Please tell me if you have any idea how to repair this. ^^
    • Sounds like you have incorrectly updated the fw or menu. Try again. First place all firmwarecfiles in the update folder and then boot the cart. Wait a minute then power off. Then place the menu update files in a folder called menu inside of the update folder.

      So menu files inside of a folder called "menu" inside of the folder called "update" and boot. This should get you going again.

      Do make sure the firmware files are fir MVS and not AES. If you mix them up the cart will not work. The MVS multi is very stable so you should not be encountering gfx issues.
    • the multi is updated with the newest files... but still glitching on samurai showdown 4.
      Red screen at the beginning, all dialogues boxes are plain red... shadows are red to...

      It pains me to see one of my top 3 Neogeo games like that.

      My "good" slot is still glitchy as hell. I don't understand why.
    • I Had pictures of my new astro, but it's a pain to post... anyway, I tried my Multi MVS with other slots, on other Arcade Cabinets and with mine as well.
      I found two good slots, and the cartridge works perfectly fine on any Cabinet.

      So, I have to replace my 3 MVS slots (or to find someone who can repair them).

      Thanks a lot for your help