Multiple MVS 4 Slot Repair Log - In Progress

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Multiple MVS 4 Slot Repair Log - In Progress

      Hi everyone,
      I was asked to repair a box full of 4 slot MVS boards by an operator friend.

      I pulled the first one out today and decided to start a log as I go and hopefully get at least a couple of these up and running (some are believed to be beyond repair but will be good for parts supply!)

      Board 1 Fault: Video RAM Error - In progress

      Board 2 Fault: Video RAM Error - Repaired!

      Board 3 Fault: Fast Video Ram (8000 region) error - Repaired!

      Board 4 Fault: Crosshatch of death - Repaired!

      Board 5 Fault: Click of death - Repaired!

      Board 6 Fault: Major corrosion. Both top and bottom boards beyond repair

      Board 7 Fault: Major corrosion. Both top and bottom boards beyond repair.


      Standard upgrades/cleaning for all boards:

      - Batteries removed and coin cell holder installed

      - Battery area scrubbed clean to remove any previous acid leakage

      - Rechargeable CR2032 installed

      - Board cleaned using Simple Green

      - Flux residue cleaned using isopropyl alcohol

      - Cart slots cleaned with isopropyl alcohol

      The post was edited 6 times, last by xodaraP ().

    • Board 1

      Replaced both 62256 surface mount video RAM (twice, the first replacement set was also faulty!)

      Additional Fault: Video RAM Error at $8000

      Fix: Replaced both fast video RAM (Sony CXK5814)

      Additional Fault: Crosshatch of death

      Current Status: Repaired 3 traces that all failed continuity test. Board is currently still not booting on any slot.

      Tested top board. Slots 2 and 4 boot with graphics issues, no boot slot 1 and 3. No sound on any slot.

      The post was edited 1 time, last by xodaraP ().

    • Board 5

      Clicks regularly on startup, does not proceed through boot process

      In progress. Board was very dirty and has been properly cleaned before proceeding with repairs.

      Click of death

      Replaced work RAM - click of death on different colour screen

      Replaced BIOS with UniBIOS and boots to crosshatch

      Burned factory BIOS to replace dead mask ROM - now reports fast video RAM error

      Socketed and replaced fast video RAM

      Fast video RAM error expecting AAAA received AAEA

      Metered out working board and found bad trace on pin 11 to LSPC custom

      Repaired trace on underside of board

      Board now booting on all 4 slots, repair complete!

      The post was edited 1 time, last by xodaraP ().