Blind Blast City - MS-2931

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Blind Blast City - MS-2931

      It looks like I am going to have to get my Blast City serviced. Just want to share everything I've tried, ask for recommendations, and get some feedback on where to send the chassis (unless it sounds like something else).

      1) The blast city was working just fine two weeks ago with no issues. Image was bright, no flickering, no odd sounds booting up, and worked with 15 and 31 signals when it last had an image. This is the autosync ms-2931.
      2) When I boot it up I do hear the power supply fan, the marque lights turn on, I do get sound to the speakers, I can control my game, and I was able to use the credit button. I am using a j-pac and groovymame setup though but I did test with my neogeo mvs with darksoft kit and everything stayed the same. Just blind gameplay but everything but monitor works.
      3) I unplugged the power cord for 30 seconds and tested but no luck
      4) I tried turning off the power switch on the power supply for 30 seconds and tested but no luck
      5) I checked the door switch and the zip tie was still secure. I even got a flat head out, pressed the button in a little more, and tried turning it on but no luck
      6) When the cab is on I don't get anything on the screen when touching the osd buttons
      7) When I am turning it on I get no buzz, pop, static, or flicker from the monitor. I even touched the glass of the monitor and there is definitely none of the usual static

      I haven't checked fuses or popped open the back yet on this issue. I'm a crt newbie and I've only owned this KC cab for a 4-5 months. I did have to touch the power supply early on since the fan was dying. I replaced the fan and while I was in there I did visually inspect the caps for mushrooms and leaking. Besides for being dust rabbit city it looked ok. I haven't really moved the cab and I've probably played it off and on every weekend for 3 months since I did the fan change. I have my doubts it is the power supply since the built in speakers work, it can power a darksoft mvs kit, controls work, and lights work. I'm definitely leaning towards a chassis issue.

      What should I do now? Think I go straight for a recap and send it out?
      I don't have a ton of info on how to test for HOT or flyback issues but is there anything I should rule out there before sending it for repair?
      Should I test the voltage going to the monitor? (If so where is the cable)
      Any recommendations on who I should send my chassis to if it needs repairs?
      I haven't checked for tube glow yet but I tried to look up the side while testing the door switch and I couldn't detect any light inside the cab at that level.
      As far as tube goes it does have some minor screen burn and I did open the back twice to add some convergence strips. I couldn't see any black goo while I was adding convergence strips a few months ago but they may have been some behind the heatsinc.

      I watched arcade tips youtube video on troubleshooting a playing blind arcade cabinet. I've been trying to google this issue and I've found a few articles on similar issues but haven't found a ton of info on how to test on this cabinet or solutions since many of the posts were 10 years old and they just swapped monitors or chassis. Thanks for the help. Let me know if you have questions.
    • Check the fuses first. There are two. Just unplug the cab, and pull each out with your fingers. If they're good, put them back, if they're bad, replace them with the same thing.

      If they were good, take the rear panel off, and listen from there, when you plug it in see if you hear a click, waits a few seconds, and clicks again. If so, one of the protection circuits is tripping (there are 3).

      There's a somewhat useful trouble-shooting flowchart in the manual here:
      wiki.arcadeotaku.com/images/3/…1_Service-manual_full.pdf
      On the hunt for: Dinoking, Mushiking, Love & Berry, Egret 29, Grand Am Q25, Capcom New Concept 2, and Naomi guncabs.
    • I just heard back from sharp image yesterday after sending them my chassis for recap and diagnostics. It was both caps that needed replacing and my flyback was bad. Just wanted to share in case anyone else has the same symptoms. The chassis is in the mail now but I will be sure to add to my post if I discover anything else after installing it.
    • kadrik0 wrote:

      I just heard back from sharp image yesterday after sending them my chassis for recap and diagnostics.
      Man, you got lucky. I know a bunch of people on here have had theirs sitting on Sharps' bench for literally months (and are still sitting there), and you got yours sent back in two weeks.
      On the hunt for: Dinoking, Mushiking, Love & Berry, Egret 29, Grand Am Q25, Capcom New Concept 2, and Naomi guncabs.
    • rewrite wrote:

      kadrik0 wrote:

      I just heard back from sharp image yesterday after sending them my chassis for recap and diagnostics.
      Man, you got lucky. I know a bunch of people on here have had theirs sitting on Sharps' bench for literally months (and are still sitting there), and you got yours sent back in two weeks.
      Really? I've sent them three chassis this year and all had a two week or less turnaround.

      In fact the last chassis I sent them was in the last month or two and they had it back to me recapped and with a new flyback in a week.

      Maybe those chassis that are waiting are more uncommon, or they are waiting on specific parts? They are always easy to get in touch with on the phone too.
    • kuze wrote:

      Really? I've sent them three chassis this year and all had a two week or less turnaround.
      That's surprising to me, my experiences and all the ones I've heard this past year have been awful. They gave up on my last one after 2+ months of "it's on the bench". And when I asked what they'd done "Replaced a ton of parts, just a ton of parts, you can see on the chassis", and it turned out they replaced like three caps and a resistor...
      On the hunt for: Dinoking, Mushiking, Love & Berry, Egret 29, Grand Am Q25, Capcom New Concept 2, and Naomi guncabs.
    • rewrite wrote:

      kuze wrote:

      Really? I've sent them three chassis this year and all had a two week or less turnaround.
      That's surprising to me, my experiences and all the ones I've heard this past year have been awful. They gave up on my last one after 2+ months of "it's on the bench". And when I asked what they'd done "Replaced a ton of parts, just a ton of parts, you can see on the chassis", and it turned out they replaced like three caps and a resistor...
      To be fair you sent them a really obscure domy 33 chassis right?

      Sucks that you had a bad experience with them though. When I first got in touch with them I found the best way was just to give their shop a call.

      The last time though I didn't reach out at all, just sent them a chassis in a box with a note on what I wanted done, they did it (including extending neck board cables for use on Windy 2, recap and new flyback) - they called me 5 days later telling me it was done, gave a short description of what they did exactly and had it back out to me the next day.

      First chassis I sent to them was a PB7534, they couldn't fix it due to bad flyback and no known replacement at the time, but they only charged me $60 and they had fully recapped it and tried swapping a few things like the HOT before making the determination. I ended up sending it to Grant because he had the flyback, he got it working on his setup but it cost me a lot of money to ship back and forth from UK and it still wouldn't work on my tube/yoke - instantly kills the HOT each time.

      Next I sent them a Yaton MS9 also from the cab group buy (Egret 2 MS9-29T), they cleaned it up great and gave it a recap, also less than two week turnaround.

      Third chassis was a broken MS2930 that I described above and put in the Windy 2.
    • kuze wrote:

      To be fair you sent them a really obscure domy 33 chassis right?
      Sure, but why lie and say they replaced a ton of parts when they definitely didn't?

      I think @8bitforlife has had 3? chassis returned to him broken, despite supposedly working at Sharp. 2930's and a 2931 iirc? Nothing as odd as mine at least.

      I've heard a couple other bad stories too. But I'm honestly glad to hear it's working out for some folks.
      On the hunt for: Dinoking, Mushiking, Love & Berry, Egret 29, Grand Am Q25, Capcom New Concept 2, and Naomi guncabs.
    • rewrite wrote:

      kuze wrote:

      To be fair you sent them a really obscure domy 33 chassis right?
      Sure, but why lie and say they replaced a ton of parts when they definitely didn't?
      I think @8bitforlife has had 3? chassis returned to him broken, despite supposedly working at Sharp. 2930's and a 2931 iirc? Nothing as odd as mine at least.

      I've heard a couple other bad stories too. But I'm honestly glad to hear it's working out for some folks.
      Dunno but yeah that sucks. My guess is they were in over their head on it, at least with stuff like the MS9 or MS293x there are service manuals or other documentation available to techs. They definitely had a hard time with the PB7534 but they were honest and told me it had to be the flyback (which was then confirmed later).

      Can't speak for anyone else, but they have been straight up, more than fair with pricing and very quick in my dealings.
    • Sharp is hit and miss with some things.

      They had two of my chassis for 3 months. I had to send them another working spare for them to get the resistor values.

      They have my Toshiba PB7534 right now, lets see how long that takes- I want them to finish that before I send them this 2931.

      Edit: They are good on actual repairs. Once of my Sanwa PFX, they brought it back from the dead with a new flyback, HOT and full caps. If you need just a recap, do it yourself or reach out to rewrite. If its a repair, send it to them.

      The post was edited 1 time, last by radiantsvgun ().

    • they still have mine and its been months. It was working before I sent it. Something just popped on it when I tried to adjust sync for moonwalker. They sent it back once but picture was all distorted and purple. Theyv had it since.
      My cabs: 2×Blast City/Egret 2/Egret 3/Windy 2/Crownin 203/ Tmnt/ Centipede upright+cocktail/ Space Invaders cocktail/Neogeo 4+6 slot BigRed/ Area51/ 2×mk3/ BigGuns Pinball/ Dkjr