Trouble Netbooting Atomiswave Games, Black Screen

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • defor wrote:

      Out of curiosity (maybe I missed it somewhere) but when changing games on the netbook device (pi or pc) the system auto resets if the game currently running is naomi... if it's an atomiswave game it seems that the system has to be manually rebooted is this simply a byproduct of not having all the naomi system handlers or something?
      N -> N and N -> A auto reset, A -> N or A -> A do not.
      It's not just the Atomiswave games, Some games will auto reset, some will not. Most do as far as I know.

      See Games that won't allow for auto reset when netbooting
    • I started tracking this in my NAOMI compatibility spreadsheet a while... Unfortunately it seems fairly inconsistent, for instance some games will auto-reset fine in attract mode but not during gameplay, or sometimes it's just a crap-shoot as to whether or not it will work with no good reason as to why it works or does not work.

      most non-AW games will auto-reset on a new game transfer if you enter test mode first. so I've simply got in the habit of doing that all the time. There are a few games where even that is problematic though.
      "Information wants to be free"
      VOOT | RFM | Kraylix V3 | FiF Jr. | KI2 | UMK3 | E29 | E29| TOTD | DDR
      Follow my projects on Instagram: instagram.com/twistedchu

      Buy my 3D Printed Parts: bit-district.com
    • Darksoft wrote:

      As plasia posted in his first post and I already anticipated, the problem is the BIOS.

      Problem Status: Using a standard Japanese G Bios solved everything. Not sure why the multibios didn't work but hey, there we go.

      Each BIOS has a different timing as the code is different and a different number of instructions are executed. Atomiswave games are programmed to run on Atomiswave BIOS with Atomiswave exact timing. They have been fixed to work with CF and with the BIOS I had in my Naomi (which was Japanese G IIRC).
      Thank you guys for posting this stuff... I had two N1's that I sourced my Bios replacements from different locations. I gave one to my best friend, and turns out it was the one that WORKED with AW games, I've been banging my head for a week trying to figure out why they won't boot.

      This has thread been useful as a sanity check on why all my AtomisWave games go black screen at boot!
    • One more interesting thing, I noticed that some of the game conversions are done by different people (obviously). In particular for example "ggx_v2p.bin" is not *tagged* by the person that fixed it to run on Naomi. It plays fine for me, no black screen issue!

      Where as an alternative example "AW - Guilty Gear Isuka.bin" we see in the header "NAOMI arcademodbios.com AWNAOMI" or in dolphinblue.bin we have a similar "-= ARCADEMODBIOS.COM =-" and "ATOMISWAVE-LOADER V1.2 (C) ARCADEMODBIOS.COM", neither of which boot for me.

      Likewise "NAOMI2FIXED VERSIO BY DARKSOFT" is in kov7spirits_Naomi2_Fixed.bin which is also not booting for me.
      I've also seen "DARKSOFT RULEZ", "** Status DUMPER v2 by Darksoft **%", and "** Status DUMPER v1 by Darksoft **%"

      I'd bet this is yet another a common thread to the ones that don't boot.

      Now here is the kicker... I noticed the first time I loaded "ggx_v2p.bin" it comes up saying I have an "EEPROM ID or VersionErr" and instructing me to go into GameTestMode.


      In doing so I was presented with some status info:
      "BACKUP ROM CLEANED", and "EEP ROM CLEANED", and instructed to press my test button twice before the game would boot.


      These strings are in the rom seemingly related to what it is doing when it cleans things up:
      USER EEPROM GET FAILD !
      USER BACKUP GET FAILD !
      USER EEPROM GET SUCCESS!
      USER BACKUP GET SUCCESS!
      USER EEPROM GET FROM BANK 0
      USER BACKUP GET FROM BANK 0
      USER EEPROM GET FROM BANK 1
      USER BACKUP GET FROM BANK 1
      USER EEPROM CLEARED!
      USER BACKUP CLEARED!
      EEPROM ID or Version Err
      Pelase Execute GameTestMode
      EEPROM / MASKROM
      ID :%6x / %x
      VER:%6d / %d
      Press any key To Start Default Setting
      BACKUPRAM ID Err
      Pelase Execute GameTestMode
      BACKUP / MASKROM

      Since seeing these messages, I've now been able to play AtomisWave games just fine. I hope that is useful to someone.
      *shrug*. I've noticed that from time to time I need to come back and repeat these steps.

      Maybe the other games hit some corrupt bytes in BACKUP / EEP ROMS and that prevents them from booting?

      The post was edited 2 times, last by Finisterre ().

    • Nice catch on it not being an actual AtomisWave game. I think the reason I had it classified as such was from trying to organize my ROMs folder. The header for that one has "NAOMI SAMMY / ARC SYSTEM WORKS" in it.

      The other GuiltyGear rom ggx15.bin has "SYSTEM_X_APP arcsystemworks" and uses ATOMISWAVE-LOADER.

      Clearly I was being lazy and just did a mv ggx* <destfolder> when I was moving things around. Now the real question is why it has magical voodoo powers to fix my Black Screen on demand. =]