Help! Sanwa 29E31S and Rodotron 666a Issue

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Help! Sanwa 29E31S and Rodotron 666a Issue

      Hi all,

      I’m hoping someone can help me out! 8)

      I’m having issues with my Sanwa 29E31S with its tri-sync chassis, which I believe to be a Rodotron 666a.

      I had an outstanding previous issue with the vertical height with 15KHz sources being too tall, but it was otherwise working until today.

      I was running Mars Matrix on the cab, when picture suddenly flickered for a split second, then went black. The relay on the chassis began to tick, about once a second.

      Now that’s all it does, completely blank screen, relay ticking approximately every second. I’ve tried both 15KHz and 31KHz input sources, and the result is the same, although I think the frequency of the relay ticks is slightly quicker with 31KHz.

      Here’s a video where the ticking of the relay can be heard (you may need to turn up the volume a touch):



      The monitor makes a hum and a feint hiss sound between each tick, nothing that sounds unusual, but it’s like it’s trying to ‘start up’, but failing, then trying again, over and over.

      Tick, hum, hiss, tick. Pause.
      Tick, hum, hiss, tick. Pause...

      Does anyone have any advice? Is this a chassis issue, or is the tube screwed? I’m hoping the former rather than the latter. I’m fine with game boards, but when it comes to monitors, I’m pretty clueless.

      I need to get it up and running, since my cabinet also serves as my main board testing rig when tinkering for our CPS2 and CPS3 projects and repairs, as well as being used by myself and my kids for playing our games! ;(
    • It is a monitor chassis issue, quite possibly something in you High Voltage circuit.

      Do not continue to power it off and on.

      You will need to discharge the tube properly, and remove the chassis.
      If you do not know how, you will need to look it up, and do it CAREFULLY!!!

      If you are not comfortable with the repairs, then you will need to send it to someone who can.

      It would have to be a rodotron/wei-ya chassis, because the 29E31S is traditionally only a VGA monitor.

      I'm unsure of all of the chassis repair techs in your area, but I believe giz10p is one of them for the UK.
    • Thanks for the reply, @bagheera369.

      Indeed, I literally only tried it once again with a 31KHz source over JVS to rule out an issue with the JAMMA loom, and again with 15KHz source in order to take the 15 seconds of video.

      Last time I spoke to Craig at Giz10p, he was no longer repairing monitors. I believe Grant (grantspain over on AO) at error24.co.uk may be able to sort it for me, so I’ll likely hit him up for some further help and advice.
    • Great to hear! Hope he can sort it out!

      me and my buddy had about 3 or 4 Wei-ya C3129’s coming through or hands and all had issues in someway or even arrived dead when bought new.
      No one we contacted would touch those pieces of crap.
      Luckily was able to fix one of the new ones but never where able so sort out the other one :(
    • I removed it and as it turns out, it’s actually a Wei-Ya 3129D chassis. It looks a lot like the Rodotron 666, so it’s probably just as shit as one too!

      Anyway, Grant has fixed it! :D

      Here’s the list of what he did:
      • Replaced bad flyback transformer, big bulge on the side of it
      • A load of caps replaced in the power supply and vertical deflection section
      • Vertical deflection IC replaced
      • Vertical size resistor replaced
      He turned it around swiftly - he received it on Monday, fixed it on Tuesday, sent it back out on Wednesday and it arrived back with me on Thursday.

      I think I need to do some pot tweaking but, even without touching anything, it’s looking nicer than it ever did before. A great result!

      I’ll try and get some pics when I get a moment.