Conversion of single layer Taito Cup Finals PCB to something else?

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • there are lots of ways to deal with power-planes,
      one is to pre-heat the top with hot air and then desolder from the under side,

      if you dont have hot air(you should as it's only €30) then desolder all the data pins with whatever method,
      then heat each power pin and lift that end of the chip out.
      then use stainless-steel needles to clear the holes out - or melt the solder from one side and use a pump on the other side.
    • I use a Hakko 808, it's a wonderful piece of tool!
      I first desolder all pins except the ones connected to Vcc or ground. I found that if I slightly lean the gun in the direction opposite to the IC I'm working on, it cleans the holes neatly.
      For the remaining pins I crank up the temperature. On some boards chips literally fall by themselves.
      Looking for:
      - faulty Hang-On, Space Harrier or Enduro Racer (2203 sound board)
      - Sega Mega-CD 1 power board
      - Super Nintendo CPU (3 needed)



      "I'd 1cc games but I have a real life."
      01010011 01000101 01000011 01010010 01000101 01010100 00100000 01001101 01000101 01001110 01010101 00100000 01000111 01010101 01011001

      The post was edited 1 time, last by Apocalypse ().

    • Back to the conversion discussion...

      I'm not sure if the full set of sounds works correctly on some games. Light Bringer seems to be missing some, which i think is to do with a slightly different address setup for the large sound roms.

      What i know so far is:

      There seems to be 4 banks for the sound roms as specified in mame. Only 2 banks seem to be used for most games (as i was mentioning before)

      Locations seems to be:

      1) 0x000000
      2) 0x400000
      3) 0x800000
      4) 0xC00000

      Most games tagged a V2 in mame seem to use banks 1 & 2. Like games Gun Lock and Elevator action and work fine. Light Bringer also uses this setup but i see a few (not many) sounds missing and it doesnt say 'Light Bringer' at the start with the logo either.

      Now on Cup Finals mame says its tagged as V1 and the banks are:

      1) 0x000000
      2) 0x600000 (half empty)

      So it looks like the hardware is defaulted for a 27c160 rom at bank 1 and a 27c800 rom at bank 2 only using the upper address part. This could possibly explain why some sounds are missing if only 1.5 banks are accessed instead of 2.

      There are 2 pals at ic locations 16 & 17 near these roms, and i have worked out that IC17 pin 14 enables the first bank rom and IC17 pin 15 enables the second bank rom. There are also 2 versions of IC17 as far as i can tell. D49-21(used on cup finals) and D53-12 (used on gun lock/light bringer boards). The only difference between these files is the addition of input 6 for both equations but using D53-12 on the cup finals board results in no sound at all.

      So my conclusion at the moment is the board must have another slight difference trace wise between the cup final single layer boards and the ray force/light bringer ones. This makes sense as i already had to do 2 other mods to it. I cant seem to work out if the addition of input 6 should be another line on this board.

      This board is labelled as K1100743A J1100313A

      Light Bringer single layer in mame is labelled as K1100746A J11--318A


      Anyway, thats all i know right now and everything else seems to work perfectly. If you want to add any info to this then please do so. Again i've written this all down for the use of others and so i don't forget what the last 20 hours of experimentation was all about!!
    • New

      I just finished swapping over the eprom, and graphics and gameplay work fine, though I get no sound... I did the address line mod already.
      Before I spend too much time diagnosing, did you have to convert the jed file for the GAL22v10? I just looked a bit, and the documentation claimed the fusemap should be compatible, but I tried both a gal22v10 and an atf22v10 and get no sound...

      Edit: Jp1 1-2 is closed for me - did you open that?

      The post was edited 1 time, last by Fluffy ().