Running Niko's 2.0 on X3 hardware

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Running Niko's 2.0 on X3 hardware

      Hello everyone!

      I've been poking against a few X3s I picked up over the past week or two. My goal is to run the multiboot on a X3 host with some games on a Chewlix for running at home.

      I imaged out the 2.0 image to a SSD, I threw it on the X3. I turned off security in the BIOS and it boots up. The ttxshell.exe said it couldn't find a com port. Tried throwing the onboard ports to what in the DOS days would be COM3 and COM4, no go. So I backed up ttxshell.exe and placed a cmd.exe in it's place. It boots to cmd.exe, yay! Except I think the motherboard drivers on the multiboot don't jive with the X3. I see when Windows loads, the USB power goes away and keyboards cease to function. The cursor is still blinking so I think the host is still alive. I realize the multiboot is for the X2.

      I realize it's embedded and lots of drivers are stripped. I don't have an X2 to boot it on. Sometimes you can boot it on the proper PC then if the target motherboard installer allows you can run the target mobo driver installer and install the needed drivers -- then move the board over. I've had success with that on games like GVR Need For Speed Underground and Aliens Extermination. Some motherboard driver bundles will refuse to run.

      I can execute things against the original hard drive in the system using psexec and all that, and launch cmd.exe. That works fine, but I'm terrified of having a system where hard disk failure leads to forever failure. Would be cool if someone could figure out a way to extract the SATA key (if anyone wants the bios from my machine I desoldered it, dumped it and put it back.)

      Next question. Is there a dump of a X3 hard drive that isn't encrypted to build a multiboot off of? I was thinking if I could figure out a way to image off the running windows image (Lord of Vermillion IV) to another disk then image that back to an unprotected disk, then remove all of the game content it would give me a starting point. But I don't know of a linux equiv to dd for windows, nor something that could power through files that are open for writing and such?
    • Progress report!

      Okay, so I took the LOV IV hard drive... I managed to image the encrypted drive off to a file using a windows clone of the dd utility from linux.
      From there I re-wrote the image to a standard non-locked disk.

      That image totally boots on the X3 with the security turned off! Windows boot screen in Japanese, looks so cool. The actual game executable itself blue screens with an error code. Who cares.

      Next step, I deleted the game data, game and have tried taking the bits from the current Niko's 2.0 multi image and copied them onto the drive. I wasn't able to update the registry pointer to the first run command (I know that is mentioned somewhere which key pair does that.) I threw cmd.exe in place of the normal boot program in the root of C: for the time being and cd over to the ttxmulti and execute it from there. It just returns to prompt?

      So far haven't gotten the ttxmulti to work yet. Not sure if there are DLL's from the system directories that are needed, or the fact that I haven't really populated all the game data directories yet.

      This is going to seem odd, but I'm more of a pinball / classic arcade guy / some music rhythmn and just dipping my foot into the candy land. Love the graphics on the more modern HD games but am not good at fighters.

      There does seem to be a watchdog action where the system gets rebooted automatically after 30 minutes or so, will have to look at that later.