CPS3 Darksoft Setup Not Booting

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • CPS3 Darksoft Setup Not Booting

      Greetings,

      I purchased a CPS3 Darksoft setup a few years back and finally got around to hooking it up in my Sega New Net City (I moved right after purchase and 'lost it' during the move).

      I'm using a Namco JVS/Jamma converter in the cab that works fine with my Darksoft CPS2 setup.

      However, it appears that I'm not getting power to the CD-Rom Unit. Unfortunately I don't have a multi-meter to check the voltage, but I'm guessing that's the issue. Needless to say I basically get a white garbage looking screen when powering up.

      I guess my question is what would be the best route to fix this? Should I investigate getting it converted to a no CD setup? Buy a separate PSU?

      Any help or advice would be greatly appreciated.

      Thanks!
    • Reseat the cart, even without power to the CDROM you should still see the menu/checking disc screen.
      Darksoft/Apocalypse: CPS2, CPS3, F3-β, MVS, S16-β
      RGB: RECO v2
      invzim: Jammafier v1.6b
      XianXi: JNX Raiden, SC Taito Classic, SC Sega System 16/24, Namco System 11/12 KHA
      Frank_fjs: JAMMA Extender (Special HAS Edition)
    • OldSchoolNeo wrote:

      when all else fails clean the cartridge contacts
      With CPS3 its more like... At first fail, clean/reseat the cartridge.
      Because that's almost always what the issue is.
      Darksoft/Apocalypse: CPS2, CPS3, F3-β, MVS, S16-β
      RGB: RECO v2
      invzim: Jammafier v1.6b
      XianXi: JNX Raiden, SC Taito Classic, SC Sega System 16/24, Namco System 11/12 KHA
      Frank_fjs: JAMMA Extender (Special HAS Edition)