Multi now not working FIXED (Mac ISSUE)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Multi now not working FIXED (Mac ISSUE)

      Like a crazy fool I opened up the CPS2 case to replace the lcd screen cable with a short one - and to also update the puzzle fighter rom and now the kit is not working at all, either I get a white screen on my astro, or black screen on my supergun, although sometimes i get that picture which has some horizontal blck lines across it.

      My set up;
      ex- pheonixed gem fighter, with jumper config changed with my poor soldering :- I checked continuity today and this was still fine.

      SD card named CPS2 formatted FAT32 with games folder that contained that new roll-out package. - I'm on a Mac, so I made sure that garbage files were deleted in the directory.

      After this failed to work, I thought I would try the prevoius standard package of Roms again, with only 1 thing that was changed, i replaced the puzzle fighter games with the one that was updated.

      Again this shows no difference at all, I don't get garbled picture, - where there is a connection issue.

      I have checked that the pins are all nicely seated between the boards, and all looks good.

      The green power light illuminates, and the lcd tells me whatever game is loaded up - i did load up a couple of other games just to see.

      It seems like the board is completely dead somehow. I have another couple of CPS2 B Boards and have tried it with the A board that I am using and they work fine (admittedly I have to re-seat each B Board at least once).

      So all i really amended were the contents of the SD card, and removed the old long LCD harness to the short one, and I was careful removing this.

      I'm at a loss as to why this has gone the blink again. I had problems previously, and when I finally got it working I swore never to touch it again ...

      Is there anything not obvious that could be causing an issue?
    • Spent some more time with it today.

      I reformatted the sd card and wiped the garbage files (Mac).

      All the boards are down tight.

      Tested the A Board with two other games.

      Shorted out EX5.

      - Still nothing but a blank screen.

      The strange thing was that the only thing I did from when it was working was remove the lcd lead and reformat the sd card. Really am at a loss as to why this thing is dead.
    • Have you removed the battery? Let it sit for a couple hours without you power it up so the battery capacitors discharge (or short circuit them yourself to kill the encryption data).

      It's plausible that "accidentally" upload random data to the encryption hardware can happen if the board is powered on and is being manipulated while the CPS2Multi is uploading a game (due to it holding the system reset low, which is one of the enables for the encryption programming port).
      If a pullup resistor at the encryption data upload port is damaged the input can be left floating and it may "pick" random noise as data and store it, making the possibility of a accidental encryption programming (with useless random data) more likely to happen. And that will prevent the board from operating properly with the MULTI.

      If your problem has to do with this, discharging the encryption will "revive" it since if there's anything programmed on the encryption/security, decrypted ROMs won't be able to boot...
    • Hi,

      I did just that earlier because not all of the pins were in all the way on that little board, so I loosened it all up, took off the bridge board and re-seated it all.

      I still notice that not all of the pins are 100% in - but they can't go in any further - no matter how hard I press one side you can still see the metal pins by about a mm.

      Again, the whole setup used to work, as it was and all i did was remove the lead.

      Here is a pic of the orientation of the boards;



      Here is a pic showing some metal on the pins on one side exposed;
    • I had a similar issue after using my mac to update my SD card to latest 1.41 pack from SomkeMonster. I erased all the files, uncompressed the 7z pack and moved the files to the card. Everything went OK, but when using the multigame, every game I flashed would produce only a red screen. It would also flash very fast (like only 12-15 seconds). I tried again, same problem. Finally I formatted the card and copied the games a 3rd time using a Windows 7 laptop, everything worked fine. Might be worth a shot.
    • bloodhokuto wrote:

      Yeah, given that nothing else seems to fit the bill.

      I formatted the card with FAT32.
      SD Card named 'CPS2'
      Games in 1 folder called 'games'.
      I used terminal to get rid of the junk files OS X puts in and then ejected.

      But I don't think I went wrong with the above.
      The problem is probably OS X
      SmokeMonster Patreon
      YouTube | Twitter | Twitch

      Darksoft: CPS2, STV, MVS
      Supergun: HAS
      PVMs: 2030, 1944Q, 3 x 8041Q
      PCBs: 50ish | Sticks: 50ish

    • So top dude Wigsplitta sent me over a pre-tested SD Card and the damn thing started working again. :D

      I still have to tweak the connections a bit, and I am going to use a better A Board, but it's clear that there was an issue with the SD Card after I formatted it on Mac OS.

      My original card was also formatted on my Mac, but that was when I was using the Snow Leopard OS.

      My current Mac has Yosemite 10.10.5 and I believe that the terminal prompt I was using to clear the card of 'junk' files that Mac likes to put on anything writable works no longer.

      Anyway really chuffed that the multi is working again.

    • I have boot camp on an old Macbook, but the problem is that it is very old and creaky and only ran Win XP (Very poorly). I did in fact try using this boot camp setup for the CPS3sd PCB, but that didn't go very well.

      Unfortunately I only have Macs, but I might have to get an up to date Boot Camp set up on my newer machines / try bottling methods for the windows programs / pick up a windows equivalent of the Mac mini to do Win PC stuff.