Deathsmiles 2

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Deathsmiles 2

      Does anyone know how to get Deathsmiles 2 working on Niko's Type X2 Multi? It is literally the only thing I'm missing (I can live without Jonestown) now that I've moved from the ArcadeModBios Multi to Niko's Freeware TTX2 Multi. I'm currently happy as a pig in poop playing around with all the new games, the game videos and of course emulators (without having to manually delete and replace a file on the multi every single time I want to play Wizball), but this one small thing is niggling at me. It burns.

      So, if there's any help or wisdom out there I'd be much obliged!
    • Urabutbl wrote:

      Does anyone know how to get Deathsmiles 2 working on Niko's Type X2 Multi? It is literally the only thing I'm missing (I can live without Jonestown) now that I've moved from the ArcadeModBios Multi to Niko's Freeware TTX2 Multi. I'm currently happy as a pig in poop playing around with all the new games, the game videos and of course emulators (without having to manually delete and replace a file on the multi every single time I want to play Wizball), but this one small thing is niggling at me. It burns.

      So, if there's any help or wisdom out there I'd be much obliged!
      I'm just curious here, what emulators are you running along with the multi and is there a tutorial out there to get them running?
    • ekorz wrote:

      It's not supported but I'm pretty sure you can get it running. try turning off the "GameExit" feature before you launch it
      Ah! Thank you! That did get it running, however the inputs won't work. I read in another thread about putting a "config-file" that set JVS to yes in the Deathsmiles2-directory (E:\DeathSmiles2\TypeXMulti), so I copied the exact same structure from one of the other games that had this. Any ideas what's wrong? The most obvious one is that the version of Deathsmiles I have is the "wrong" one, but the fact that it starts at all belies this somewhat...

      Geddon wrote:

      I'm just curious here, what emulators are you running along with the multi and is there a tutorial out there to get them running?
      I'm just at the start as I got Niko's Multi up and running just yesterday. At the moment I'm using @Sjlewis78 and @Dreygor's setup for MAME which can be found over at Mame for Taito Type X2 on Niko's v1.4 multi, which works great.

      However, I've also started experimenting with Winuae and Glaunch to see if I can get them to run in Niko's Multi. Many years ago I managed to get the ArcadeModBios-multi to launch Vice64, Nesticle etcetc by using Glaunch as a go-between, so if I can only get it working on Nikos, I should be golden. No idea how it'll go but I'll put up a thread as soon as something works!
    • I just checked on the 2.0 hard drive and yes the game either does not work on or starts but you can't do anything because buttons are not responsive to anything.
      I just copied my game from my 1.4 drive to the 2.0 one and it is working on the 1.4.

      However, if you launch the game from the AM, then it works, however, you won't be able to exit the game, even by using the test menu exit option.
      Also, if you disable the "exit game" option, then the game launches and is playable, but like when using AM, there are no ways to exit the game then after.

      The post was edited 4 times, last by Mackie ().

    • New

      I've tried it with and without patches and game exit feature, but it sadly doesn't help. My latest theory is based on the fact that most of the versions of Deathsmiles2 floating around seem to have been modified using a program called "DS2_Loader", or need to be modified with it; without it, the keybindings in the game are all set to null. I did an experiment where I set the coin to "1" and then transferred that game to the multi; starts fine, and if I press "1" on a connected keyboard, I get a credit!

      Theoretically, this means I could set the game's keybindings on my PC to whatever the JVS outputs, launch it once, and then transfer the game to my multi. However, this means I need to know what "buttons" the TTX2 thinks my JVS is outputting... and I have no idea (nothing happens if i press buttons while in command prompt on the TTX2).

      I guess I'll have to keep experimenting... unless some kind soul sent me a copy of Deathsmiles2 they KNOW work on the multi. (hint. hinthinthint).
    • New

      Urabutbl wrote:

      Hmm, when you say it works "when launched from the AM", what do you mean by that?
      If I use the Attract Mode that was originally designed for the 1.4 image, then it works.
      The issue with Attract Mode on the 2.0 image is that it switch to low resolution once you exited any games.

      I gave up for now with ttx2 until I know more about the system and underlying running stuffs so I can eventually work on something that handles everything properly on my machine.