X2 BSOD after splash

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • X2 BSOD after splash

      Hi there I just acquired an X2. Here is a link to some images of the BSOD and replacement graphics card that are referenced in this post imgur.com/a/ywwljmi
      No HHD
      -7900 GS card
      -1 gig of ram
      -the case says it has a P4 cpu but I have not lifted up the heat sink yet to verify
      -looks to have the jamma labeled usb out and dip board
      -I have this running to a chewlix cab with a capcom io, the io is powered by some generic PSU in the chewlix
      -dip switches 1, 2, and 5 on. have toggled them and the results below don't seem to care about the setting
      -taito fast io board?? with rj45 connectors
      -motherboard revision .01B

      I have set up two different hdds with the TGM3 image that is shared in the sticky. I've also tried this with the multi image that contains no games. The results don't seem to care which hdd/ssd or image I use. The disks are prepared with hdd raw copy tool.

      Starting it with no hdd attached I get
      gladiac text -> single loud beep -> taito splash - > OS not found
      this makes sense to me

      with the hdd
      gladiac text -> single loud beep -> taito splash - > BSOD (fault in nonpaged area)

      with the hdd but with the fast io pulled
      gladiac text -> single loud beep -> taito splash - > hangs on black screen for ~ 5 minutes -> BSOD (nv4_disp)

      with ram pulled I get beep codes
      with 7900 pulled I get beep codes as well

      Tried different sticks of 800 MHz ddr2 ram and also different slots on the mobo

      Has anyone encountered something like this before? I saw a few threads where people say they just had to clean the PCIE card slots but that didn't seem to help me. I'm also a bit confused by the fast io board seemingly causing a ruckus.
      I'm going to try flashing a "new" 7900GS using the guide that Niko has shared :thumbsup: Should I expect issues since the card I've bought only has 256MB of VRAM compared to the 512MB that is typically in the stock 7900? Hopefully this will solve my issues.

      Thanks much

      EDIT:
      so I replaced the nv4_disp.dll file that was originally unpacked on the ssd with one I downloaded from here personalcomputerfixes.com/step…e-the-nv4_disp-dll-error/
      The system now behaves the same with or without the fast io.
      The TGM image boots up to this imgur.com/a/cOiL08L this window frame will go back and forth between full screen and being at the bottom of the task bar.
      The multi boots up and says that no games are installed (I havn't put any on there yet), but the vertical blue lines that can be seen in the above photo are present still.

      EDIT2:
      flashing the replacement 7900 graphics card did the trick for me everything is working great with the stock images, no need to putz with the drivers like I did above.
      I did try and reflash the card that came in my unit originally and the display had some weird artifacts/glitches throughout the flashing procedure so that was another pretty good indicator that it was borked.

      The post was edited 2 times, last by snakeGrave ().