Faulty Type X 2 - Need Advice!!

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Faulty Type X 2 - Need Advice!!

      I've got a Type X 2 that has an issue. I'll write the chain of events below.

      - Type X 2 arrives in working order, bit dirty inside. I remove the cpu heatsink to check thermal grease, it's solid.. I built pc's/server for 15 years for a living so i have some experience in this space, and I know these old P4 chips ran pretty hot. I decide i'll take it apart, give it a clean and redo the thermal grease.
      - I disassemble the whole TTX2 system and give it a clean. It's not too dirty, no bulging caps at all, even inside the PSU. I give it a light dusting, case a wipedown and put it back toghether... taking extra care, i even wore the ground strap whilst doing this...

      - ISSUE STARTS HERE... After i put it all back together and turn it on, it does this. POWER ON for 1 second, fans all spin up, POWER OFF. It just repeats this process. Power on, fans spin up, then power off. I remove the video card, the ram, the IO to see if it makes any difference NO difference. Can't make it change behaviour regardless of what's plugged in.
      - Try another ATX PSU to make sure it's not that. Brand new ATX psu does exactly the same thing... hmmm.

      OK, so i took the whole system apart and stuffed around for a few hours, using all my years of big brain hair pulling, frustrating troubleshooting experience... i've come up with this.

      When the TTX2 is stuck in the POWER ON, POWER OFF, POWER ON loop, I can get it to boot again properly by removing the cpu, booting the machine without cpu in the machine (this fixes the boot looping), and then re-installing the cpu. The machine will now boot normal. HOWEVER... I can't screw on the heatsink. I can only sit the heatsink on there. As soon as I screw on the heatsink, it starts the boot loop again. POWER ON, POWER OFF... I can replicate this every time. Once it starts boot looping, the ONLY way i can get it out of this loop is to remove the cpu, boot the system without the cpu in the system, and then reinstall the cpu. Works every time.

      I thought there might be a problem with the bracket on the bottom of the LGA775 slot, maybe shorting, so i created a thin cardboard sheet to go between just to see if that was it... nope. As soon as i start to screw the heatsink down, it starts the boot loop again. Even if i just do it a very slight amount.

      More testing, I can also trigger the boot loop now just by applying a small amount of force to the top of the CPU heatsink when its not screwed down.

      Ok, so i've basically got to this point. I now know that any force on top of the cpu will basically make the machine boot loop. The force i'm applying on the heat sink by hand to trigger boot looping is nothing compared to the force that will be applied when the heatsink is screwed on.

      It's not the cpu pins in the socket.. well they're not bent or damaged at all, they're perfect. There's nothing visually wrong with the CPU either. If I just sit the heat sink on top of the cpu, no screw down, and no force, the system works perfectly. I played on it for about 30 minutes and it works fine. Just can't screw down the heat sink or apply force.
      I tried applying force around other areas of the board close by and I can't trigger the boot loop...

      SO... this is where I need advice from people more knowledgeable... what do you think it might be? What are my next steps here.

      Cold solder joints (there's very little things I can reflow solder around that area)? Is this an xbox 360 GPU style issue where I need to bake the motherboard in the oven! The board is in really good condition, it hasn't had a hard life, but some of the solder joints look a tiny bit cold on the IO ports, but this is nowhere near the CPU.

      The only thing I can see that is remotely wrong is that the bracket that sits on top of the cpu that you clip in, is slightly bent. I don't have any other LGA 775 parts here to check, but i'm pretty sure this is not supposed to be bowed like this. I haven't attempted to bend it back yet. Can anyone check their TTX2 or LGA 775 socket MB for me and let me know if their bracket is boxed like this one in this pic?

    • Ok, so i went out and got myself one of these.



      I've never owned one of these, and it's not really the right tool for the job i don't think.... I was sort of inspired by this youtube video.



      He replaces a cpu socket... now i don't know what tool he is using to desolder, but it looks definitely like the right one for the job!

      So.. i'm 99% sure there is a broken or cold solder joint on or near the cpu socket and when you have tighten the heat sink up, it flexes the board and socket and causes the issue, which has the symptom of rebooting.


      I tried to heat up the board at 300 celcius... nothing really seemed to happen. So I went straight to the tools max of 500 celcius. Ok... so now im moving the heat wand around the socket, trying not to keep it in one spot too long to melt the plastic, and i get the board really hot and i see the plastic starts to burn a tiny bit, so i stopped... It's a little tricky because the socket i need to heat up is probably 10 times larger than the area the heat is coming out of my wand from.

      Put it all back together and it's MUCH better now. I can put the heat sink on and it works ok, i can still trigger the fault if I push on the heat sink, but at least i can put all the board back together now and play it fine, so long as i dont push down on the heat sink it works.

      Maybe the fault was already there before i removed it from the case, it just hadn't made itself evident yet. So, i'm going with cold or broken solder joint on the cpu socket which is agitated by the flex the heatsink and the underplate for it puts on the cpu.

      It's not perfect, but at least i can use it, will definitely hurt resale value if i ever decide to sell it, but it's ok, i'm more happy to be able to play it!
    • New

      I suggest you buy a new motherboard, this motherboard is made by Toshiba, it may be a little expensive, you can't fix it, I have a motherboard that is not bright, because oxidation caused a failure over a long time, I tried to fix it, and replaced the Nanqiao chip, still no power, there is no way I threw it into the trash can, and re-bought a Konami the same motherboard installed on, everything is normal!