Multikit install questions

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Multikit install questions

      New

      I have a couple of questions regarding installing the DS CPS2 Multikit.

      Rev 6 B Board, Marvel Vs Capcom, G PAL already installed on board (I also ordered one from highscoresaves but didn't install it yet).

      1. In the install guide PDF on highscoresaves, the guide says leave the solder jumpers alone. But, in a video I found regarding installation, it has a section in which it shows jumpers being reviewed and changed. If I look at the legend for which jumpers are to be shorted and which ones are open, they don't match up for what I have on my board in sections JP5 and JP6 nor at positions JP8-13. All the other positions match. Do I need to change them on my board to what the video shows (Mitsurigi's install video) or leave them as is as suggested by the PDF file?

      2. Do I need to use the kit's G-PAL, or, can I leave in the existing one?

      3. Do any of the G-PAL pins need to be lifted to use the multi kit with the Rev 6? I am thinking no based on what I read, but, want to make sure.

      4. Do the key writing wires have to be installed? If no, which ROM set do I use? If Yes, which do I use?

      What I've done so far: Installed it all, used smokemonster's roll up pack, and the SD card I bought with the kit. I didn't use the new G-PAL because my board has one, but, can change it out if needed. Also, I didn't change any jumpers (as per the manual). There's no battery on the board, and, before hooking it up to any power source (supergun), I shorted out the three pins on EXC5 to clear out any residual keyfile.

      I fired it up, and had the Multikit execute a flash, which succeeded, of SFA3. However, the system does not reboot, and I need to manually turn it off and then back on a few seconds later. I have gotten black screens, orange, white, pink, etc., but no game loads. I triple checked all the pins to make sure everything was in contact and they are. The bridgeboard is installed properly as well (albeit by the hardest. why not a ribbon able instead?). I tried reflashing with a different game, same result.

      Any suggestions on where to start?
    • New

      The video is old, ignore it. Leave your jumpers alone!

      your existing g pal is fine, so is the new one. Same chip same code. Either way don’t lift any pins

      The rest sounds like keywriting wire issues. Or basically that you didn’t install them.. They trigger reset as well. You don’t have to use them but you’d need the old rom set. Try any hack rom like MvsC-all-characters, they use no key file and should boot even if you have no wires installed. You’d have to reset manually.

      this does make it simpler CPS2 Multi Key Writing Quick Solder Board

      For future reference:
      The Definitive Guide to Fixing Your CPS2 Multi Kit
      cabs: sega blast city x2 | taito vewlix c + egret ii
      links: klov/vaps games list | custom fight sticks
      working on: organizing stuff

      The post was edited 1 time, last by ekorz ().

    • New

      Thanks. I have the quick solder board ordered already after having seen it in another thread here last week. I got shipping notification for it yesterday, so, hopefully in the next couple of days it will arrive. In the meantime, I'll try one of those hack ROMs and see what happens.

      I will mention one random thing... it took me nearly an hour to carefully remove all the ROMs from the B-board. I've never encountered dual wipe sockets like this with a near death-grip on the ICs. I was wondering if CAPCOM used some ultra-high quality sockets and this is normal for these boards, or this is an anomaly on my part. I usually use a plastic "spudger" tool between the socket and the IC and advance it slowly and it easily "unzips" the chip from the socket within seconds (I find this method gives me better control versus using a DIP IC puller). Is this normal for these boards?
    • New

      Got home and tried a hacked ROM (boss character unlock SFA3). Flash completes, then I reset the board, but I get a black screen (or sometimes a green one). So, I unseated the kit, cleaned all sockets, and then reseated the kit. I checked continuity with a multimeter by placing one probe on top of the DS kit boards and the other probe on the corresponding solder tail pin of the socket on the underside of the B board. Everything is in contact. Tried again, flash completes, but still a black screen. Any other suggestions? Tagging @Darksoft and @Mitsurugi-w
    • New

      Upload some high res photos to imgur or something, we can take a look. A lot of the time folks install the interconnect board backwards or don’t seat it firmly enough. Sometimes they don’t seat the whole multi firmly either. We can see from photos if you show those angles
      cabs: sega blast city x2 | taito vewlix c + egret ii
      links: klov/vaps games list | custom fight sticks
      working on: organizing stuff
    • New

      Link to images on imgur. The plastic shoulders of each of the pin strips in the small PCB are fully in contact with the edges of the sockets. The Pins cannot be pushed in any further. Once again, I verified continuity on every single pin on the top of each Darksoft board with the B-board's socket soldertails on the underside of of the B board. Maybe I am STILL using the wrong ROMs.
      Should I be using
      The Darksoft OLD DECRYPTED files on the archive.org Smokemonster Roll Up?

      imgur.com/a/xhHpVvU

      The post was edited 2 times, last by obitus1990 ().

    • New

      Yes, I read through the recommended post 3x. The SD card is the one sent to me with the Darksoft kit from Highscoresaves.com, so I assume it to be correct. It is a SanDisk Edge 8 GB MicroSD HC-I Class 4 card. I use a Mac and I used the dot_clean command to eliminate all the index files that MacOS creates.
    • New

      If it’s not booting the program code just isn’t running right.

      I run the key wires so I’m not 100% sure how the old and new rom packs behave. The newest firmware is expecting the directory to have a key file, I think. The decrypted games are just blank keys.. 16 bytes of FF or something like that. If you’re using the old pack, I guess make sure that those key files are still in there even though they’re blank.

      The multi should say something like “writing game” then “writing key” and it just won’t work with an encrypted game. But it should load something like MvsC character unlock (or any game where the key file is that empty string of 16 bytes FF). You could check your card to make sure you’re trying a game with that empty key.

      Maybe @xodaraP remembers, he fixes a lot of these

      I also avoid Mac at all cost so I’m not sure of the dotclean rules. Maybe you have to run it every time you put the card it your computer
      cabs: sega blast city x2 | taito vewlix c + egret ii
      links: klov/vaps games list | custom fight sticks
      working on: organizing stuff
    • New

      I went ahead and reformatted the card on my PC and copied over one of the games I had tried before into the newly formatted SD. Now, after inserting it into the Multi, it works. I didn't format the card on the Mac, it came pre-formatted, so I thought it would all be good, and, even issuing an "sudo ls -lisa" in terminal in the root of the card and all subdirectories didn't reveal any more index files. Weird. Like you say, Mac is a pain in the ass with these things.
    • New

      I'd play if I could...I don't have any NeoGeo controllers to use with my supergun, so, I am awaiting arrival of the NeoGeo to PSX converter from France. Also, parts for me to build my kick harness are stuck somewhere in USPS hell...they arrived at the New Orleans post office 7 days ago and haven't moved since then. It'll be a while, sadly, before I get to play on it, it seems. :( But, at least it's working now :)
    • New

      Frank_fjs wrote:

      Save yourself some time and order PSX to Neo adapters from @Arthrimus now.

      That way, when the Retroelektronic ones from France arrive and you discover that they don't work, you'll have a headstart on working ones being on their way to you.
      Well, crap... I had asked Low_Budget, the creator of the Parsec supergun, if those adapters were compatible/worked with his supergun and he said yes. $50 wasted then on two of them :(

      @Frank_fjs Where does he sell them (not seeing a PSX to NEO adapter over on his website)?

      The post was edited 1 time, last by obitus1990 ().

    • New

      Hopefully your experience is better but I have 2 of them that don't work and another friend, @evilsim had the exact same experience.

      I also have their Mega Drive and Snes adapters. One of the two Mega Drive adapters doesn't work either.

      Really poorly designed and assembled products. No response or offer to rectify from the seller either.

      The silver lining is that their horrible products inspired me to learn to make my own. :)
    • New

      My PSX adapter is not for sale on my website at the moment, but I do have the parts on hand to assemble a couple if anyone needs them. PM me if you are interested @obitus1990
      plus ça change,
      plus c'est la même chose,
      The more that things change,
      The more they stay the same.- RUSH- Circumstances
    • New

      The retrotronik ones arrived today... and yep, they're problematic. I have the brand new, version 3 PCB that allows for custom mapping of the buttons, which I have done successfully, but no matter what, button 5, which I map to be the MEDIUM KICK button on the CPS2 fighting games, both KICKS and adds a coin every time. I wired up a kick harness and enabled buttons 4, 5 & 6 on my Parsec supergun and connected it to the A board. I notice that when I put the PCB into system test mode, and check the controllers, HARD KICK is always activated even if I do not press button 6, as well. I am using it with an original SONY PSX controller (no analog sticks, no dual shock).