[Repair log] Random reset, black screen on start up - TRIFORCE III

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • winteriscoming wrote:

      I bought a Triforce listed as broken on eBay. It was listed with this description:

      eBay seller wrote:

      when tested triforce picture comes up then screen goes black and will not load game
      I got it today and it booted and had boot screen audio, but video wouldn't sync well in spite of filter board DIP switches set correctly, and there where black bars in the video. I didn't leave it on very long in this state, but it once faded to black completely.

      I tore it apart, recapped the baseboard and crossed my fingers...

      I'm very happy to report that this process has resurrected yet another Triforce for me!

      I'll be replacing the noisy case fan, but otherwise not bad at all for $150 shipped. My cheapest type 3 so far, and I didn't have to source it from Japan. :thumbsup:
      Sigh....if all PCB repairs could be fixed with a cap kit.... Nice work Boss!
      Arcade Multi Systems:
      • Sega: ST-V, Naomi w/Net Dimm, Naomi w/CF Boot (DIY and OG versions), Taito: G Net, Taito F3, Taito Type X², Capcom CPS2, Capcom CPS3, Neo Geo MVS 4-Slot
      Favorite Arcade Genres (in order):
      • Fighting games, Shmups, Light-gun, Puzzlers, Driving
    • An arcade piece of equipment has much longer working hours than a domestic one.
      During operation, internal temperatures become higher and components age faster.
      Triiforce is gamecube period hardware, the wii is more recent.

      I shouldn't worry to much about replacing capacitors in wii's anytime soon.

      If your smd components explode during soldering, you should worry about your soldering techniques.
    • i know about arcade machine hours - i used to work them!!

      nothing wring with my soldering, just smd cans filled with liquid is poor design.
      i dont know a single pro-engineer that flows them off the board, they use methods from soldering tweezers, to twisting off or using flush-cutters.

      there are boards where you simply dont have the clearance for those methods though.
    • I admit this last time when I was pulling caps that I pulled off some pads on the first 2 that I pulled - having forgotten the method... :(

      The key is not to pry at the caps, but twist them in place until the legs come out of the cap body. It was mentioned in the original post, but it's worth repeating.

      Prying rips the pads right off with almost no effort, so don't do it. Don't even rock the caps back and forth. Only twist back and forth laterally until the legs break free. It doesn't take long, and the legs and plastic piece are left behind. Don't pry at the leftover plastic piece, either! After twisting all the caps off, I followed up with snips to either snip the legs down to where the plastic could slide off, or snip the plastic and break it apart around the legs so it can be removed. Then I followed up with solder and iron to both remove the legs and tin the pads a little heavier for the legs on the new through hole caps.

      If a pad gets completely ripped off, then you'll have to expose copper from the connecting trace with a small file and make a new solder point. It's worth checking if the ripped pad goes to ground because there would be a lot of other potential points to tie into.
    • Thanks for this hoping recapping the base board will solve my issue with Mario Kart. Fires up in morning, game runs and sound ok but after 15 mins or so video goes off (no signal). Off / on doesn't resolve video issue although sound & game running. Switch machine off for 24 hours and video comes on again for about 15 minutes then black screen again. Will post if re capping resolves the issue.

      Aha - resolved but not by recapping. Fault turned out to be broken ribbon cable out of baseboard.

      The post was edited 1 time, last by lineb ().