Installing the multi on a rev 3 board missing sockets

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Installing the multi on a rev 3 board missing sockets

      I've had the multi since day one and was excited when I remembered that I had a phoenixed Super SF2 (rev 3) board that I could use without have to track down a dead B board. As soon as I checked it, though, I noticed that the CN6 header was missing, as discussed here.

      I finally got around to getting a DIN 41612 connector to install at CN6 recently, and then noticed several more missing sockets. I installed sockets where needed and got everything setup and ready to go.

      Not much to say, but I wanted to post this in case anyone else has a board like this and is wondering if anything can be done as I've seen a few people have trouble and opt to find other boards. I did have some graphical issues at first, but it seems to have simply been loose connections between the A and B boards.

      Missing sockets are circled below. The multi doesn't use all pins for 8-12, so you can use smaller sockets in most cases, if you have them. I used 24 pin sockets for 11 and 12 (24 pin is required for one - 11 I think, but something smaller could be used for the other), 28 pin sockets for 8 and 9 (though you could use as little as a 4 pin socket IIRC), and a full 40 pin is needed for 10.





      New sockets installed:



      Multi installed (not shown: lifted pin 9 on PAL3):

      The post was edited 1 time, last by Mattroid: Added link to the connector I bought as I've had a few people ask over the years. ().

    • Top notch job. I can already imagine what a PITA should have been installing that CN6, wasn't it? All those pins perfectly aligned? Any trick about how you did it that you can share with us?
      * Arcade-projects, the site where you get the most of your arcade games.
      * If you want Drama go to Neo-Geo forum ---Darksoft
    • Darksoft wrote:

      Top notch job. I can already imagine what a PITA should have been installing that CN6, wasn't it? All those pins perfectly aligned? Any trick about how you did it that you can share with us?
      It wasn't nearly as bad I imagined it would be, honestly. Nothing terribly specific to mention, but I will say a good desoldering gun, a magnifying lamp, and a fine soldering tip REALLY help speed the process along. I'm not sure that I could have done as good of a job without the magnifier lamp.
    • Mattroid wrote:

      Darksoft wrote:

      Top notch job. I can already imagine what a PITA should have been installing that CN6, wasn't it? All those pins perfectly aligned? Any trick about how you did it that you can share with us?
      It wasn't nearly as bad I imagined it would be, honestly. Nothing terribly specific to mention, but I will say a good desoldering gun, a magnifying lamp, and a fine soldering tip REALLY help speed the process along. I'm not sure that I could have done as good of a job without the magnifier lamp.
      Did you insert the pins one by one? Did you first remove the solder from the holes?
      * Arcade-projects, the site where you get the most of your arcade games.
      * If you want Drama go to Neo-Geo forum ---Darksoft
    • Darksoft wrote:

      Did you insert the pins one by one? Did you first remove the solder from the holes?
      I first removed the solder from the holes. That's where the desoldering gun came into play (I just recently got a Hakko FR300 - I've been waiting to get one to really take this project on). One by one would have definitely been a huge PITA. Once the solder was removed, getting the header in place was easy.
    • Darksoft wrote:

      Top notch job.

      kuze wrote:

      Nice work there, looks very clean.
      Thanks, guys. I have to admit I was surprised to see it work pretty much on the first try. I was fully expecting to have issues that would take some time to figure out but so far so good :)
    • Mattroid wrote:

      Darksoft wrote:

      Top notch job.

      kuze wrote:

      Nice work there, looks very clean.
      Thanks, guys. I have to admit I was surprised to see it work pretty much on the first try. I was fully expecting to have issues that would take some time to figure out but so far so good :)
      I guess your skilss are better than you expected :thumbup:
      * Arcade-projects, the site where you get the most of your arcade games.
      * If you want Drama go to Neo-Geo forum ---Darksoft
    • Darksoft wrote:

      Mattroid wrote:

      Darksoft wrote:

      Top notch job.

      kuze wrote:

      Nice work there, looks very clean.
      Thanks, guys. I have to admit I was surprised to see it work pretty much on the first try. I was fully expecting to have issues that would take some time to figure out but so far so good :)
      I guess your skilss are better than you expected :thumbup:
      So the board is a regular board, except that capcom were too cheap to include the full sockets? good to know.
    • Great info, thanks for posting this !
      I have a rev 3 board and I though I would be stuck because of the lack of CN6 ! Thanks to your info I did order a DIN41612 with 96 pins straight to be able to connect the MultiCPS2 ! I think I'll use an air soldering gun to install the connector instead of removing the solder from the 96 holes :P
    • Just a word to tell that I tried to use hot air station to install the 96 pins connector but it was hard (for me at least) to get the whole surface hot enough and get all the 96 pins correctly aligned to fit correctly ! Moreover even with everything around protected with kapton, you can't make things hot for a too long time ... Maybe that if you have what you need to keep the board horizontally to allow to use flux and use protection gloves to make sure you don't burn your hand when trying to install the connector from behind, it's possible, but on my side I had to gave up before making some damages on the board :S
      So I had to remove the solder from all the 96 holes one by one :D
      Without counting the solder to remove for installing the other sockets ! It took me few hours to get everything in place, but now I can enjoy my multiCPS2 :) Thanks for all the information available here :thumbsup:

      The post was edited 1 time, last by Sylver ().

    • Sylver wrote:

      Just a word to tell that I tried to use hot air station to install the 96 pins connector but it was hard (for me at least) to get the whole surface hot enough and get all the 96 pins correctly aligned to fit correctly ! Moreover even with everything around protected with kapton, you can't make things hot for a too long time ... Maybe that if you have what you need to keep the board horizontally to allow to use flux and solve protection gloves to make sure you don't burn your hand when trying to install the connector from behind, it's possible, but on my side I had to gave up before making some damages on the board :S
      So I had to remove the solder from all the 96 holes one by one :D
      Without counting the solder to remove for installing the other sockets ! It took me few hours to get everything in place, but now I can enjoy my multiCPS2 :) Thanks for all the information available here :thumbsup:

      Good work! I've never seen a non fully populated CPS2