Preparing a Hikaru BGA Chip for Re-installation

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • freddiefiasco wrote:

      Oh gotcha. When I am tinning I can't tell if it's the right way or if I'm missing something.
      Are you using rosin flux or water soluble?

      I'm new to the reball process and your thread is helping me deal with the gotchas I'm encountering. :)
      I'm still learning the process too. Luckily I have a Hikaru pcb with damaged pads that is worthless so I have been testing on it. Some things I've learned:

      Clean the pcb good before applying the Kapton tape. If you don't it will not stick and will warp during heating. This is bad because it will create heat pockets under the tape that will damage components. I exploded a bank of 6 caps in this manner. When tinning the pads I would use a no clean flux. Water soluble is probably ok as well. Do not use RA flux on the chip. It's too messy and is unnecessarily hard on the pads when cleaning. You may get away with reballing the chip with a water soluble flux. However, DO NOT use water soluble flux to reattach the chip to the pcb. You need a flux that is semi-tacky that will hold it up during the process and help keep the chip in place.

      Make sure it's a paste flux for reballing and reattaching.

      What are you learning to reball?
    • Mitsurugi-w wrote:

      freddiefiasco wrote:

      Oh gotcha. When I am tinning I can't tell if it's the right way or if I'm missing something.
      Are you using rosin flux or water soluble?

      I'm new to the reball process and your thread is helping me deal with the gotchas I'm encountering. :)
      I'm still learning the process too. Luckily I have a Hikaru pcb with damaged pads that is worthless so I have been testing on it. Some things I've learned:
      Clean the pcb good before applying the Kapton tape. If you don't it will not stick and will warp during heating. This is bad because it will create heat pockets under the tape that will damage components. I exploded a bank of 6 caps in this manner. When tinning the pads I would use a no clean flux. Water soluble is probably ok as well. Do not use RA flux on the chip. It's too messy and is unnecessarily hard on the pads when cleaning. You may get away with reballing the chip with a water soluble flux. However, DO NOT use water soluble flux to reattach the chip to the pcb. You need a flux that is semi-tacky that will hold it up during the process and help keep the chip in place.

      Make sure it's a paste flux for reballing and reattaching.

      What are you learning to reball?
      Nothing specific, just wanting to have this type of skill under my belt. I just barely learned how to perform drag soldering with SMD. My next goal is mainly aiming at a few Radeon chipsets that are relatively easy compared to the hikaru. Baby steps in this case because I do not yet have all the proper equipment so when I get to a step that needs a specific item, things are on hold.
      I am getting the same issue with exploding caps in the vicinity of the GPU core. I think the temp is too high and also the amount of time and depth of the heat. I will double check my numbers and see if I am getting consistent.

      Is the water soluble flux considered no clean or is that a whole different type of flux? I've only seen resin flux, the kind that crystalizes at room temps.
      From what I have learned, water soluble flux is recommended if dealing with high impedance. I'm not sure if any of the items being used for our processes so I dunno.
      Having two different types of flux will be something I need to keep in mind during practice.
    • The update is I've moved into a house that does not have the amp requirements needed to run a rework station. So for the time being I can't use it. The machine uses 20 amps by itself during a rework cycle. I would need a 25 amp outlet at least. None in this house are over 15 amps except one, the one in the garage is 20. Even if it was 25 amps the garage is not a temperature controlled environment like you need to do BGA work. :(
    • @Mitsurugi-w You need to run a #10 line from your breaker panel to the location where you want the reflow station at. Hell you could throw in a sub panel in your office/work area and rewire the whole room.

      Anyone near Mitsu that can help him and get this done??


      Wanted:
      Cabs/Parts - Egret II, Forgotten Worlds PCB/Spinners
      Pinballs - Stern Star Trek / Metallica, The Simpsons PP, Medieval Madness
    • I just want to say very well done so far. I am glad to see you picking this up. I was the last of three people that worked on these in the world and I stopped doing these a couple years ago. I will still do reflows for opens but that it now. Everything you are doing so far is dead on perfect. Let me know if you need any asssitance setting profiles. Aside from Hikaru and M3S2 Video Bds, the Naomi DIMM Bds (315-6154) also suffer from burnt BGA issues. This ones super easy to do if you want to take a look at those. If you have some junk Hikaru's laying around, there are two of the ICs on it just waiting to be reballed for DIMM Bds.

      Some one mentioned needing some of the RAM IC 41/42. If you need these I still have a handful of new ones.

      Oh and BTW...Since I retired from doing the heavy BGA rework, my station is also retired and up for grabs. Its a perfect working BGA-3000 OK Industries with everything it came from factory including extra nozzles. Check ebay from for what they run and hit me up. Pick up only..sorry.
    • help please. I have a Air Trix arcade cabinet, that I bought from auction real cheap about a year ago. It said it had graphics problem, which it does. At the auction place I was able to get the splash screen to show. The marquee didn't light up. So I've been fiddling with it for the last yr.

      I've switched out the large power supply for a new smaller one, now the marque lights up, along with the projector which they were not using. However, I just get a whole bunch of lines for graphics, no sound. Now, somehow I lost the power to the projectors input so nothing shows from projector.

      Ok onto the board. I removed the game board and booted just with main pcb. I have about 5 less that show solid red, then there is one which you cant really see if the game board is installed and that one is blinking red.

      I've checked the power supply that goes to the main pcb, its 3.3v rail is good, the 5v is showing 4.93v output. I keep blowing that fuse because I adjust the 5v with screwdriver with machine off, but its missing the plastic turn nob. I wont blow it again..lol

      All that to ask these questions.
      1. What are the white buttons on main pcb, I know one is restart.
      2.Can that low voltage cause blinking led. And graphics problem.
      3. Are any of the Led supposed to be solid red color.

      I've removed the main pcb, cleaned it, all chips look like they have solid connection, no movement when slight wiggle of heatsinks. The pcb itself looks practically new tbh.

      Any manuals for hikaru board itself.

      Thanks