Seibu ‘HB-41’ reproduction by Caius

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Seibu ‘HB-41’ reproduction by Caius

      THIS IS A REPRODUCTION PROJECT MADE BY @caius ALL INFORMATION HAS BEEN POSTED WITH HIS PERMISION. CREDIT AND MERIT GOES TO HIM.

      Maybe many of you will recognize this IC and throw up hands in horror:

      This is the ‘infamous’ ‘HB-41’ used on several arcade PCBs (from Seibu/TAD Corporation but not only) :

      Raiden
      Blood Bros
      Legionnaire
      Sky Smasher
      Toki
      Dynamite Duke
      Olympic Soccer ’92
      Cabal
      Heated Barrel
      Operation Wolf

      This analog component (20 pin SIL package) is used in sound circuit to mix background music and sound FXs as well as it acts as as filter of both.From my experience (maybe also others can confirm it) it’s a prone to failure part.Let’s take a look at what is inside it:

      As you can see from above Hi-Res scan the custom is built around two ICs : a 4560 dual operational amplifier (8 pin component on the left) and a 2060 quad operational amplifier (14 pin component on the right), both from JRC manufacturer.All the rest are resistors (also printed film ones, the black squares), ceramic and tantalum capacitors.In order to reproduce it, after removed the epoxy, I pulled all the parts and metered them then I drawn schematics :


      Then I routed them ending up in a 5.3 x 1.8cm PCB:

      More or less same dimensions of original part:

      Here is how it looks assembled:

      I used an LM358 and LM324 for my testing which maybe are not the best solution since the original OP-AMPs have both high gain bandwith (10MHz) but the replacement works well on all PCBs I tested so far.Here is testing on a Cabal, Blood Bros and Toki PCBs:



      See you all to next reproduction project!
      * Arcade-projects, the site where you get the most of your arcade games.
      * If you want Drama go to Neo-Geo forum ---Darksoft
    • donluca wrote:

      Well done!

      I've done something similar to a Neo Geo MV1FZ which completely lacked the stereo audio output which other boards had: I've downloaded the schematics of the stereo boards and reproduced the stereo mixing-amp part on a breadboard and attached it to my MV1FZ.
      @donluca what are you waiting for?? Please post about it! :)
      * Arcade-projects, the site where you get the most of your arcade games.
      * If you want Drama go to Neo-Geo forum ---Darksoft
    • I've always wanted to start a thread on how to get stereo sound out from several arcade boards.
      All the ones I own have a stere jack added because, contrary to popular belief, many are actually capable of stereo sound and, most importantly, make full use of it.

      But I need time to do a proper write up, with pics and everything, instead of writing a half-assed thread with vague information. This week is going to be hell, but I promise I'll write something down when I have a bit of time to sit down and write everything.
    • donluca wrote:

      Well done!

      I've done something similar to a Neo Geo MV1FZ which completely lacked the stereo audio output which other boards had: I've downloaded the schematics of the stereo boards and reproduced the stereo mixing-amp part on a breadboard and attached it to my MV1FZ.
      Good work but don't forget I drawn myself schematics of all customs I reproduced,they were not available anywhere :)
    • No, Raiden 2/DX use the 'HB-45A' which has same SIL package and functions of HB-41 (it mixes/filters music and sound FXs) but different pinout.It's on my TO-DO list.Anyway your issue should be caused by the HB-45A, probably the internal OP-AMPs are faulty.

      The post was edited 1 time, last by caius ().

    • Awesome info, Caius. I'll keep paying attention to your project updates and see how you get along with the HB-45.

      My DX board is one of my prized games. Not that it's exactly super rare or expensive, but mainly because I bought the board off ebay, cheap, with faulty sprite graphics and worked it out that one of the custom IC's needed to be re-flowed. It was the first board I ever repaired and was pretty proud of that moment I powered it up and it worked!
      I'm never getting rid of it, and hope to keep it in healthy condition for as long as I can (barring the audio issue).

      Thanks!
    • opt2not wrote:

      Awesome info, Caius. I'll keep paying attention to your project updates and see how you get along with the HB-45.

      My DX board is one of my prized games. Not that it's exactly super rare or expensive, but mainly because I bought the board off ebay, cheap, with faulty sprite graphics and worked it out that one of the custom IC's needed to be re-flowed. It was the first board I ever repaired and was pretty proud of that moment I powered it up and it worked!
      I'm never getting rid of it, and hope to keep it in healthy condition for as long as I can (barring the audio issue).

      Thanks!
      Update.I decapped the 'HB-45A' (it's very similar to the 'HB-41'), figured out schematics and routed them to a PCB layout, I attach a 3D simulation.Now I'll send it to manufacturer.
      Images
      • Seibu HB-45A.png

        126.57 kB, 2,048×1,536, viewed 78 times

      The post was edited 1 time, last by caius ().

    • caius wrote:

      opt2not wrote:

      Awesome info, Caius. I'll keep paying attention to your project updates and see how you get along with the HB-45.

      My DX board is one of my prized games. Not that it's exactly super rare or expensive, but mainly because I bought the board off ebay, cheap, with faulty sprite graphics and worked it out that one of the custom IC's needed to be re-flowed. It was the first board I ever repaired and was pretty proud of that moment I powered it up and it worked!
      I'm never getting rid of it, and hope to keep it in healthy condition for as long as I can (barring the audio issue).

      Thanks!
      Update.I decapped the 'HB-45A' (it's very similar to the 'HB-41'), figured out schematics and routed them to a PCB layout, I attach a 3D simulation.Now I'll send it to manufacturer.
      Awesome, I’m in!
      Looking forward to clean sound on my Raiden DX. :D
    • First of all you should figure out if the lack of audio has a digital or analog cause.In first case the system ruled by the Z80 CPU is not running properly.In latter case the problem is due to a bad HB-41 or LA4460 amplifier.In order to determine the nature of the fault you could use an audio probe and 'listen' to various point of the audio circuit like analog outputs of YM3014 DAC or OKI MSM6295.If you don't hear anything then the fault is in the digital section of audio circuit.If you hear music or sound FXs, the fault is in the HB-41 or amplifier.Obviously you can use also a logic probe to troubleshoot the Z80 system.

      P.S.
      Check if -5V is present on your JAMMA harness.

      The post was edited 2 times, last by caius ().

    • Caius: thank YOU! there is no -5 v in that cab! there is on one of my other cab and guess what?! sound is fine ! :)

      easy fix :D !

      now I'll look into that -5v on that cab cause there's no sound in magician lord on the neo multi and I'm guessing that's why !

      thanks also for teaching us how to fish even if you have the fish for sale! much appreciated!
      +++
    • Mrhide wrote:

      now I'll look into that -5v on that cab cause there's no sound in magician lord on the neo multi and I'm guessing that's why !

      thanks also for teaching us how to fish even if you have the fish for sale! much appreciated!
      No, this has a different cause. Try flashing in another slot first. If it still doesn't work you can check the games with issues thread :)
    • Sp33dFr34k wrote:

      Mrhide wrote:

      now I'll look into that -5v on that cab cause there's no sound in magician lord on the neo multi and I'm guessing that's why !

      thanks also for teaching us how to fish even if you have the fish for sale! much appreciated!
      No, this has a different cause. Try flashing in another slot first. If it still doesn't work you can check the games with issues thread :)
      I did and no change. Yet it works in the NAC cab.
      +++
    • Mrhide wrote:

      Sp33dFr34k wrote:

      Mrhide wrote:

      now I'll look into that -5v on that cab cause there's no sound in magician lord on the neo multi and I'm guessing that's why !

      thanks also for teaching us how to fish even if you have the fish for sale! much appreciated!
      No, this has a different cause. Try flashing in another slot first. If it still doesn't work you can check the games with issues thread :)
      I did and no change. Yet it works in the NAC cab.
      Please post your issue here Games with Issues in order to avoid going offtopic.
    • @caius I have a Legionnaire board that has very very low sound. All sound seems to work (music and effects) and the pot for the volume works, but I have to turn it up to full volume and also turn my speakers very high up to hear anything. At that high of a level I also here power hum and of course, I don't want to keep it up on high volumes to play.

      1. Is it possible it is the HB-41? James from JNX has done a cap kit on the main PCB with no effect. (Caius answered with yes this is probably the issue).

      2. Since my sound is still working (just very low) is there one component I can replace on the actual HB-41, or will I have to replace the entire thing? If for example low sound symptom is just one thing that is failing, versus no sound and the whole HB-41 is bad.

      3. I prefer to keep it stock and save money where possible, but I have 3-5 of your other reproductions, and they are TOP NOTCH so I am not worried about it if I do need to buy one from you!

      4. Last, since I'm in the US, what is your recommend purchase location? Is this it: arcadepartsandrepair.com/store…u-hb-41-reproduction-pcb/
      I asked @Mitsurugi-w since he does the amazing work with the Konami sound modules, but he said no on this one.

      Thanks for what you do for the community and keep up the good work!
    • xtrasmiley wrote:

      4. Last, since I'm in the US, what is your recommend purchase location? Is this it: arcadepartsandrepair.com/store…u-hb-41-reproduction-pcb/
      I asked @Mitsurugi-w since he does the amazing work with the Konami sound modules, but he said no on this one.
      Arcade Parts & Repair is now selling some of my products so you can purchase from this store with confidence, they are 100% products made by me, no clones/fakes :)