Pinned Darksoft Neo Multi Help thread

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Darksoft Neo Multi Help thread

      UPDATE Feb 25th 2019


      CURRENT KNOWN ISSUES:

      #1 Fatal Fury 2, Super Side Kicks and KOF98 protection is not emulated yet. Use patched version for now.
      Rest of issues have been solved. Please make sure that you update to latest MENU and Firmware:
      Darksoft's MultiMVS Latest Firmware, Menu and Instructions

      COMPATIBILITY WITH UNIBIOS:

      #1 Controls won't work with MS3,4,5 and X when CONSOLE mode was activated in Unibios.
      #2 the NEOGEO logo is not shown properly in the UNIBIOS screen, the first time as soon as I power on, later it shows OK . The problem lies in the way in which UnIBIOS has been programmed as it tries to pull the logo from the cart instead of having it included in it's own code.

      FIRST BATCH HAD THE FOLLOWING ISSUES:

      - Should you use a MV-1F or MV-1FS, please note that there currently is an issue with these. Quick fix is lowering your 5v to about 4.7-4.8v or cutting a trace as explained here:
      - Some multicarts do show some gfx issues like fixed dots. All carts passed the quality test but seems as some solderpoints were not properly done and have a bad contact originated during shipping. Please PM me if this is your case.


      Please post any issues or questions you may be experiencing here. Some things to keep in mind:

      1. It's highly unlikely but you may encounter an unknown bug. If you do please let us know.

      2. Most issues with MVS systems are caused by poor contact with pins in the connectors. On normal carts this usually causes a failure to boot or lines in the graphics/missing sounds. With the multi bad contact can cause these or other issues. Please keep this in mind.

      3. The first time you boot the multi on your pcb it will take a longer time to boot while the filesystem is set up. This will happen again if you switch the cart between motherboards.

      4. Your battery on the motherboard needs to be functioning for settings of the multi to be saved between boots.

      5. If you load three large games onto the cart the initial load time when you reboot the cart will be longer.

      6. Please use GOOD, RELIABLE, MICROSD Cards. I've found some people with FAKE or poor quality microSD which make a game loading a pain. For example: SanDisk Ultra 16 GB Micro SD SDHC UHS-1 with Metal Slug 5, KOF 2003 and Aerofighters 2 takes 21 seconds to load. A fake one can take up to 1 min 32 seconds to load. You've been warned :huh:


      How to build game romsets.
      Some users have already made available some rompacks. To do that they have followed these instructions:

      for all the files except CROM just concatenate as it's in MAME. For example for the game Fatal Fury Special:

      ROM_START( fatfursp ) /* MVS AND AES VERSION */
      ROM_REGION( 0x180000, "cslot1:maincpu", ROMREGION_BE|ROMREGION_16BIT )
      ROM_LOAD16_WORD_SWAP( "058-p1.p1", 0x000000, 0x100000, CRC(2f585ba2) SHA1(429b4bf43fb9b1082c15d645ca328f9d175b976b) ) /* mask rom TC538200 */
      ROM_LOAD16_WORD_SWAP( "058-p2.sp2", 0x100000, 0x080000, CRC(d7c71a6b) SHA1(b3428063031a2e5857da40a5d2ffa87fb550c1bb) ) /* mask rom TC534200 */

      NEO_SFIX_128K( "058-s1.s1", CRC(2df03197) SHA1(24083cfc97e720ac9e131c9fe37df57e27c49294) ) /* mask rom TC531000 */

      NEO_BIOS_AUDIO_128K( "058-m1.m1", CRC(ccc5186e) SHA1(cf9091c523c182aebfb928c91640b2d72fd70123) ) /* mask rom TC531001 */

      ROM_REGION( 0x500000, "cslot1:ymsnd", 0 )
      ROM_LOAD( "058-v1.v1", 0x000000, 0x200000, CRC(55d7ce84) SHA1(05ac6a395d9bf9166925acca176a8d6129f533c8) ) /* mask rom TC5316200 */
      ROM_LOAD( "058-v2.v2", 0x200000, 0x200000, CRC(ee080b10) SHA1(29814fc21bbe30d37745c8918fab00c83a309be4) ) /* mask rom TC5316200 */
      ROM_LOAD( "058-v3.v3", 0x400000, 0x100000, CRC(f9eb3d4a) SHA1(d1747f9460b965f6daf4f881ed4ecd04c5253434) ) /* mask rom TC538200 */

      ROM_REGION( 0xc00000, "cslot1:sprites", 0 )
      ROM_LOAD16_BYTE( "058-c1.c1", 0x000000, 0x200000, CRC(044ab13c) SHA1(569d283638a132bc163faac2a9055497017ee0d2) ) /* Plane 0,1 */ /* mask rom TC5316200 */
      ROM_LOAD16_BYTE( "058-c2.c2", 0x000001, 0x200000, CRC(11e6bf96) SHA1(c093a4f93f13e07b276e28b30c2a14dda9135d8f) ) /* Plane 2,3 */ /* mask rom TC5316200 */
      ROM_LOAD16_BYTE( "058-c3.c3", 0x400000, 0x200000, CRC(6f7938d5) SHA1(be057b0a3faeb76d5fff161d3e6fea8a26e11d2c) ) /* Plane 0,1 */ /* mask rom TC5316200 */
      ROM_LOAD16_BYTE( "058-c4.c4", 0x400001, 0x200000, CRC(4ad066ff) SHA1(4e304646d954d5f7bbabc5d068e85de31d38830f) ) /* Plane 2,3 */ /* mask rom TC5316200 */
      ROM_LOAD16_BYTE( "058-c5.c5", 0x800000, 0x200000, CRC(49c5e0bf) SHA1(f3784178f90751990ea47a082a6aa869ee3566c9) ) /* Plane 0,1 */ /* mask rom TC5316200 */
      ROM_LOAD16_BYTE( "058-c6.c6", 0x800001, 0x200000, CRC(8ff1f43d) SHA1(6180ceb5412a3e2e34e9513a3283b9f63087f747) ) /* Plane 2,3 */ /* mask rom TC5316200 */
      ROM_END



      Bus #1 PROM: Just concatenate using any hex editor the two files in the same order: "058-p1.p1"? + "058-p2.sp2"? into "prom"

      Bus #2 SROM: Just rename "058-s1.s1"? to "srom"

      Bus #3 MROM: Just rename "058-m1.m1"? to "m1rom"

      Bus #4 VROM: Just concatename "058-v1.v1"? + "058-v2.v2"? + "058-v3.v3"? into "vroma0"

      Bus #5 CROM: Here you need to word_swap the files and concatenate. Do it in pairs using the script attached. You will need to edit the file to adjust input and output names. First process "058-c1.c1"?+"058-c2.c2"? into "out1.bin", then "058-c3.c3"?+"058-c4.c4"? into "out2.bin", then "058-c5.c5"?+"058-c6.c6"? into "out3.bin". Once you've obtained the 3 files, just concatenate into a big file and rename to "crom0"
      Files
      • join_crom0.zip

        (295 Byte, downloaded 57 times, last: )
    • @Mitsurugi-w was faster than me. We look forward to your feedback.

      Also I would like to add the following:

      * We havent been able to test ALL THE GAMES WITH ALL THE MOTHERBOARDS,so please when you report a problem, make sure that you specify which model of MOTHERBOARD, you are using, which BIOS, and WHICH GAMES ARE GIVING YOU TROUBLE. Try to be so detailed as possible.
      * Make sure that you load the same game in different slots and that the error repeats, to make sure it wasn't a glitch but rather an error.
      * Clean you cart and motherboard contacts properly.
      * Look for any signs of repairs in your mobo and let us know how they look
      * Include pictures or video of the problems you are having.

      Thanks!

      We have converted the Neo Geo monitor test tool, so you can check that your Multi is properly working and will help understanding better where the problem comes from. Just rename your 2020bb folder to something else and copy this one instead. Load that 2020bb into any slot and run it.

      mediafire.com/file/4id5rs42uca847u/2020bb.7z

      YOU CAN FIND THE INSTRUCTIONS HERE: Neogeo Multigame Presales open!!!!
      * Arcade-projects, the site where you get the most of your arcade games.
      * If you want Drama go to Neo-Geo forum ---Darksoft
    • My 1st impressions:

      The cart works great on my MF-1FZS and I'm very impressed! :thumbsup: :thumbup:

      The splash screen of the Unibios (v3.1 & v3.2) seems to be a little bit corrupted after powering on the system (top section) but I've simply disabled the splash screen and so it doesn't bother me anymore. :P

      Some menu music files seem to be corrupted, too. But that's no problem for me either because I've turned the menu music off anyway.

      A minor suggestion for improvement: It would be nice if the "pointer" doesn't jumps back to the 1st game of the list after assigning a selected game to a slot (I use the thumbnail view). ;)

      The post was edited 1 time, last by SVM ().

    • SVM wrote:

      The splash screen of the Unibios (v3.1 & v3.2)
      And UniBIOS 3.3, but this only seems to happen when the menu is booting... When switching slots/games it's perfectly fine.
      Darksoft: CPS3, CPS2, F3, MVS
      RGB: RECO v2, HAS v3
      invzim: Jammafier v1.6b
      XianXi: JNX Raiden, SC Taito Classic, SC Sega System 16/24
      Frank_fjs: JAMMA Extender (Special Edition)
    • @Darksoft

      THX for the menu update. But there is a new little issue, now. ^^
      When a new game is assigned to a slot (thumb view) and "C" is pressed to exit you'll leave the game list menu completely (only happens, when filters turned off)


      Another little issue?: If boot mode ist set to "Game", the game starts and "Start" + "Right" are pressed for 3 seconds to turn back to the main menu, no menu appears and the game will reboot instantly. But when the button combo "Start" + "Right" is pressed longer (10 seconds?) you can return to the menu...

      Anyway, big THX for launching updates very quickly! :thumbup:
    • I'll check the first issue.

      About the 2nd it's already explained in the instructions. You need to keep start pressed in order to avoid going back to a game when option "game" is chosen.

      Thanks.
      * Arcade-projects, the site where you get the most of your arcade games.
      * If you want Drama go to Neo-Geo forum ---Darksoft
    • Don't know, it's probably settings on the OSSC and the TV, I pressed the scanline options couple times and from the couch it looked ok. I had to hook it up downstairs cause the MVS MV-2F takes so much space. Will play around with the settings to see if I can get it any better. I'm also suffering a 'cyclic diagonal wave' pattern all over the screen. Need to try out with a shorter and or shielded SCART cable I guess, see if that helps.
      Darksoft: CPS2, ST-V, F3, MVS
      RGB: HAS v2.1
      Undamned: 2x DB15 USB dec
      marqs: OSSC v1.5 (audiomod)
      superg: GSCART switch v3.4
      Vector-Labs: NAMCO SYS1 4 in 1 (vert)
    • does someone have some idea about what game / combination could be tested? I'm open to suggestions...

      I read the first 40 pages of the neosd post to check if the same issues (sound clicks, exceptions, non booting games, whatever etc..) could be reproduced in the DS multi. So far I didn't have ''success'' in finding anything relevant (I'm not really in the mood to check the next 40 pages, it takes too much effort)

      I'm testing now with a fzs mainboard with stock bios, and official games (no bootlegs so far)
      LOAD "*",8,1
    • deibit wrote:

      does someone have some idea about what game / combination could be tested? I'm open to suggestions...

      I read the first 40 pages of the neosd post to check if the same issues (sound clicks, exceptions, non booting games, whatever etc..) could be reproduced in the DS multi. So far I didn't have ''success'' in finding anything relevant (I'm not really in the mood to check the next 40 pages, it takes too much effort)

      I'm testing now with a fzs mainboard with stock bios, and official games (no bootlegs so far)
      arcade-projects.com/forums/ind…t/&postID=70377#post70377

      I made a list earlier based on the prototype testing video done by beast. You can check to see if all those issues are resolved I guess.
    • All these issues were due to a bug introduced in the last firmware release. The bug was found and eliminated so all carts that left to the users had all these problems fixed.
      * Arcade-projects, the site where you get the most of your arcade games.
      * If you want Drama go to Neo-Geo forum ---Darksoft
    • I played already most of those games, some of them extensively (mslug5, neo turf, winjammers...) and I didn't feel anything out of the ordinary.

      Sound issues were fixed in the last pre-preorder firmware as far as I can tell.

      There's a small glitch in pulstar attract mode and some clicks on blues journey music (need to check the original cart to compare)..

      But I'll check again the games you mention :)
      LOAD "*",8,1

      The post was edited 1 time, last by deibit ().

    • K405 wrote:

      I like the error message when there's no game(s) found in the games folder :)


      Unfortunately I'm seeing these 'dead/random' pixels on my CRT as well. I noticed pixelation in game as well. I'll pickup a new sdcard today, Samsung Evo I hear from everyone is good and try again and report back.
      Darksoft: CPS2, ST-V, F3, MVS
      RGB: HAS v2.1
      Undamned: 2x DB15 USB dec
      marqs: OSSC v1.5 (audiomod)
      superg: GSCART switch v3.4
      Vector-Labs: NAMCO SYS1 4 in 1 (vert)