Konami hornet revival

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Hi everyone, @neocps1 , just providing an update.

      First to just clarify what the issue was with my NBA board. It experienced an RTC device error 35d (35d being the chip location for RTC m48t58y chip) and would not boot after that error.

      My game was US version, no dumps of this version. According to someone who dumped the Asia version a few years back, they claimed that everything between Asia and Jap version were the same, except program rom and RTC data. They were unable to dump their Asia version RTC either -the mame rom for the asia version still uses the japanese RTC file.

      The results i found online for this game are scarce, but people just buy and program the Jap version RTC, socket it and it works again. Though unsure what version program rom they had to begin with.

      Based on this, I removed the dead M48t58y RTC, put a socket onto the board. I ordered the following chips:
      - one brand new blank RTC chip from mouser
      - one programmed RTC chip from buyicnow , with programming from RTC file from mame dump (Jap version)
      - one programmed 'program rom' for Japanese version of NBA
      - one programmed 'program rom' for Asia version of NBA

      Installed the pre-programmed Japanese RTC chip, and Japanese program rom. On first bootup, it would show JAA version at first as region, then automatically blank out to *** no region, and then auto reprogram itself to show AAA Asia region version.
      The game would boot, play the game fine for a bit, but then after a few minutes of play or when inserting a credit, would reboot, lose region again back to blank *** and reprogram back to AAA Asia version, boot up again, play again fine then crash again after a couple minutes , lose region *** etc.

      I tried the blank RTC chip this time, and Asia version program rom. The blank RTC automatically programmed the blank RTC chip to AAB version. This means it should match both RTC and program rom to be asia version - game boots, works for a bit, but still reboot, loses region back to ***, reprograms itself to AAB, works for a bit, crashes again etc. I tried the 'hold test button from power on' trick, but still doesnt change the outcome above.

      At this point, I gave up on fixing the game.

      I had some great support options locally to pay to repair the game, but I decided not to proceed. My reason is that although I would have a working game again, I would still be left with a game which would be a ticking time-bomb and eventually fail again due to the RTC chip battery dying in these. Unfortunately the board design is poor and I would be having to pay for repairs every few years any time it failed and wasn't something I wanted to do long term. It wasn't worth it for me for this specific game.

      I then came across this tool from NeoCPS1 which seemed to be a more permanent and self-manageable solution

      I followed the instructions in this thread (extracted the tool into C:\Hornet, extracted the mame program rom to c:\778a01.27p, edited the compile file to point to c:\778a01.27p, ensured hboot.s had the appropriate rtc data for this game - which i confirmed with neocps1 in pm - note the RTC data is relevant to the JAA jap version). Once I created the data file with the compile batch file, I confirmed it had been updated by doing a file compare to the original program rom dump - it was successful.
      I had buyicnow supply and program the chip with this data.

      I received it today, however it unfortunately it has not resolved the issue and has made everything a little worse off :)

      First, I put in my new RTC chip
      I remove the program rom
      Install the revival chip into program rom slot
      Power on the game. It shows the digital little clock display flashing - as expected it was supposed to be doing, as per the instructions in this thread.
      Waited about 20 seconds. Powered off the game. Reinstalled the Japanese game program rom and powered it up

      It shows the usual bootup sequence, however shows version ***, does all the rom checks which come up OK, but after all of that it will do one of two things
      1. Reboot itself straight away (version ***, rom checks 'OK' to everything, then reboot again, and do identical)
      or
      2. Sometimes it passes all the rom checks OK, and instead of booting the game OR rebooting - it will just go to a black screen with no error, just sits there, even if you leave it for 20 minutes.

      I tried performing the procedure again, this time using my second RTC chip which buyicnow had previously programmed with Japanese data.
      Again the revive chip was put into the program rom slot, powered on, done its flashing sequence, and this time the flashing eventually stopped after maybe 10 seconds or so and stayed steady. Powered it off, reinstalled the japanese program rom - same result as above.
      It will either do its rom tests and instantly reboot and do them again over and over with *** region, or just sit on a black screen after the rom checks pass.
      I tried again, considering the flashing stopped during the revive chip process - this time, it continued flashing non stop, so i powered it off after 30 seconds, then reinstalled the program rom (Jap) - same as above, no region assigned, just reboot loops after rom checks.

      I tried removing the program rom, and putting in a different region program rom - same behaviour as above...

      This is now behaving different to it was, before the revive chip was attempted.
      Prior to trying the revive chip, it used to allocate a region of some form e.g. AAB, and I used to be able to boot up into the game for a few minutes, before it decided to crash.

      Unfortunately it seems worse off than before, so i would recommend caution before anyone else trying this.

      Im not overly concerned, as the game wasn't ultimately working anyway and has been a cheap exercise to attempt.

      If anyone has any further ideas, or insight, would be happy to try - otherwise I think I may have to give up on it :)

      Thanks all
    • Edit: another update.

      I tried the revive chip again with another spare new m48t58y rtc and power on for 1 minute

      I powered off, put japanese program rom back into the game (mame JAA version program rom).

      I power on the game, it says 'revision JAA' on first bootup.
      The game boots, but i check test menu and it says AAA version now?

      Then 1 minute after game reboots and shows revision *** blank again and game goes into bootup loop with no revision (or sometimes will show AAA then reboot back to *** nothing)

      Any idea @neocps1 ?

      Is it more than the program rom and rtc which control region

      Thanks

      The post was edited 2 times, last by pyJamma ().

    • Hi all
      Update. I had actually stored my NBA board as i wasnt going to bother with it anymore

      Then i ran into some issues with my cps2 kit this week. Was blacking out randomly during use. Following advice i adjusted my voltage to be 5v at the gameboard, rather than it being 5.1v at the harness with no game connected and about 4.7-4.8v with a game (how it was previously)
      Thus far cps2 seems ok but need to test it more.

      Anyhow i thought maybe my NBA wasnt getting enough juice either so i tested it with the newly adjusted voltage.

      Whilst displaying a random region on boot and in the test menu (AAA) the game boots and plays through the whole game (even winning the finals). Entering credits doesnt freak it out anymore etc.
      Such an odd thing though. If this has fixed it i dont understand why voltage would cause blanking of a region to *** ...

      Anyway i do need to keep testing but very positive result thus far!

      Thanks all
    • Hmm it reset itself again during NBA finals - this time however, it doesnt change / blank out region on boot up again

      I find something interesting though. My Astro cabinet has adjustable voltage. At the harness with no game, ive maxxed out the voltage adjustment pot to 5.5v
      With CPS2 connected, its a steady 5v at the gameboard edge connector (sometimes a touch higher, but usually 5)
      With Hornet NBA connected, its only like 4.6-4.7v

      Is the power supply to weak for this game? Seems to be thirsty for more voltage than CPS2.
      I might try my brothers arcade cabinet which has a standard arcade PSU in it and have him play NBA for a while to test for me.
    • Cabs: Vewlix FC, GC 3, ID7, DinoKing, Swing, MiniCute, NAC
      Multis: CPS1│CPS2│CPS3│ST-V│F3│GNET│TTX2│MVS
      Superguns: Jasen's MK30ADCAP│RGB's HAS
      Displays: PVM 2950Q│Pioneer PDP-V402E│LG B6 65" Oled
      Scalers/Misc: OSSC│VP50Pro│Gscartsw│Hydra

      Wanted Cabs: Egret 29, Egret II, AWSD, Stern Star Trek Pinball
      Wanted Part: SFII Dynamo HS5 "Cut Corner" CP, Egret 29 Complete CP top (blue or red)
    • i have the 400-5261 variant of astro psu which is 12a 5v. The nba manual says it needs 5v 10a, but i do agree a beefy psu is needed for these boards definitely. I think my psu is just enough to keep it kicking haha

      As above, after my last single instance reset, i jacked it up to max 5.5v no load at harness, which gives cps2 5.05v at board and about 4.8v at NBA board. Since maxing out its been steady thus far no resets and plays through.. If any other issues ill probably give the board to my brother to test on his machine

      Thanks all