Got around to testing new cps2 A board sprites are transparent

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Got around to testing new cps2 A board sprites are transparent

      avp works fine on my first a board but has sprite issues on new one (they are transparent) is there anyway to fix?
      is website lagging for anyone else?

      My Cabs: Blast City | Blast City | Egret 2| Egret 3| Windy II | Neogeo 6Slot | Centipede| TMNT

      The post was edited 1 time, last by 8bitforlife ().

    • PascalP wrote:

      website is bad the last 2 days for me... :(
      Yep, I was about to post about it but didn't want to be the ranting guy (especially since computers hate me I thought I might be the exception as often).

      But working fine today.
      Looking for:
      - OutRun boardset even untested or not working
      - Sega System 18 romboard type 171-5987



      01010011 01000101 01000011 01010010 01000101 01010100 00100000 01001101 01000101 01001110 01010101 00100000 01000111 01010101 01011001
    • Open the board, check for any obvious signs of corrosion, knicked traces etc. The culprit is often visibly obvious. Re-seat all socketed chips (make sure they're firmly pressed into their sockets). Make sure the A and B boards are firmly pressed together, and use the inter-board clips to secure them.

      That's the easy stuff. Beyond that requires probing/scoping, and the guys mentioned above might able to tell you where to focus on.
    • Your sprites aren't transparent, they are flickering every other frame. Check for a solid A-B connection, because it sounds like only one of the two sprite buffers are being written to. It could just be that the sprite RAM is bad, or an address line is stuck there too.

      With a snipped-off post (common B board case damage), it's very easy for the headers on the graphics side to make poor contact, so first try testing outside of the B board's case to eliminate possible errors.
      Working on Gimmick!

      Always on the lookout for 29" monitors!
      Game Want / Have list
    • I'm having this exact issue as well (plus another one on the B-board, but that's another story).

      On SSF2 I have the sprites (fighters and health bars) flickering, everything else is ok (background, music, etc.).

      Where do I start looking? The motherboard looks immaculate, can't find a single sign of corrosion.

      EDIT: some additional info, thing I've already tried to do:

      1 - Remove all socketed chips, cleaned connectors, reseated all the chips.
      2 - Clean the boards (both A and B)
      3 - Made sure there's optimal contact between the two boards
      4 - Checked all the electrolytic capacitors
      5 - Looked carefully for any sign of corrosion or broken traces
      6 - Inspected the connectors, looking for broken/bent pins

      I've heard that the 74LS245 are prone to failure, but how do I tell which has gone bad?

      EDIT 2:

      So, I've tried reflowing the connectors since I've read that those points are prone to crack, nothing changed so far.
      One thing I've noticed is that "INSERT COIN." is written not in all caps like it should, it uses all lowercase letters.
      And one more thing: I tried going into the test menu to scroll all the graphic tiles and the only one flickering are the Object ones. Everything else is fine.

      The post was edited 3 times, last by donluca ().

    • Uhm, I'll look into it, but shouldn't the board not boot at all if a RAM was bad? I ran the tests and all the RAMs checked out fine as well.

      Anyway, I guess I'm looking at the HM514260 modules since they are the only DRAM on the motherboard, the other ones being SRAM ( git.redump.net/mame/tree/src/mame/drivers/cps2.cpp ).

      I'll see if all pins are connected or something is amiss.

      Thanks for the tip, if anyone has any other idea please do chime in!
    • There are many RAMs on the board, and not all of it is visible to the CPU. You can boot a CPS1 or CPS2 without any valid sprite FB ram, and it'll boot up and run as if nothing is wrong.

      As for your addressing issue, my hunch is you have one addr line floating or stuck high. That just so happens to correspond with the 7th bit of the tile ID, making your text lower-case.
      Working on Gimmick!

      Always on the lookout for 29" monitors!
      Game Want / Have list
    • I guessed as much, I thought the 74LS245 were the culprits, but it might be just one address line stuck high or floating.

      The B-Board was really dirty, maybe something is shorting an address line to Vcc? That's going to be a huge pain in the ass, I've already had a similar issue on my System16B board and I've been *VERY* lucky to accidentally find a point were two traces touched each other due to a scratch.

      Fun times ahead.

      EDIT: how do I clean properly a CPS2 B Board? I can't just put it under water as it has a battery...
    • Done some tests in MAME and discovered that the EPROMs with a bit stuck high are 13, 15, 17 and 19.

      There's a possibility that the BGS3 PAL could be shot as well.

      EDIT: the PAL is good otherwise I'd have issues on SCROLL stuff as well since they are tied to the same pins as per wiki.pcbotaku.com/wiki/CPS2_PAL3

      EDIT 2: Checked all the traces on the B-Board and everything is good. So my guess is that one (or more) of the EPROM are bad, but I won't be able to verify this until the adapter for my GQ4x4 arrives.

      About the motherboard and flickering sprites: I've checked the DRAMs and again, all traces are good and I don't have a way to test the RAMs to see if they are good or not, so the only way to find out would be putting two new ones in but, damn, those RAMs are pretty pricey, going for 15-20€ each. I'm starting to think it would be cheaper to get another motherboard entirely and selling this one for parts.

      Either way, I'm gonna call it a day for now, since I've exhausted all possible diagnostics.
      I'm going to update this when I'll have the adapter for my programmer and decided what to do with this motherboard.

      The post was edited 3 times, last by donluca ().

    • I would suggest it is highly (extremely) unlikely that all EPROMs all in the mask ROM space are bad.

      There will be a common link between them, be it a logic IC or RAM - that's what you need to find. Often ROMs with common data have all address lines tied together (as Hatsune Mike pointed out they switch between very quickly to give got a solid image)