SOLVED! Darksoft Kit installed - not working please help

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • SOLVED! Darksoft Kit installed - not working please help

      Hello everyone -

      I have seen the thread here: Please help: Could not figure out why my CPS2 Darksoft kit not working

      That person has a similar problem to me, so I will perform these steps as well when I get home. Can you please take a look at my photos and see if there is anything else that looks out of place? Here are the details. Note that I checked my solder points on the jumpers and it is all clean...no crossed wires.

      Also - the first pic below shows what appears to be a missing pin on the ARM...I looked it over again and there is no pin missing, it was the angle/shadow of the photo.

      I have already tried adjusting the contrast pot, it is not the issue.

      The boards are super tight and no bent pins, but I can try re-seating again.

      Board status: Was a working board at one point, has since had the battery removed, no battery on the PCB.
      Board Revision: 4
      Darksoft kit manufacturered date: 2018
      Original Game: Marvel Super Heroes
      PAL: F-Pal installation with a jumper from the pulled leg (4th one over) to CN3 C13
      JP jumpers adjusted - I double checked the order as I did it to match the manual - will check again for a third time.
      Key Writing jumper wires installed as well.
      Used a CPS2 rollup Rom pack on my SD card installed using a PC

      Any thoughts on what is going on, what I may be missing, or what I have done incorrectly? Do I need to do some other form of "reset" to the board?

      I have waited months to get this kit, any help would be greatly appreciated!






      Current Lineup: Donkey Kong/DK Jr.--Mario Bros. Wide Body--Punch-out!!/Super PO!!--VS. Unisystem Dedicated--VS. Dual System Red Tent--Playchoice 10 Dual Monitor--Playchoice 10 Counter-top--Nintendo R-Type--Nintendo Super System--Sega Blast City--Capcom Mini-Cute (Pink)

      The post was edited 2 times, last by orlandu81 ().

    • Derick2k wrote:

      The solder joints look a little rough, make sure you use some good no clean liquid flux when soldering. It looks like you also have a solder bridge from the red key writing jumper wire to a resistor.

      I would undo the key writing jumpers all together, reflash the firmware, and retest.
      Thanks Derick2k for the input. I did not use Flux, I will remove the jumpers and reinstall the firmware as you recommended. I did notice previously that I may have had a bridge from the red jumper to the resistor and cleaned it up a bit and the problem persisted.
      Current Lineup: Donkey Kong/DK Jr.--Mario Bros. Wide Body--Punch-out!!/Super PO!!--VS. Unisystem Dedicated--VS. Dual System Red Tent--Playchoice 10 Dual Monitor--Playchoice 10 Counter-top--Nintendo R-Type--Nintendo Super System--Sega Blast City--Capcom Mini-Cute (Pink)
    • Get yourself a bottle of this flux

      amazon.com/gp/product/B004RIF3…smid=A2T9G15QSM4M3M&psc=1

      Will make things a lot easier, it doesnt really need to cleaned as its non corrosive, but if you like too, just use some alcohol to remove the sticky feeling on the board.

      and some Goot Wick

      amazon.com/Goot-CP-3515-Desold…T=_SY300_QL70_&dpSrc=srch

      Both what I use, excellent products to work with.
    • Ok guys, I took the whole thing apart and noticed that two jumpers needed to be cut, they were shorted when they should have been open. A very small connection was there, I could barely see it. Now I am reassembling and think I should reinstall the new firmware....how do I do this? Do I simply place the flash file onto a blank micro SD card and fire it up? I don't want to go out of order here...
      Current Lineup: Donkey Kong/DK Jr.--Mario Bros. Wide Body--Punch-out!!/Super PO!!--VS. Unisystem Dedicated--VS. Dual System Red Tent--Playchoice 10 Dual Monitor--Playchoice 10 Counter-top--Nintendo R-Type--Nintendo Super System--Sega Blast City--Capcom Mini-Cute (Pink)
    • orlandu81 wrote:

      Do I simply place the flash file onto a blank micro SD card and fire it up?
      Yes, that's it. After updating, check the microSD to make sure the file flash.img is now gone.
      * Arcade-projects, the site where you get the most of your arcade games.
      * If you want Drama go to Neo-Geo forum ---Darksoft
    • Darksoft wrote:

      orlandu81 wrote:

      Do I simply place the flash file onto a blank micro SD card and fire it up?
      Yes, that's it. After updating, check the microSD to make sure the file flash.img is now gone.
      It did not disappear after booting up the pcb with the flash file in it. I simply had the flash file by itself, powered the board on with no jumper keys attached, and i got my black screen.
      Current Lineup: Donkey Kong/DK Jr.--Mario Bros. Wide Body--Punch-out!!/Super PO!!--VS. Unisystem Dedicated--VS. Dual System Red Tent--Playchoice 10 Dual Monitor--Playchoice 10 Counter-top--Nintendo R-Type--Nintendo Super System--Sega Blast City--Capcom Mini-Cute (Pink)
    • Perhaps that means the newest firmware is already installed and I should just hook up the key jumpers again and try it out????

      Someone stop me if this is a mistake........... :)

      (30 mins later)........anyone going to stop me? I'll wait a little while longer then I will install the jumper keys and load up the rom set and pray!
      Current Lineup: Donkey Kong/DK Jr.--Mario Bros. Wide Body--Punch-out!!/Super PO!!--VS. Unisystem Dedicated--VS. Dual System Red Tent--Playchoice 10 Dual Monitor--Playchoice 10 Counter-top--Nintendo R-Type--Nintendo Super System--Sega Blast City--Capcom Mini-Cute (Pink)

      The post was edited 1 time, last by orlandu81 ().

    • Update: Sorry for the multiple bumps...I have now completely reseated everything, checked the jumpers with my multimeter to ensure open and closed connections. Triple confirmed the order.

      I then cleaned up my mediocre soldering job and removed the jumper keys. I tried to reinstall the "flash" file but it remained in the root folder so i just formatted it and dumped the "games" folder in there. I have the KEY file and the NO BATTERY file in the "games" folder.

      I then re-attached the jumper keys and fired it up. Same result----black screen, LCD just lights up with no lettering. I'm out of ideas, I've now re-done this thing 3 times with the same result. My PCB was a working MSH, so the PCB is fine. Please review the updated pictures...what am I missing?

      Edit: I'm done...sending this back to Aldo. 7 hours of troubleshooting is enough.



      Current Lineup: Donkey Kong/DK Jr.--Mario Bros. Wide Body--Punch-out!!/Super PO!!--VS. Unisystem Dedicated--VS. Dual System Red Tent--Playchoice 10 Dual Monitor--Playchoice 10 Counter-top--Nintendo R-Type--Nintendo Super System--Sega Blast City--Capcom Mini-Cute (Pink)

      The post was edited 1 time, last by orlandu81 ().

    • as you're based in USA send it to @Mitsurugi-w please. He's based in New Bern,NC

      I think you should send it with the B board but @Mitsurugi-w will confirm. If the problem is the kit he'll fix it for you for free.
      * Arcade-projects, the site where you get the most of your arcade games.
      * If you want Drama go to Neo-Geo forum ---Darksoft
    • Darksoft wrote:

      as you're based in USA send it to @Mitsurugi-w please. He's based in New Bern,NC

      I think you should send it with the B board but @Mitsurugi-w will confirm. If the problem is the kit he'll fix it for you for free.
      that’s fine, I’ll send it wherever it needs to go, I just can’t look at this thing anymore. If it’s the kit and he can fix it for free, great. If it’s something else and he can fix for a fee, that’s fine too. I’m happy to send with my B-board. To be honest, I just want to be able to use the kit in my machine at this point...I will see what @Mitsurugi-w says. I sent him a note on KLOV over the weekend.
      Current Lineup: Donkey Kong/DK Jr.--Mario Bros. Wide Body--Punch-out!!/Super PO!!--VS. Unisystem Dedicated--VS. Dual System Red Tent--Playchoice 10 Dual Monitor--Playchoice 10 Counter-top--Nintendo R-Type--Nintendo Super System--Sega Blast City--Capcom Mini-Cute (Pink)
    • Before you do that.... I've seen a similar issue before....

      A BLACK screen is very different from a solid colour. Solid colour is an issue reading the main program ROMs.

      A BLACK screen I only ever see if the A and B boards aren't seated correctly. Seperate your boards, check for bent pins on the connectors and then reseat firmly. See if that helps.

      I know you said you've done this, but check again. It could also be a loose pin which is more difficult
    • Well from my experience since the kit is obviously getting power and adjusting the contrast does not show any message combined with the fact that the update file is not being deleted I think the bootloader has become corrupted or is not installed. I've seen it in previous batches.

      If you take the main kit PCB and power it up by itself it will still give you a message on the LCD. Even if it's not installed on the b board.
    • All- thanks for the tips, I have tried everything stated. I am done trying to get this kit to work, and am ready to send it back for an exchange, repair, or refund. I’ve already stated that if the issue ends up not being from the kit, I will take ownership and pay for any repairs that are not a result of the kit. However if it is the kit, I would appreciate coverage on that...
      Current Lineup: Donkey Kong/DK Jr.--Mario Bros. Wide Body--Punch-out!!/Super PO!!--VS. Unisystem Dedicated--VS. Dual System Red Tent--Playchoice 10 Dual Monitor--Playchoice 10 Counter-top--Nintendo R-Type--Nintendo Super System--Sega Blast City--Capcom Mini-Cute (Pink)
    • orlandu81 wrote:

      All- thanks for the tips, I have tried everything stated. I am done trying to get this kit to work, and am ready to send it back for an exchange, repair, or refund. I’ve already stated that if the issue ends up not being from the kit, I will take ownership and pay for any repairs that are not a result of the kit. However if it is the kit, I would appreciate coverage on that...
      No worries mate, Darksoft and Mitsu got you covered, their support is excellent ;)