Konami Viper (Thrill Drive 2)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Konami Viper (Thrill Drive 2)

      I'm at a loose end with fixing this board, so I thought I would write up my repair attempts here (and will add pictures later).

      I purchased a broken Konami Viper for about £30 as my first repair project. The seller informed me that it used to work, and then had the infamous RTC issue. The seller said he got the issue repaired, the board worked for about a week and then the whole thing just wouldn't turn on anymore. He had it running in a real Thrill Drive 2 cabinet.

      When I got it home, I powered it up and it would flash through a series of LEDs and get stuck with 2 lights on and never get any further. Having looked at other videos of the Konami Vipers booting up, it looks like after those 2 lights show the screen is supposed to burst into action which makes me think maybe the graphics chip wasn't working properly?

      Sometimes when I turned it on it would flash completely random lights in a loop - I think this was possibly to do with it not having enough power. I checked the voltages and could read around 4.59 on the 5v lines, and 12.1 on the 12v lines. I had bought a cheep Jamma connector, and so had to replace the very thin wires which then made the 5 volt line go to about 4.89. This didn't fix the board, but made sure that the lights would always get stuck (which I think is better than them flashing randomly, and I think closer to what the board is supposed to do).

      I decided to check the PCMCIA/CF card against the thrill drive 2 rom online, and that all checked out. If you've got a linux computer you can use the ```dd``` command to do a raw copy of a CF card, and then use the ```diff``` command to see if it differs from a rom you know to be correct.

      I assumed the RTC was okay seeing as it wasn't booting with an RTC issue. I also tried taking out the RTC (it was already socketed) and the PCMCIA/CF card to see if the machine would boot to an error message which it didn't.

      At this point I thought the machine was pretty much dead, so I went to do a reflow of the graphics chip. I got my dad to take it into work, and someone from there to reflow it for me on their proper equipment at the office. Dad said that during the reflow they didn't have any flux (i'm not even sure what that is) and so it wasn't the best reflow job. When I got it back unfortunately it turned out worse than before. Now when you apply power all the LEDs light up, and nothing happens. After a while a slight burning smell comes from the board, which could possibly be a bridged connection on the Graphics chip?

      Dad (who is an FPGA engineer) suggested that all the LEDs remaining on, suggests that the program is never being loaded into the FPGA properly to run the lights, and that they just default to being on - which I think means the board just isn't starting at all now?

      So that's where I'm at - if anyone has any suggestions with what to do next I would be super interested. I'm thinking of trying to heat up and take off the graphics chip, and see if the burning smell goes away - if it does I could then try to attach the chip back somehow and see if that makes it work?


      Alternatively, if anyone in the UK wants a broken Viper with a working CF/RTC for £30 feel free to contact me!
      OpenJVS | JVSCore | OpenLSA | Arcade Blog

      Own: Naomi / Chihiro Type 1 / Chihiro Type 3 / System SP / Lindbergh / Sega Ringedge / Galeco Power 3D
      Want: Time Crisis 1, Time Crisis 2, The House Of The Dead 1
    • i don't think the large chip at the center of the board is gpu, but most of time, that chip is the culprit.
      in some cases, pressing that chip by finger while it's on, the game would boot, if not, it just showing that kind of random led behavior.

      there's must be something wrong when reflowing the chip. as the burn smell, it could be worse, breaking another chip. your best bet would be just find another working one.