Taito F3 Video and Audio problems.

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Taito F3 Video and Audio problems.

      Hi, I was looking to get an F3 multi at some point in the future so I ordered an F3 Motherboard and Puzzle Bobble 2X on eBay to prepare for this. I received it in the mail today but I'm having some issues.

      To start with, I'll mention I'm running it on an old MAS Supernova on composite to a Sony PVM 20M4U. I have also tried turning up the voltage slightly as per suggested in other topics, but since all I have on hand to test voltage is a shitty analog multimeter I'm not very confident in the accuracy of, I didn't want to push it too high without further consultation. I aimed for 5.1v on the analog multimeter.

      The problem with the picture is obvious, you can see most colors ghosting to the left. From pictures on the auction, this problem is not present. (There is also an issue of the game screen being centered too far right and down, but I understand this is typical for the F3)

      As for the audio, the music is nice and loud, but the sound effects are extremely low.

      I've included pictures of the motherboard at the bottom of the post.





      Motherboard (TOP): i.imgur.com/xZKQwww.jpg
      Motherboard (BOTTOM): i.imgur.com/NDHGwbd.jpg

      The motherboard is pretty dirty. I cleaned it in a few places gunk had piled up and I was worried about a potential bridged connection but that resolved nothing. The fan has one of the wires pulled out but I don't think that is too big of deal, I should probably disconnect it entirely for the meantime though.

      Ebay post showing proper image: i.imgur.com/Vcxp46k.jpg (I can't tell if the colors are a bit off on their picture, and they seem to be outputting it to an LCD)

      Thank you for any help! :)

      EDIT: I've been thinking about it, is it possible the crappy composite video converter built into the MAS Supernova doesn't like the the odd refresh rate of the F3 and is having trouble syncing? This thing has apparently RGB out via an 8-din port I'd like to try, but I don't have the cable for it.

      The post was edited 6 times, last by Rotanibor ().

    • I was at Super Arcade in SoCal on Saturday and the owner was kind enough to let me try the F3 on one of the arcade cabinets. The video and audio issues were not present there.

      I'm totally confused about why the audio had no problems, but I am thinking that the video problems are a result of the composite video converter in the MAS Supernova.

      Has anyone else had any instances of the F3 working or not working on certain video converters? Mostly curious what is confirmed as working if possible.
    • It sounds to me like you already diagnosed it properly. If your board works correctly in a JAMMA cabinet, then it definitely doesn’t like your SuperGun. You are correct that the Taito F3 board uses an unusual sync signal, and there’s multiple threads on here discussing it. I had F3 problems myself with my HAS SuperGun and OSSC upscaler until @RGB got me sorted out.

      I suggest updating to a modern SuperGun that’s still supported by its creator. The HAS and Sentinal SuperGuns on this forum are worth your attention.
    • Sync plays a significant role in the RGB to composite conversion. The F3 indeed has non standard timings and to make things worse, a weak sync signal.

      Nothing that can't be compensated for however it all depends on the quality of video circuit. I think you'll find your supergun will be fine via RGB. Not 100% confident with s-video as if it's not handling composite well s-video may also be of poor quality.

      RGB's HAS supergun has great video output as does my Sentinel Supergun, F3 included. Just sayin' :D
    • I've actually been think of upgrading superguns for a while now, and as soon as I considered the possibility my problems with the F3 were due to the Supernova, I immediately got myself placed on the interest list the Sentinel.

      I was however starting to worry that the F3 just couldn't handle being converted to composite or s-video at all, @Frank_fjs has popped in to reassured me that it'll work fine. I'm looking forward to the finished product! :thumbsup: