Pinned The Definitive Guide to Fixing Your CPS2 Multi Kit

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Unfortunately no. I'm still waiting for a Q1 supergun. Was told July but all signs point to October so I'll have to sit on this issue for a while. I plan on reflowing my cps io switches to get them working and then maybe redo the coax. After that, well not much choice left. I thank you all for your help, you've eliminated many possibilities and gotten me down to a few things to focus on. Love the community, keep it up! I appreciate any further suggestions.

      The post was edited 1 time, last by FakeNoose ().

    • Hello, I've just tried to install my multiCPS2 today on my revision 3 board and I have a purple screen after selecting a game and key writing ... I checked with an unencrypted game with same result ! As the board was working well few hours ago, I had to remove the battery and I shorted EXC5 (for few seconds, don't know if it's enough).
      I've checked continuity between different pin contact from B board to MultiCPS2 board and it seems OK. I've checked the 4 wire for key programming and it's OK too. I've put a GAL16V programmed with the PAL3 G version and I did connect pin 9 from GAL16V to J17. I also checked that the small board connecting the 2 main MultiCPS2 boards was in the right way.

      In the installation document, there is an instruction about the jumpers settings that says : don't touch them, let them as they are !
      But in a previous install document, I see instructions about the jumper configuration :
      SOOS SO OSOSOS SOSOSOSO SOSOSOSO (S=Short, O=Open)
      On my board I have
      SOOS SO OSSOSO OSOSOSOS OSOSOSOS

      It's quite different ... So, should I change the jumpers settings or not ? If not, what could be the cause of my issue ?
      Thanks :)
    • Ok thanks for the info ! The game was Super Street Fighter II: The New Challengers (Jap version) and it was working before trying to install the MultiCPS2 !
      I use a Sandisk 64GB microSD card, FAT32 formated. Could it cause these kind of issue ? I can select the games with the included screen and after flashing game and writing keys, the screen is always purple ... I tried the Punisher CPS2 "hack" with key bytes all to FF and it's still purple :(
      It's almost 4AM now here, I'll get some rest, I'm not able to thing anymore ...
    • What brand of SD card? Do you have a smaller one you can use, 64gb is massive...

      Things to confirm:
      - Key writing wires installed correctly
      - Try another SD card, preferably 32gb or smaller
      - Interconnect board installed the correct way
      - Multi kit is seated correctly


      Take some photos of key writing wires and the multi kit installation as well to confirm the above :)

      The post was edited 1 time, last by xodaraP ().

    • My sd card is a Sandisk !

      I did test the connection between multicps2 and b Board with a continuity tester, it should not be the problem !

      For the installation part :





      BTW I did program the GAL16V myself, I did extract data from it to check and the program is ok, but I did test with the original PAL3 chip I had and I also have a solid purple screen with it ! I also tested with no chip for PAL with same result ...
      I definitely have to test with a smaller SD card ! I’ll do it later today after my work day !
    • Ok your key writing wires are correct, try a smaller SD card (32gb or below, preferably 8gb)

      Did you extract the roll up pack to the SD card preserving the directory structure? You should have a folder called games in the root directory and all games within that

      Do you use a Mac? If so you need to run the dot_clean command to remove the preview files macOS creates automatically
    • Yes I kept the directory structure to have a games folder at root and I can view the list of games when using the buttons on the remote screen.
      But you are right, I have a Mac ... So I have some useless folders created on the SD Card ! I'll check that dot_clean thing that I didn't noticed, thanks for pointing that ! Not removing these files could lead to such malfunction ?

      Edit : my bad, I've just read the end of the installation procedure ... Everything is written here and it seems to lead to black/purple screen issue :S
      I feel so dumb ... I'll try that when I'll be home to confirm that this is really the reason why I slept only 4 hours that night :whistling:

      The post was edited 1 time, last by Sylver ().

    • Not removing the dot files will absolutely lead to malfunction, so they need to be removed

      If you're on a later version of macOS, Apple has added stupid security settings so you can't run dot_clean even on an external SD card without setting the permissions correctly. If you come across that issue I have a fix.

      Don't feel bad, it happens a lot and that's why it's all documented here. As we fix issues we add to the documentation for next time
    • Thanks for pointing this to me !
      My SD card is indeed a XC card ! I've ordered a Sandisk 32GB micro SD (non XC) and I'll try to find a small MicroSD to make some tests ... Thanks for all the info, the multiCPS2 is really not tolerant ! I also have a Darksoft Multi AES with the same 64GB MicroSD (and hidden MacOS files) and I have no issue at all !
    • Ok I tried to use one 4GB sd card I had in a new 2DS XL, copied few games, run the dot_clean script on the mounting point (after giving full disk access to the terminal elseway I had protection error as you guessed), and still had purple screen !
      I found a 8GB card, I did format it using a Windows virtual machine I had, copied some games, tried and it worked !!! Thanks guys, the problem I had was only due to sd card stuff ! It’s time to enjoy few games (and the fan noise ... I have to install a "silent" fan now ;)