RESOLVED: CPS2 Multi Troubleshooting

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • RESOLVED: CPS2 Multi Troubleshooting

      I received a CPS2 and multi-kit today from another forum member.

      The CPS2 was Marvel Superheroes. It had no battery and did nothing when I plugged it into one of my cabs.

      I installed the kit. It has an F Pal and I installed a wire from the pin on it to the one on the multi.

      I also installed wires for key writing.

      I wasn't sure which firmware was on it, so placed the file from one of Darksoft's post about the newer key writing FW onto the SD. When booting it seemed to take a while. I assume it was flashing. I did NOT have the key writing wires installed prior to that.

      Visually inspecting the installation, I'm not noticing any issues with the pins.

      At the moment I'm plugging the B board without a case into A. The connections seem pretty secure.

      The LCD comes on and browses through the games. I have the set linked in the smokemonster thread. I select a game and I get a greenish screen with thin diagonal lines while flashing, and when it's finished, I get a grayish blue screen with thick stepped diagonal black lines.

      I hear no sounds.

      I measure 5v at the JAMMA connector coming into the board when it's powered on.

      Any suggestions on troubleshooting this would be appreciated.

      Edit: forgot to mention jumpers. I believe they're all set correctly, but I'll double check. I only had to make changes in the 3rd bank of switches. Others were as needed already, IIRC.

      The post was edited 1 time, last by winteriscoming ().

    • I double checked jumpers, removed and re-installed all boards from the multi kit. I still get the same behavior.

      I'll try a different microSD card. I saw a recommendation for Samsung Class 4, but those don't seem to be readily available. Is there a card available on Amazon that are proven successful? I ordered a Samsung card, but assume the class is higher than 4 and I'm not sure if that's supported.

      My current card I'm using is a class 4, but it's a generic brand, IIRC.

      Another suspicious area of troubleshooting is my JAMMA harness. The only JAMMA cab I have is a light gun cab that I purchased with Area51 installed. The harness successfully powers that, an Atomiswave, a PGM and a couple others. I'm using it to test boards, but obviously am lacking controls.

      Anyway, I noticed that one of the ground pins and one 5v pin are unpopulated. Perhaps the CPS2 is not getting enough power due to unpopulated power pins on the harness? I've got a better harness on order from Twisted Quarter that will hopefully address this area of concern.
    • Sandisk class10 works awesome for me ... 16gb and you're good to go ! And i tell you this because i suppose you will install sometime the keywriting wires.Cheers :saint:
      Multi's: CPS2 / Taito F3 / Irem M72
      Superguns : HAS v3.1
      Scalers : OSSC v1.6 / RetroTINK-2X
      Scart switch : Gscartsw V5.2
      JNX: Spitfire
      NAC: Splitfire

      My Arcade Stuff

      [nes-101] [pce] [genesis] [segacd] [neogeo] [snes] [saturn] [psx] [n64] [gamecube] [dreamcast_ss]
    • winteriscoming wrote:

      I double checked jumpers
      Is this your first CPS2 Multi Kit?

      If so, just an FYI, some of the jumpers are bridged by traces from the factory... not solder, so you'll see the two half circles with a tiny hair-line traces connecting them and you'll need to cut that trace if the jumper is supposed to be disconnected. It's best to double check jumpers by actually metering them out because even a cut-trace could still be making some contact if it wasn't cut deep enough.

      I see this trip up a lot of people the first time they install a kit as this often looks like an open jumper on first glance due to the lack of solder.
      Buy 3D Printed Parts:
      Projects: instagram | blog
      Games: VAPS | VOOT | UMK3 | RFM | Vewlix | FiF Jr. | KI2 | E29 | Net City | DDR | Flash Beats
      Wanted | For Sale/Trade
    • It is my first CPS2 and my first multi for it.

      I have cut traces where needed and soldered together the jumpers per the instructions, and tested all with my multimeter. I even went back to all cut traces and dug them in a little deeper, even though they already registered as open.

      I have the F Pal and lifted pin 7 and wired it to the pin on the multi.

      For the record: it was an unused multi kit from Paradise Arcade. I received it in the original sealed mailed package, inside a larger package with the CPS2 from someone who hadn't opened it. I just wanted to make sure no one's under the impression it was a used damaged multi.

      The post was edited 1 time, last by winteriscoming ().

    • Here are a few pics.

      I received a JNX adapter today to play JAMMA in my MVS-wired cab. I tried the CPS2 on it, and get similar results to what I had before. The resulting screen after flashing/reset doesn't look the same, but it's still stuck at that point.

      I'll hopefully get my other B board next week. I hope it's not the A board that's bad, but I know so little about these boards at this point, that I'm not sure how to troubleshoot beyond having an entire 2nd set that works to swap between.

      Edit: In case it's not obvious - both A and B boards are removed from their casing.
      • 1550169009591982.jpg

        161.96 kB, 2,448×1,836, viewed 65 times
      • 1550169008975356.jpg

        322.25 kB, 2,448×1,836, viewed 68 times
      • 1550155749067997.jpg

        154.4 kB, 1,836×2,448, viewed 69 times
      • 1550169008343319.jpg

        231.96 kB, 2,448×1,836, viewed 61 times

      The post was edited 1 time, last by winteriscoming ().

    • The new B board showed up today. It's a working Marvel Superheroes. However, unfortunately, it's a rev 3 and CN6 is unpopulated. I don't mind the extra steps for the rev3, but I'll have to get CN6 populated before I can test the kit.

      Anyway, since the new B board works, I have ruled out a bad A board.

      The post was edited 1 time, last by winteriscoming ().