MV4FT2 with sound issues

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • MV4FT2 with sound issues

      Hello, I have a MV4FT2 board that I'd like to repair.

      Using the Neo Diagnostics the board showed a Video Ram error. I replaced both 62256 VRAM chips and after that all I got was a white screen that turned cyan after a second. I was really pissed off thinking I broke it, but I tried again. Poking some SMD custom chips the board showed signs of life again :) finally I found the culprit: the LSPC2-A2 needed a reflow.

      After reflowing LSPC2-A2, the board passed all tests but it was stuck at the crosshatch of death. With a cartridge in slot 1 I can use the memory viewer and looking at address 0x100 I can see "0x4E00 0x4F00 0x4700 0x4F00" instead of "0x4E45 0x4F2D 0x4747 0x4F00". I did this

      - Replaced the two 470µF capacitors
      - Checked continuity between d0...d15 Neo-G0 at B1 with CN10 according to Neo-G0 pinout and MV4F pinout
      - Reflowed B1 and B2
      - Checked continuity between cartridge 1 and B1. Noticed a typo in the MV4F pinout link: pin 39 connects to CN9-13A (the document indicates CN9-13)

      Lower data signals reach 74LS245 at C11, I replaced it and now I can boot games. Not all games work in all slots and I have sound problems: Metal Slug 2 misses some melody sounds, and Pulstar doesn't play the melody. Both carts work fine in other machines, and the slots and cartridges are very clean.

      One of the two channels sounds a bit less loud in the hardware tests, but both sound. Things I have tried so far:

      - Clear the backup ram
      - Replaced all electrolytics caps
      - Tested 74LS245 at M2, N2, M3, N3
      - Replaced Yamaha YM2610
      - Replaced Yamaha YM3016
      - Replaced Z80
      - Replaced Z80 memory (6116)
      - Replaced 2066D
      - Replaced 2003 (BA12003)
      - Extracted and changed order of the three 4558, no change
      - Neo Diagnostics all tests passed, even using the M1 ROM keeping +D pressed at boot
      - 2M and 2N test ok. In the MV4F I think they are data latches for the YM2610.
      - Tried a SM1 rom from a parts board. Same sound problem.
      - Tested with stock bios and Unibios 3.3

      The board came with a blob of solder and a cutted trace to make it jamma compliant. I've removed the blob and restored the connection to make it stereo as it should be originally.

      I'm running out of ideas. Is it possible this is caused by some broken trace or IC at the top board? games CRC checks are fine according to Unibios tests. Maybe the problem is the Neo-D0 custom chip?

      The post was edited 16 times, last by rsignal ().