[Repaired] Captain America and the Avengers Repair Log

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • [Repaired] Captain America and the Avengers Repair Log

      I thought it was time for me to try repairing boards. I probably don’t have much of a knowledge about it outside of reading a bunch of logs, nor do I have half of the equipment, but we all have to start somewhere! The plan is to build both up as I go.

      Writing this here will help me to stay accountable and hopefully receive some tips and advice :)

      So got this Captain America and the Avengers from Data East for a low enough price, disclosed as booting but with issues, mostly sound.



      It came in full of dust, and dead flies/cobwebs/egg sacks. Yikes. I brushed most of it off and will definitely Simple Green and wash it as soon as possible. This is after brushing it X(


      I noticed already some dirt and corrosion that I will have to look into once cleaned up



      Booted it to do an initial check, and almost no image with a big loud buzz.
      Pushing gently a bit on the EPROMs randomly managed to get me an image and eliminate the buzz! But the colors are wonky (missing).



      Sometimes, the image gets garbled and pressing a bit on the board fixes it



      Adding a credit to leave the attract mode, the sound plays good, music and SFX!

      It seems like the debug is enabled though, and I will have to lookup the dip switch settings.




      At least the game is alive and responsive. The fact that I can have sound, image and controls seems to be a good thing.

      Next step will be to remove all the chips, give it a good cleaning overall, clean the sockets and legs and do a visual inspection to see all that can potentially be broken (traces, legs, etc).

      To be continued!
      Multi Systems: Sega STV + DS Multi | CPS2 + DS Multi | CPS3 + DS Multi | Taito F3 + DS Multi | MVS + DS Multi | Naomi 2 + Pi Netboot | Atomiswave | Taito G-Net + 2011 Bios | Taito TypeX2 + Niko Multi | M72 + Apo Multi
      Cabs: Tecmo Kyotaro | Tekken 5 NNC

      The post was edited 1 time, last by Takosuke ().

    • Next step was to remove all the chips for a deep cleaning.

      It was even nastier underneath:


      After using a nice paint brush to remove most of the dead insect parts and spider egg sacks, I prayed the entire board (both sides) abundantly with Simple Green.

      Rinced it slowly in the sink after letting the Simple Green rest for a minute or two, then removed more stuck dead insect parts and did the same process once more for good measure.

      I let it drain and dry a little bit, and then used my ESD protected Air Duster to push the excess water out of the sockets and help the drying process (now more than a minute or two at a time).



      I let the board rest for a day and a night in the nice hot Californian weather, using the Air Duster a few more times once in a while.

      Next step was to do a full visual inspection of the board.
      • Nothing major detected, no lifter legs on the legs of the chips, but a few scratches on the traces.
      • Used the multimeter to check continuity and all seemed fine.


      Before doing more tests, I proceeded to cleaning the EPROMs and Pals.

      • One of the EPROMs had a bent leg that I managed to carefully salvage while cleaning it.
      • For the rest, I used a nail filer to carefully clean all the dirt off from the legs.
      • I then re-seated all of the chips in their sockets to do a quick test:




      Colors are back, screen is stable for the Attract mode!

      I let it run for a while and all good!



      Starting the game gives me still that debug code :/


      But pressing start on player two made it disappear!!



      Played the game for about 25 minutes with no issue!

      • Image good, controls good, sound perfect.


      Success! It was an easy one!
      Multi Systems: Sega STV + DS Multi | CPS2 + DS Multi | CPS3 + DS Multi | Taito F3 + DS Multi | MVS + DS Multi | Naomi 2 + Pi Netboot | Atomiswave | Taito G-Net + 2011 Bios | Taito TypeX2 + Niko Multi | M72 + Apo Multi
      Cabs: Tecmo Kyotaro | Tekken 5 NNC

      The post was edited 1 time, last by Takosuke ().