Taito G-NET flash problems "CanNotFindProgramRom. Error B930" *(updated with motherboard jumpers!)

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Taito G-NET flash problems "CanNotFindProgramRom. Error B930" *(updated with motherboard jumpers!)

      Hello!

      Trying to flash my (original?) bios into the modbios 2011 but I cant seem to get around thir error: CanNotFindProgramRom. Error B930

      I removed the game CF, shorted the jumper JP1, put in a 27C800 containing the bios, and then start the game.

      I have even read out the bios again from the 27c800 and verified its crc is matching.. I cleaned the pins and socket on the motherboard, nothing, still the same error...

      Original games play fine.. Do I need to update to MB2009 version before going to 2011 perhapps?
    • Your order of operations for updating the bios reads wrong to me. You don't play the games with the bios chip installed in the socket, it's only used to flash the bios to the motherboard:

      Remove the CF/Game
      Add the jumper
      Add the ModBios
      BOOT THE GNET
      wait
      wait
      bios flashes
      wait
      when it says it's done, power down
      remove the jumper
      remove the bios
      insert CF/Game

      (also use these chd's ikotsu.co.uk/GNet/)
      multis: cps* ttx2 gnet f3 mvs sega st-v/16b/24/c2/naomi(netboot) sys2x6 m72
      cabs: sega blast city x2 | taito vewlix c + egret ii
      links: klov/vaps games list | custom fight sticks
      projects: test bench
    • ekorz wrote:

      Your order of operations for updating the bios reads wrong to me. You don't play the games with the bios chip installed in the socket, it's only used to flash the bios to the motherboard:

      Remove the CF/Game
      Add the jumper
      Add the ModBios
      BOOT THE GNET
      wait
      wait
      bios flashes
      wait
      when it says it's done, power down
      remove the jumper
      remove the bios
      insert CF/Game

      (also use these chd's ikotsu.co.uk/GNet/)
      My order is exactly same as yours:

      Copy from first post:
      I removed the game CF, shorted the jumper JP1, put in a 27C800 containing the bios, and then start the game. (BUT here I wrote GAME, and I mean the whole motherboard, GAME is removed ofc :) )

      sorry that I was unclear :/
    • MoppelTheWhale wrote:

      i'm pretty sure my board was on stock bios when i updated it to the 2011 bios - do you have a secon eprom to try out?
      nah I dont have a second one :(. But since I can read the eprom again in the programmer and verify the CRC it "should" be ok... hmm

      I programmed it with my tl866 but split BIN and used the profila 27C4096 x2 instead.. second pass with A18 high..
    • How is the jumperconfig supposed to be on the G-NET pcb where you "close" JP1 jumper when updating? It also has JP2, JP3, JP4 in the same area..

      Mine are:

      JP1 - Closed (only closed when trying to update)
      JP2 - Closed
      JP3 - Open
      JP4 - Open

      I didnt have the update bios in the socket at the time when I took the pic.

      Thanks!
      Images
      • 20190504_101751.jpg

        697.58 kB, 1,594×897, viewed 6 times
    • did you remove the pcb that is suppoed to be above the other jumpers or are you missing that pcb in total? - i'll look later when i'm on my break, but i have to remove the pcb first.

      UPDATE:

      i just had a look - with your photo i didn't have to remove the pcb:

      JP1 bridged only for update
      JP2 bridged
      JP3 open
      JP4 bridged

      i hope that helps

      The post was edited 1 time, last by MoppelTheWhale ().

    • MoppelTheWhale wrote:

      did you remove the pcb that is suppoed to be above the other jumpers or are you missing that pcb in total? - i'll look later when i'm on my break, but i have to remove the pcb first.

      UPDATE:

      i just had a look - with your photo i didn't have to remove the pcb:

      JP1 bridged only for update
      JP2 bridged
      JP3 open
      JP4 bridged

      i hope that helps
      Thanks! I will see what JP4 does when I am back home then.. :D. I just removed the top pcb when inspecting the jumpers, in case there were more jumpers or damages.
      I checked that the eprom is powered ok so there is something with the communication.. I wonder if the flash rom is 3.3v.. but then again.. if there was a problem with the flash, then the board wouldnt boot at at.. :/
    • I had no “issues” with the standard blue & red 128mb Sandisk CF cards. However, a few in the batch of the 15 I bought only formatted to 64mb. That didn’t really matter as the smaller games fit on those cards just fine.

      Cheapest seller I found on eBay was ea_memory. Hope that helps.
      Multis: CPS-2, CPS-3, F3, ST-V, MVS, M72, G-Net
      PVMs: 2043MD, 20M2MDA, 20L2MD
      Supergun: Sentinel / XRGB-mini
      PCBs: VAPS Profile

    • bytestorm wrote:

      Hello!

      Trying to flash my (original?) bios into the modbios 2011 but I cant seem to get around thir error: CanNotFindProgramRom. Error B930

      I removed the game CF, shorted the jumper JP1, put in a 27C800 containing the bios, and then start the game.

      I have even read out the bios again from the 27c800 and verified its crc is matching.. I cleaned the pins and socket on the motherboard, nothing, still the same error...

      Original games play fine.. Do I need to update to MB2009 version before going to 2011 perhapps?
      One of my G-NET mobo has had this issue before. I found some traces were cut/broken near IC and socket. After I repaired those traces, the BIOS could be flashed.
      I suggest you use a multi-meter to check all the traces leading from the BIOS socket.
    • KoshiroKazuma wrote:

      bytestorm wrote:

      Hello!

      Trying to flash my (original?) bios into the modbios 2011 but I cant seem to get around thir error: CanNotFindProgramRom. Error B930

      I removed the game CF, shorted the jumper JP1, put in a 27C800 containing the bios, and then start the game.

      I have even read out the bios again from the 27c800 and verified its crc is matching.. I cleaned the pins and socket on the motherboard, nothing, still the same error...

      Original games play fine.. Do I need to update to MB2009 version before going to 2011 perhapps?
      One of my G-NET mobo has had this issue before. I found some traces were cut/broken near IC and socket. After I repaired those traces, the BIOS could be flashed.I suggest you use a multi-meter to check all the traces leading from the BIOS socket.
      Thanks, but I already tried that. And it connects good to nearest component. Overall this board is in very nice condition. Voltages are good also..
    • I will try the chip from MoppelTheWhale and I will also try and read that chip with my TL866.. I have a feeling something is not correct with this programmer or adapter.. it was really cheap.
      But then adain.. the programmer has worked great before.. the adapter is the first time I use, but its really simple and he had sold ALOT so I dont know.. Its not any advanced sh*t to program a 27C800 in 2 passes as a 27C4096...