Black screen on boot

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Black screen on boot

      I've been having some trouble on my supergun with my cps3 not booting like normal. The supergun itself appears to be in working order since it's loading my NeoGeo just fine and the 3s board itself does turn on.

      If I boot the board with no cart in, I get a scrambled image and when I boot with the cart in, I get a blank screen and that's it. Based on this, I'm inclined to think that there is something wrong with the cart but I don't really know what could be the case.

      The only real changes that I've made from when it was working to now was moving to Canada but upon looking at the PSU, it is rated to work from 100-240v and as mentioned above, it runs my NeoGeo with no issues. The only change to the CPS3 setup itself is using the SCSI2SD which has been working without issue when I was using it in the UK. I'm not using the molex cable since it's not needed it but maybe that's it.

      I've attached some pics of what it looks like and any help would be much appreciated.
      Images
      • cps3_cart.jpg

        650.97 kB, 1,740×2,320, viewed 75 times
      • cps3_no_cart.jpg

        553.01 kB, 870×1,160, viewed 31 times
    • I just cleaned the cart and it's a no go. But I think that it is the 5v since I tried it with my cps2 and that behaved the exact same way. Certain weirdness I can chalk up to the CPS3 being temperamental at the best of the times but the CPS2 tends to not give much fuss. I'm willing to bet it is the PSU.
    • Smallcab delux supergun with the below Powersupply.

      smallcab.net/arcade-power-supply-5v15a-12v25a-p-98.html

      A buddy of mine made it for me in the UK and put it in a nice enclosure back when I didn't know a lot (still learning though). The wiring on the inside isn't great but I do suspect it's a PSU thing. Tried the NeoGeo this morning and it will boot but it will take a substantial amount of time before it does and then will boot just fine for subsequent runs. Almost like it was warming up but again, that's not something that I experienced when I used this thing in EU.

      Right now my conclusion is that the PSU is just not very good and I could test it with a new PSU or just get something like the Windy Gaming one and have something simple that suits my needs.

      Thanks for all the help guys!
    • In addition to cleaning the cartridge, I would suggest cleaning the cart slot... very carefully. I use a piece of thick cardboard. not corrugated, but a thick card stock. If it's not quite thick enough you can fold it in half. I then cut it so that it's smaller than the width of the slot so it can go in and out easily. Spray it down with either a contact cleaner spray or just isopropyl alcohol and work the cardboard in and out over the pins to brush off any crud. make sure it's fully dried out before reattaching and powering up!
      Woodies: Xevious, Pac-Man, Dig Dug, Donkey Kong, Joust Cocktail, Space Invaders, 3-KOAM Red Angle
      Candies: 3x Aero City, New Astro City, 2x Blast City, Net City
      VAPS
    • XeD wrote:

      What part of Canada are you in?
      I'm in Nova Scotia. Just moved to Halifax.

      xodaraP wrote:

      Stop using that PSU. The PSU sounds like it's failed and it will cause damage if you try to make it work by turning up the +5 adjustment

      Those are a cheaper PSU and while they work, they're not great. I'd recommend spending the money on a Happ or a Peter Chou. CPS3 isn't cheap, don't ruin it with a cheap PSU
      Yeah, once I cracked it open and did a bit of reading that was the conclusion that I've come to aswell. I'm going to see if I can swap out the PSU but the thing is damn near glued in which I'm not a fan of in the first place. Looking over the wiring inside I think I can now do a better job myself with it.

      Totally agree that I'd rather not risk blowing up my CPS3. It still actually turns on without the cart so I'm reasonably comfortable that I haven't destroyed it.
    • XeD wrote:

      To bad your not in the west coast, I would have tested for you. Black screen on boot (even with garbage with no cart) is a cart/cart slot problem for the most part. If it end up being a bad cart, let me know and I can help out.
      Really appreciate your help and I'm not counting it out. I'll definitely let you know if I need someone to test it.
    • Remember as well that the main CPU for CPS3 isn't on the motherboard, it's in the cart. That's why you run into so many issues if the cart edge or slot is dirty

      The garbage screen above is typically what you see when an SH-2 CPU is loose and needs a reflow or damaged as well. You would absolutely see that if it's not making good contact due to a dirty slot/edge
    • It's been a while and this was quite low on my priority list but wanted to leave an update for anybody that may stumble on this thread in the future.

      The issue was definitely the power supply and I have a much better one in there now and the game is running without any issue. Quite lucky that the PSU didn't cause any damage either. So a happy ending all things considered; albeit one with quite a bit of delay.

      Naturally it looks good on the CRT but I've also got it running through the OSSC at Line 4x with it's scanline generator and the result is really crisp. Wouldn't use it for serious play but quite nice when I've got some friends over for a casual session.

      Cheers for the help guys.