Fast IO to Jammafier

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Fast IO to Jammafier

      The long and winding quest to install Fast IO in my JVS cab is coming along.

      I managed to pick-up a TTX2 unit with the Fast IO DMAC, and this morning the Fast IO jamma board arrived. I've plugged everything in (slightly guessing which connections to use, as there isn't much documentation around on this) but now a bunch of TTX games on Niko's multi no longer load. Sigh!

      My chain is: TTX2 board > Fast IO > Jammafier > New Net City/ JVS cab (I *think* this is the set-up a couple of users here use).

      Could someone check my connections to see if I have everything set-up correctly? Do I need to change any dips? Some games (e.g. Trouble Witches) work fine, but others, such as SSIV, just go to a blank screen now...

      Also, I know I am currently missing the RFID reader -- I'm about to track down one of these as the final piece in the puzzle.

    • Still struggling to get this working. Niko's multi loads with no issues, and about half the TTX2 games run exactly as they should through my Fast IO set-up.

      But some (.e.g BF, SSFIV) show a blank screen on load (when loading in the monitor switches off and on, as if it's changing resolution.) Any idea what might be causing this?

      I noticed there are three sets of dip switches on the fast io itself and wondered if it might be how these are set (I think this board came out of a Vewlix with a HD screen, and I'm running it in a Sega New Net City which has a tri-synch CRT?

      The dips are current set (from left to right):

      SW2 = OFF
      SW4 = ON
      SW3 = OFF

      Any help gratefully received!

    • Im guessing the video is the problem. Can SF4 on Taito X2 even be set lower than 1280x720?

      New Net is 31khz max, if so that's beyond your display ablity... Need downscale first.
      Darksoft: CPS3, CPS2, F3, MVS
      RGB: RECO v2, HAS v3
      invzim: Jammafier v1.6b
      XianXi: JNX Raiden, SC Taito Classic, SC Sega System 16/24
      Frank_fjs: JAMMA Extender (Special Edition)
    • Having run a few tests across two TTX2s I'm pretty sure a hardware issue rather than a software one. I reckon the DMAC might have a problem (frustrating as this is the part I specifically bought a second board for!)

      The Fast IO DMAC has a six pin male connector on the side of the PCB (see below). Is this supposed to be connected to anything?

      There's no documentation for this stuff anywhere! Can't even find a TTX2 Japanese manual online, alas.

    • If you let SSFIV sit at the black screen for awhile (2min or so) does it eventually load?

      I've noticed that SSFIV seems to have issues with my FastIO to JVS emulator.

      Someone brought this to my attention awhile back, and I investigated.

      I could only reproduce this issue on an X2, and all logging of I/O activity shows that everything is normal.

      I even tried to slow down the JVS emulator by blocking in ReadFile to simulate the wait for I/O but it didnt make a difference.

      I legit have no idea why this happens with SSFIV.

      I might investigate again and see if I can find anything.
      Want to show your support for the Freeware X2 Multi?: Buy Niko a Beer! :thumbsup:
      Official Freeware Taito TypeX2 Multi Thread
    • Niko wrote:

      If you let SSFIV sit at the black screen for awhile (2min or so) does it eventually load?

      I tried this today with SSFIV, and I'm afraid it didn't display after the 2 mins. The issue for me isn't that the game is not loading, but that the system seems to be switching to a resolution incompatible with my 31htz screen when I click to load certain games from the frontend. I can always hear the game sound running in the background, so it's definitely a display issue.

      Your post reminded me that I have an old SF4 (original ver) drive and USB dongle sat in a cupboard, so I tried this with my Fast IO and it loaded/ displayed correctly, where the NikoLoader version doesn't, so it seems the issue is (probably) not with my DMAC after all.

      For reference I'm using a model 217A with upgraded RAM.

      Ack, never mind. Guess I will go back to a straightforward JVS set-up and wait for the new version of your loader to drop. thanks for the suggestion!