What's new
Ahhh... these damn boards. I ended up sending my to Chad and has been working like a champ so far. But, If it ever goes out again I'll just put an ms9-29.

I give you mad props for tackling the ms8.
But boy, when they work it's just beautiful.
Wonder what its causing all that garbled image.
 
Ahhh... these damn boards. I ended up sending my to Chad and has been working like a champ so far. But, If it ever goes out again I'll just put an ms9-29.

I give you mad props for tackling the ms8.
But boy, when they work it's just beautiful.
Wonder what its causing all that garbled image.
chad?
 
Chad is https://arcadecup.com/.

I sent my MS8 to him, it took 5 months. It still went into HV shutdown when I got it back and then he stopped responding.
Thanks notsonic.

Yeah, that is true it takes a while till you get your board back. Damn, sorry to hear that your board still didn't work man. And yeah he either, won't reply or when he does it will be months later or not at all. The only communication is printing out he's form from website and send it with your board.
 
None of you guys can tell what was replaced in your chassis to get them going by visually looking at the board?
So far I replaced a lot of stuff on there and still haven't had any luck.
 
I can't find the repair form, but what I do remember from the form he wrote capkit installed and some trace or pads repair and cleaned. I guess I messed something up when I did capkit or something. But it was working fine after I did capkit and then, one day it just stopped turning on. Sometimes it turned on and sometimes it didn't. So I just shipped it to him before it got worst or for safe measure. In fact... yesterday when I was installing mame pc via jpac monitor dint have a glow or turned on. So I turned off and on again and it was fine. I don't know anymore.....

I didn't see anything new on my board that I could see.
 
Back
Top