What's new

jimmyjames

Enthusiast
Joined
Aug 30, 2018
Messages
214
Reaction score
203
Location
Kendall NY
ok so I took delivery of two projects Friday. Only mishap was the STI delivery guy slipping on ice and busting his ass. Machine fell on him but no damage cosmetically. The first thing I wanted to do was get them inside and give them a cleaning. I started by pulling monitors making them much lighter and easier to move. Sat and Sunday I had some time to break down everything on the blast and clean it. Scrubbing the snot out of it with super warm water, simple green and finally using a magic eraser. Still not done but the inside and all it’s contents are clean.









The chassis that came with the blast is from a Naomi universal it also came with the original 2931-s according to the seller it was working before it was shipped to him and when he received it wasn’t so he put the Naomi universal chassis in it however picture was dim. More on this as I put things back together and possibly do some recapping and such. Need to possibly send the original out to sharp if I can’t figure it out.

The power supply was gross af. Seriously
 
Last edited:

jimmyjames

Enthusiast
Joined
Aug 30, 2018
Messages
214
Reaction score
203
Location
Kendall NY
today I put together the power supply and bolted the CP Assembly to the cabinet. Tomorrow I’m going to test the power supply and make sure it’s reading correct voltage ect. Then on to the chassis and B+ testing. I’m sending the control panels to a friend that’s a metal worker to repurpose them.
 

KalessinDB

Grand Master
Joined
Jul 22, 2015
Messages
1,195
Reaction score
809
Location
Rochester, New York
If you're looking for 2p panels, @Suzuki_Bison should have at least one spare from when he bought mine, possibly more (I think he's going to 1p panels)
 

jimmyjames

Enthusiast
Joined
Aug 30, 2018
Messages
214
Reaction score
203
Location
Kendall NY
If you're looking for 2p panels, @Suzuki_Bison should have at least one spare from when he bought mine, possibly more (I think he's going to 1p panels)
nah I am not a Big fan of two player panels. I have ones on the nnc but I’m going single as I play a lot of shooters and non fighting games. The Astro is for Tate and the blast is for stuff like black tiger, gradius, rtype, Gng, jungle hunt ect.

However I thought of trying to make the blast and NNC head to head but not sure if that’s even a possibility yet.

Off to work I go can’t wait to test the power supply later. I pulled it apart and literally the metal was black where the power supply connects. There was so much dirt and filth. The Astro is not bad at all really just normal nicotine levels. So still pretty gross but this takes the cake. Not sure if I mention but coin counter has 50k on it.
 

hoagtech

Grand Master
Joined
Mar 28, 2019
Messages
1,041
Reaction score
1,015
Location
Bellingham WA
Looking forward to see what you do your Blast chassis.

I'm in the same boat.

Good luck dude.
 

nem

Enlightened
Joined
May 29, 2016
Messages
3,552
Reaction score
2,613
Location
Finland
I’m sending the control panels to a friend that’s a metal worker to repurpose them.
Repurpose?

Man, those are OG Versus City panels that look to be in pretty nice condition. IMO sell them to someone that could use them.

If I were local I would buy them in a heartbeat.
 

jimmyjames

Enthusiast
Joined
Aug 30, 2018
Messages
214
Reaction score
203
Location
Kendall NY
I’m sending the control panels to a friend that’s a metal worker to repurpose them.
Repurpose?

Man, those are OG Versus City panels that look to be in pretty nice condition. IMO sell them to someone that could use them.

If I were local I would buy them in a heartbeat.
the new vs city is really rusty and bent a little gonna need some welding I think and restoration. The other vs city needs a wire brushing as it is rusty.
 

nem

Enlightened
Joined
May 29, 2016
Messages
3,552
Reaction score
2,613
Location
Finland
Yeah, my mind instantly went to them being cut, drilled and put in some Mame atrocity.

Nevermind!
 

jimmyjames

Enthusiast
Joined
Aug 30, 2018
Messages
214
Reaction score
203
Location
Kendall NY
well I’ve got glow, tested the power supply seemed To be ok. Gonna get a cap kit for it and the audio amp. New fan for it.




the picture is dim and a little blurry, my guess is that the Chassis needs a cap kit. I used the ms2932 Naomi universal chassis. I looked at the original chassis but it’s missing some heat shielding around the flyback and it’s plastic base so until I get those no point in messing with it. Tomorrow I’ll start it cold and see how long it takes for the picture to come on. I’ll also look around and see if anyone else had had this same issue




 

kuze

Champion
Joined
Jul 22, 2015
Messages
1,877
Reaction score
1,266
Location
DFW
the picture is dim and a little blurry, my guess is that the Chassis needs a cap kit.
Similar issue when you pair a 30/31 with a 2933 chassis
I've gone 2930 to 2933 chassis -> dim picture, but I've also done 2931 to 2933 and brightness is right.

That said I have no experience with a 2932 and you're probably spot on.
 

kuze

Champion
Joined
Jul 22, 2015
Messages
1,877
Reaction score
1,266
Location
DFW
the picture is dim and a little blurry, my guess is that the Chassis needs a cap kit.
Well for the blurriness, you can try and tweak the focus pot on the flyback.

The dimness could just be you need to calibrate colors/brightness and/or tweak screen knob on the flyback. If that stuff doesn't resolve it, could be the heater resistor swap needed like @nem mentioned.
 
  • Like
Reactions: nem

ebzero89

Student
Joined
Sep 26, 2016
Messages
197
Reaction score
48
Location
​Atlanta, Georgia
I've also got a 2933 on a 2931 tube/yoke. Definitely took a bit of work to get the brightness correct and it wasn't good out of the box for sure, but it does have the same brightness as my 2931.
 

nem

Enlightened
Joined
May 29, 2016
Messages
3,552
Reaction score
2,613
Location
Finland
Well for the blurriness, you can try and tweak the focus pot on the flyback.

The dimness could just be you need to calibrate colors/brightness and/or tweak screen knob on the flyback.
This is true, and absolutely the first thing you should do. If someone put a chassis on the monitor just to get it working, it's possible it's just badly calibrated.
 

kuze

Champion
Joined
Jul 22, 2015
Messages
1,877
Reaction score
1,266
Location
DFW
Right, 2933 chassis on 2931 tube/yoke
That's interesting. Can you check what heater resistor you have in there?
That may be difficult, as the cab is sandwiched in place. I'm pretty sure it hasn't been changed though.

Someone has definitely posted the 2933 resistor value before, I can help dig it up if needed.
 
Top