What's new

djsheep

Multi Boyz Overlord
Immortal
Multi Boyz
Joined
May 20, 2016
Messages
6,760
Reaction score
11,227
Location
Brisbane, Australia
I'm happy to announce that the list for Australia / New Zealand is officially closed, done and dusted (never again!).

Had a few people on the list not respond or try to negotiate terms, so there's just 3 units available for Australia & New Zealand and they are live now at: www.candycabclub.com/product/cps1

Don't sleep!
 

djsheep

Multi Boyz Overlord
Immortal
Multi Boyz
Joined
May 20, 2016
Messages
6,760
Reaction score
11,227
Location
Brisbane, Australia
247199BB-83D0-460D-9E48-919F965D3A39.jpeg


LCD Selector cases are ready and waiting for everyone who ordered Deluxe kits from CCC :)
 

djsheep

Multi Boyz Overlord
Immortal
Multi Boyz
Joined
May 20, 2016
Messages
6,760
Reaction score
11,227
Location
Brisbane, Australia
I'm worried you're taking this photo while standing in waist deep water. All good your end?
All good, I just emailed you. Monday was a big cleanup, have a humidifier running non stop and we’ve had sun here thankfully which has let my car dry out to a driveable stage.

We will see if my 4 CRTs that got water damage will work. Lost some sentimental stuff in the flood, but there’s people affected way worse up here. It’s headed south, so if it comes to your city, be prepared. It’s definitely almost as full on as the 2011 floods we had here.
 

xb74

Professional
Joined
Mar 11, 2016
Messages
260
Reaction score
338
Location
Australia
I hope those CRTs survive!!
My best wishes to everyone in Sth East QLD right now, hoping you all pull through and can get back to regular life with some gaming time.
 
Last edited:

djsheep

Multi Boyz Overlord
Immortal
Multi Boyz
Joined
May 20, 2016
Messages
6,760
Reaction score
11,227
Location
Brisbane, Australia
Heads up to all those Aussies and NZ’ers who were part of the pre-order here on the forums.

The first half of the multis are due to arrive Thursday and will hopefully leave by the end of next week. Will DM everyone with tracking info, etc.

The other half of the multis will arrive the following week hopefully.

EVERYONE who pre-ordered via the forums will be getting a QSound chip.

I had a few orders on CandyCabClub and accidentally oversold my initial allocation, so one of those will be the "elusive" FPGA chip, so it actually will be a lottery of sorts :) for those few people.

Can't wait for Aussie and NZ peeps to be up and running! Thanks for your patience everyone!

p.s. if anyone needs anything else from the site with their order, drop me a PM… postage won’t cost anything more.
 
Last edited:

nidulans

Student
Joined
Jun 7, 2020
Messages
61
Reaction score
124
Location
Melbourne, Australia
Huge thanks to @Darksoft for creating the amazing CPS1 Multi, to @djsheep for fantastic packing (huge fan of the new trend of putting lollies into all my orders... even if I never get to eat them myself), and to @sheep_nova for a very clean hassle free C-board.

Just as an aside. I ran into the Mac problem (of hidden system files when creating the SD card). It was my intension to find out if it was any hidden file or specific to the Mac... but I played C&D instead... If anyone runs into problems where the file list isn't displayed correctly when cycling through on the multi it it Mac related. Depending on the game, when written they would boot to a blank screen of various colours, flashing screen with random game sounds or the jumbled graphics you see while writing.
 

DRAGONKZ

Enthusiast
Joined
Jun 16, 2021
Messages
89
Reaction score
172
Location
Sydney
I got mine today, only had enough time to open it and see if I was part of the Q sound lottery but it looks pretty good!

Thanks again!
 

Esoteric_rt

Student
Joined
Dec 1, 2020
Messages
25
Reaction score
21
Location
Christchurch, NZ
Got mine on the weekend and set-up. The soldering made me a bit nervous as there isn't much room for error. But all worked out OK.

The CPS1 motherboard I used was already running in my Astro City. After I swapped in the multi, games were freezing in attract mode after about 5 minutes. This was due to the multi needing a bit more juice from the PSU. I bumped it up to an even 5.0v (measured on the multi fingerboard when running) and its been rock solid since.

Pretty awesome piece of kit!
 
Top