What's new

winteriscoming

Champion
Joined
Feb 16, 2016
Messages
1,389
Reaction score
1,078
Location
Indiana, US
My recent acquisition of a pair of Maximum Tune cabs came with Chihiros. GD-ROM works and boots Maximum Tune fine, but I want to netboot Maximum Tune 2 and other games. Yesterday on the first one to make it to my basement, I successfully updated the firmware and got it to netboot Maximum Tune. Later that evening I went back to netboot it, but every time the game would come up with Caution 51 and some wording about horizontal frequency not being set correctly. I had not changed anything, but finally found a reference to this error in an Outrun 2 manual, with very unhelpful fix other than generically saying to check some DIP switches without saying how they should be set. I triple checked the filter board DIPs against my other Chihiros and they were the same. I then disassembled the Chihiro and cleaned it up around the connectors from the filter board. I put it all back together and kept getting the same error!

OK - let's troubleshoot this thing starting from the source. What happens if I check the operation of the DIP switches?

Ugh! Switch 7 seems to have spontaneously stopped registering as ON even after I toggle it back and forth several times in hopes that it will start working again. This is one of the switches that sets the video mode and apparently being toggled to OFF makes it go into an unsupported mode for any game I tried booting. The simple hack fix was to bridge the pin for switch 7 to switch 8 which was also ON. A more ideal fix would to be to replace the DIP switches altogether, but since they just need to be set the one way for my setup, I'm sticking with the hack for now.

All good and netbooting games successfully now! :thumbsup:
 

twistedsymphony

Enlightened
Staff member
Immortal
Joined
Jul 21, 2015
Messages
9,534
Reaction score
8,688
Location
NH, USA
What a weird problem... I don't think I've ever seen a dip-switch bank fail. I can't imagine it'd be that difficult to find a replacement dip switch bank, then again I don't think there is any reason to ever change them so there's no real harm to your fix.

It'd be nice to know what they actually do though. Even if the games only support one specific setting it gives us clues as to some of the things they had planned for the system. For instance on the Lindbergh there's a switch for vertical mode despite none of the released games supporting it.

On my never-ending to-do list is figuring out the function of each of the Chihiro's dip switches. it's not documented anywhere at all to my knowledge. at least not beyond "use this configuration to make it do".
 

winteriscoming

Champion
Joined
Feb 16, 2016
Messages
1,389
Reaction score
1,078
Location
Indiana, US
@twistedsymphony, did you end up with a working Chihiro?

I honestly don't know what most of the filterboard switches do.

The "Outrun 2 Twin.pdf" manual I found a reference as follows:
Caution 51
Wrong video output setting of horizontal scanning frequency setting.
Change the No. 2-4 and 6-8 DIPSW correctly on the CONNECTOR BOARD.
The monitor must support these frequencies.

I actually don't know if it's a dash between the numbers because my pdf reader just shows a square, so I don't know if it means 2, 4, 6 and 8, or 2-4 and 6-8.

At any rate, that covers quite a few switches, so would probably be difficult to track down what they do.

I'm pretty sure while I was playing around with them I discovered that switch 1 will put it into vertical mode.

Mine are set as OFF, OFF, ON, ON, OFF, ON, ON, ON.
 

twistedsymphony

Enlightened
Staff member
Immortal
Joined
Jul 21, 2015
Messages
9,534
Reaction score
8,688
Location
NH, USA
@twistedsymphony, did you end up with a working Chihiro?
YES!

so I have the original one I bought on YAJ "junk" condition for $80 that turned out to have a a cooked GPU

then I bought one from Yaton on eBay for $220 that works well. He had a bunch of them up there cheap for a while. really drove the market price down to reasonable levels.

I've recently bought a 3rd one on eBay, supposedly working for $65 but I haven't tested it yet. I didn't need it but I couldn't pass it up at that price.

I'm in bad need of the Video link cable. for all 3 systems I have 1 cable that I built myself. it was enough of a pain in the ass that I don't want to make another one.

It baffles me that these aren't more plentiful than the Chihiros... you have to figure they all came with one, and many Chihiros have died from GPU and other issues, so why is it that the consoles out number the cables 10 to 1? If you know of any available anywhere let me know!

I actually don't know if it's a dash between the numbers because my pdf reader just shows a square, so I don't know if it means 2, 4, 6 and 8, or 2-4 and 6-8.
It's a Dash, I can see it properly on my reader...
The Ghost Squad manual is much more clear; providing a picture:
chihiro_dipswitches.jpg

Actually looking through the troubleshooting section it appears that dip 1 is for vertical/horizontal and
2,3,4,6,7,8 are resolution settings.

Lindbergh has a bank of 8 as well but I can tell you their different since I believe only 4 of them are for resolution (4-7) and #3 is the vertical/horizontal dip.
 

obcd

Professional
Joined
Oct 28, 2016
Messages
535
Reaction score
239
As we all know, the chihiro is based upon xbox hardware.
On the xbox, you had several video cables like "composite video" "rgb scart" "component" "advanced AV" and the bios is setting the video output frequency according to the connected cable.
The xbox uses 3 pins that can be grounded or left open to detect the type of AV cable connected to it.
The chihiro filter board dip switch 6, 7 and 8 gnd those pins when set to on.
The chihiro uses a different bios, and the video inputs are also interpreted differently. Switch 6, 7 and 8 on would mean RGB scart for the xbox cable. On the chihiro, it's what is selected for vga 640 x 480 x 60Hz
Maybe the chihiro bios uses those to select a video resolution. If you change them, the segaboot.xbe will error that you selected a wrong resolution. segaboot.xbe can be compared to the dashboard on an xbox. It uploads the firmware to the netdimm board and can also upload the firmware for the 2 baseboard microcontrollers. (The QC and SC firmware that is displayed on the info screen.)
There is also a dipswitch (think it's the 4) that determines where the sync is extracted from. This can be either the green video output or the composite video output. The chihiro baseboard uses an LM1881 to separate the sync from the video + sync.

I am unsure, but it looks like the chihiro base board can route the video to 2 separate outputs. Either to the normal db 15 vga connectort or to the smaller unused connector that is identical to the AVIP cable connector (but smaller with less pins)
 

Gakman

Professional
Joined
Jul 27, 2015
Messages
502
Reaction score
201
Location
Nancy (France)
This error must be not so rare, I've just fixed a "Caution 51" soldering a bridge of dipswitch 3 on my Chihiro type 3.
Thanks to this topic, I've tested the dipswitch itself. Never thought it could be physically dead.
 
Joined
May 31, 2018
Messages
646
Reaction score
644
Location
Midwest
I just had a whole bank fail (or at least multiple dips in one). It started with Caution 51, I tried to flip the switches to *exercise* them a bit. Well, upon reboot the error 51 went away, but now this particular Chihiro has an odd green tint and the video is out of sync. Every once in a while I can get it to boot properly by trying to reseat the dip switches in their proper positions.
 

nem

Enlightened
Joined
May 29, 2016
Messages
3,536
Reaction score
2,602
Location
Finland
The green tint and video being out of sync would suggest it now outputing sync on green?

There is also a dipswitch (think it's the 4) that determines where the sync is extracted from. This can be either the green video output or the composite video output.
 

Mrhide

Grand Master
Joined
Aug 17, 2016
Messages
649
Reaction score
636
Location
Montréal, Canada
Well I received a replacement baseboard from "our favorite chinese seller" cause the first one was not working. We sometime joke about him but he came through and made it right. Thumbs up!

...and then I get this:
IMG_5621.jpg


thanks to this post from @winteriscoming, I checked my dip switch 7, wiggled it and bang, 2 fully working Maxime tune ! :) (and yes, I'll need to get another usb to serial cable to wire both for the card emulator)

IMG_5622.jpg
 

nem

Enlightened
Joined
May 29, 2016
Messages
3,536
Reaction score
2,602
Location
Finland
Ahh, I've had this error pop up a few times. Turning off and on has always cleared it, but good to know there's a proper fix for it!
 

Mrhide

Grand Master
Joined
Aug 17, 2016
Messages
649
Reaction score
636
Location
Montréal, Canada
Well I had another chihiro with the same CAUTION 51 issue so knowing the above, I check the dip switches and sure enough, dip switch 3 ON was not beeping so jumpered it to dip 4 (also ON) and one more "easy fix" !
 
Top