What's new

spacejockey

Enthusiast
Joined
Aug 27, 2019
Messages
255
Reaction score
154
Location
France
Hello everyone,
I'm reaching out because I'm having some issues with a game and I got to a point where my skills are at their limit and I need help.

I recently purchased an m72 Dragon Breed game that I have been trying to find for a long time.

The game and the boards look clean, altough I have a lot of trouble making it work on any my 3 cabs.

Most of the time the game starts with "RAM ok and ROM ok" screen test ; then goes to the disclaimer message for use outside of Japan ; and then stay stuck there.
No title screen appears, and no joystick or button seems responding at this point.

The few times I managed to start the game (on any of the cabs I own, except one) , there is always a problem with the controls ; It's either the joystick doesn't go down, or the jump button is not responding, the rest works fine.
But it is impossible to play and enjoy it with those handicaps.

I have been trying to set different voltages (from 4.6v to 5.1v), but it still gets stuck at the same message.
The 12v seems quite high ; for example if I set the pcb at 5v, it will show 13v instead of 12v, and if I set it at 4.7v, it will show 12.6v.

Also I haven't been able to get to the test menu with the right dipswitch set ON, justy a white frozen screen appears

After a few days of intense trials, I managed to pass the disclaimer message ; but then the game played with some issues (joystick doesn't go down, or the jump button doesn't react). and if I swicth the power off, when I restart the cab (with the same voltage), ... the game gets stuck again on the disclaimer message.

I tried the game on 3 different cabs, an Euro one called N'styl (with scart and tv screen), a Sega Aero and a Medal Game that was transformed as a mini JAMMA cab (scart and tv screen too) and a sega Aero (all original, psu, crt screen and gear, all recapped in 2020).

Like I said after way too many trials, it worked a few times on the euro cab and the medal game, but the worst one was on the Aero, the game stay stuck to the disclaimer screen too, but the screen jumps all the time, haven't been able to get rid of the jumping and get the game to start so I didn't insist on this cab.

According to the seller, the game played smoothly at his place.
It ran at 4.9v.
The pcbs have been recapped since 2022, there also was a repair on a TTL componant, but the seller couldn't remember which one and the person who did the repairs haven't answered me yet.

I am at the end of my wits guys... can someone relate ? Have you ever encountered such issues on a Dragon breed pcb or any M72 gmae ? Am I doing something wrong ? Is there something I can do to make the game work ?

Thanks in advance for those who will help with this.

Trying to upload videos too, but having a hard time doing it.

ps: sorry if my english doesn't make sense sometimes, trying to improve on it
 
+1 for checking the ribbon cables first - unplug and firmly re-connect each cable on both ends and see if anything improves.

The hang on the Notice screen and in the Test Menu sounds like the CPU crashing, which can happen if the CPU isn't reading the code from the ROMs properly. Try using a small, flat screwdriver to carefully remove each ROM chip from each socket and then press the ROM back into place. Hopefully that's all you'll need to do to clear up that problem. If it still hangs after that then you'll want to dump the ROMs with a programmer and compare the dumps against MAME to see if you have a corrupt CPU code ROM.

As for your issue with the controls, here's how the Player 1 circuits flow on the board:

1714416266120.png

This is from the R-Type schematics located here: https://www.arcade-museum.com/manuals-videogames/R/RType.pdf

The joystick directions pass through RA5 and the action buttons pass through RA6 before meeting up at an LS244 located at IC7 on the M72-A-C board. If you still have trouble with the controls after the crashing issue is sorted out, take a look at that LS244 - especially if it was already replaced previously.

I'd run the board at 5.0V. Since it's a large triple-stack setup, it will draw more power than a single PCB game, but I wouldn't go above 5.1V or below 5.0V with it.
 
Check dip switch block #2 dip 7 "freeze game"..

"The few times I managed to start the game (on any of the cabs I own, except one) , there is always a problem with the controls ; It's either the joystick doesn't go down, or the jump button is not responding, the rest works fine."

There is a problem in the input section causing inputs to appear stuck low or stuck high. Dip switch is also an input..
Since it's intermittent, it could be the filter caps as well.
You'll need a logic probe for checking stuff like this. You can measure at the RA if the signal is HIGH or LOW, and if it's properly going into the buffer 74LS244, and exiting the same. All the stuff you need is on page 48 of the linked pdf.

Post picture of the pcb, input section. Maybe it's visible cracks or something in the Resistor Array. (RA*) or crappy caps (C*).
 
Last edited:
Tried unplugging and re-plugging firmly all ribbon bands
Resettling gently all the removable Chips ROM
+ the 5.0/5.1v approach

Tho It didn't solve the issues, the joystick acted a little more responsive this time (but not 100%) still had some hiccups when trying to go down at times.

When I get the game to start and able to play a few credits, if i switch the power off for more than 5min, when I switch the cab back on, the voltage slightly changed by itself and would not get passed the warning message ... again.

To resettle the ROM chips, I had to take each boards seperatly for the 1st time, so I took some time to look at them closely
Here are the pictures of the boards (sorry for the picture quality my phone is crap) :

The top one:
WhatsApp Image 2024-04-30 à 00.52.03_46d80103.jpg


The middle one :
WhatsApp Image 2024-04-29 à 23.43.54_5eeec382.jpg


and the bottom one:
WhatsApp Image 2024-04-29 à 23.44.07_6b2b0824.jpg


And while I went to unplug the connector, I noticed something on the IC9 componant...
WhatsApp Image 2024-04-29 à 23.44.03_d7ac3df9.jpg

WhatsApp Image 2024-04-29 à 23.44.05_f6f34a99.jpg
WhatsApp Image 2024-04-29 à 23.44.00_940a3235.jpg


A few componants in the bottom of the board seems to be corroded. But the Nanao in IC9 shown in the photos is the most concerned by this.
Could this be a clue ? Is that the input section ?

@Asure Thnaks for your input. I have tried with it on and off and it seems to be acting the same (altough on mine it seems the freeze option is on the 6th DP block 2)
I have found the imput area, but have no logic probe unfortuantely.
 

Attachments

  • 1714431927290.png
    1714431927290.png
    71 KB · Views: 13
Last edited:
IC9 definitely needs a clean and check gently each ic leg is attached to the PCB.
Best done under magnification.
 
@Gamesmonkey
Indeed, yes ! Is there a product you would recommand I should use for that ? Isopro alcool ? Vinegar ?
Is that somethjing I can do with a multimeter or will I need a logic probe for that ? Or do you mean checking each leg to see if there is dry solder points ?

On another point, the seller told me yesterday that the repair done on a TTL was for a sound problem.
 
Last edited:
Yes gently clean with a toothbrush and IPA
Then check for loose pins.
 
Hello y'all !
Thanks @Gamesmonkey. I am still waiting some alcool to be delivered, so I haven't got to that part yet.

But in the meantime, I managed to get the game to launch, works 95% of the time... YAAAAY !!!

Actually, I figured out that no matter what voltage (between 4.8 and 5.1v) or what cab I use it on ; the first time you start the game it will ALWAYS stay stuck to the regional message.
What I need to do then is switch the cab off, and restart it at the exact same voltage, ... and then it will start (usually it takes 2 times, sometimes 3).
Before that, I used to change the voltage right after switching the cab off when the game didn't start.

But even if the game starts, the jump button is non fonctioning most of the time (i managed to get it to work a few times, but then it stops working again)
And still not able to access the test menu via the dipswitch (white screen).

Also I managed to contact the person that made the initial repair on it (the sound problem, with the TTL fix). Unfortunately he is off duties at the moment, so he is trying to help me diagnose where could be the problem.

Here is a photo that shows places on the bottom PCB where components are concerned with oxydation/corrosion.
In orange the zones where the damage is mild and in red, the zones where the damage is more important.
WhatsApp Image 2024-05-08 à 16.00.27_462d2c51.jpg
WhatsApp Image 2024-05-08 à 16.11.07_b8e0bd86.jpg
WhatsApp Image 2024-04-29 à 23.44.05_f6f34a99.jpg


The last 2 photos show the 2 most corroded parts from the red zones.
 
The bottom board on M72 is used for background tile generation. Imagine a line drawn across the center length of the board - the ICs in the top half draws one background while the ICs in the bottom half draws another background. The SMD chip you circled in red in the lower-left is the compositing chip that ties them together. Corrosion on that board won't cause the control issues or failure to boot issues you're having, but it will cause background rendering glitches. I suggest carefully scrubbing off the corrosion with a fiberglass pen.

Your issues are probably coming from the middle board - inspect it closely. The control symptoms you describe make me think a TTL IC is flaky - you may just want to replace all the TTLs involved in control handling.

IMG_8878.jpgIMG_8767.jpg
 
Last edited:
Hello @ShootTheCore and thanks a lot for the explanations !!!
Cool I happen to have a fiberglass pen, so I can do that.

And i will inspect the middle board and their TTL's more thorougly !
 
Managed to get a new phone so quality in photos has increased a lot !

Here are a few photos of the RA5, RA6 and the LS244 described by @ShootTheCore earlier in the thread.

Visually it seems ok, but maybe you guys can spot if something is wrong.
Also I don't have a logic probe to check if everything is behaving as it should :/
Shot both sides of the middle pcb (components side and solder side)

WhatsApp Image 2024-05-11 à 18.12.31_149be586.jpgWhatsApp Image 2024-05-11 à 18.12.31_1280df37.jpgWhatsApp Image 2024-05-11 à 18.12.32_a80c34e1.jpgWhatsApp Image 2024-05-11 à 18.12.33_b48e2009.jpgWhatsApp Image 2024-05-11 à 18.12.34_ae6d4c56.jpgWhatsApp Image 2024-05-11 à 18.12.34_9ef819ca.jpgWhatsApp Image 2024-05-11 à 18.12.35_2a3a30f4.jpgWhatsApp Image 2024-05-11 à 18.12.36_b1960e06.jpgWhatsApp Image 2024-05-11 à 18.12.37_8121ea5e.jpg)
 
Everything looks to be in very good condition visually. I still think the LS244 should be swapped with a fresh one for your controls issue though.
 
Back
Top