What's new


Dec 14, 2021
Reaction score
Has anyone solved the Error 66 boot issue on a Yellow?
Got 2 that do this now. Tried all the usual card swapping, drive swapping, cmos reset, no IO card etc but always get an Error 66 after SegaBoot.

the sequence is:

Switch on
Machine starts to boot
White Lindbergh screen is shown
Goes through 'Vaidating'
Error 66 shown

If you go into test no game is shown as installed even though it is.

Detatch HDD - complains missing HDD
When trying to reinstall I can see the DVD drive is being accessed and is read for a short period but then it goes through 'Validating' and then shows Error 66.
Put in an invalid pic chip for the game being installed, it complains about it so that confirms its being read from DVD.
So wondering if this is a motherboard fault or something else? anyone know?
Sounds to me like it's either a harddrive or motherboard issue.
could it be invalid dipswitch settings - maybe from bad switches?
I confirmed its not a HDD issue, tried known working HDD that has another game installed on it and also a blank one that I got to install a new game and is exact same make/model.
Sort of leaves me with motherboard problems I guess.

Bad dipswitches I have had before on a Chihiro filter board. but it was kind of obvious as it messed up the monitor output resolution! Its something I can test though.

I dont know what error 66 actually means, its not listed anywhere. I'm assuming its generated in SegaBoot somewhere.
tried it with a couple, HOD4, ABC, always does the same thing. even from install disks.
irepair sega does Lindbergh hardware but the cost of sending a well packaged board from UK to USA and back plus repair costs just does not make it worthwhile.
Andy has stopped doing them now as far as I know.
I have fixed motherboard in the past, dead with shorted power rails, but partial working like this I dont know where to even start looking.
I was wondering if these guys knew what the error was.
Try reinstalling from the disk, if you’ve tried multiple games it might suggest the CF has an issue. If you install a game from the disk it will reinstall the OS as well :)
Cant reinstall from the disk. it initially accesses the DVD, but then goes through 'validation' then just errors with a 66.
Also tried swapping in another CF card too but get exactly the same result.

its a mystery!
Error 66 is reported when a CRC error is detected in the Backup Record table. This table is stored on the HDD.

I would imagine this happens when the HDD is dying, or you managed to power off the system just as it was writing the data to disk.
I suspect a reinstall should fix it.
Thanks or the info.
I've tried a replacement HDD from another system and another NOS drive.
Even if I connect up an external DVD to reinstall from disk it does the same thing. The reinstall is never initiated and it displays a 66.
Kind of points to the area of the drive controller.
Try entering the test menu and uninstalling the game first. Then try installing from DVD.
you cant. going into test menu does not show a game being installed. even though there definitely is one there. And you cannot reinstall off dvd as it errors 66 before it starts.
I just noticed this string. E66 has to do with bad or wrong region stored in EEROM on mobo near the RAM sockets on edge of pcb.
  • Like
Reactions: nem