What's new

yonggarri

Beginner
Joined
Sep 14, 2020
Messages
14
Reaction score
12
Location
South Korea
Hello.
I tried to remove the suicide battery of Segasonic the Hedgehog board today but I failed.


http://members.iinet.net.au/~lantra9jp1_nbn/gurudumps/s32convert.html


I found this page and it says I have to remove FD1149 first, program the appropriate file to two EPROMs, and replace them with IC8 & IC17.
So I tried as it says.
(I'm not sure whether this method can be applied for only 'Already Dead' board of not)





20210207_103952.jpg



20210207_105821.jpg





Removed FD1149 & Replace IC8/IC17

IC8 and IC17 roms were '27C210A-12' and I replaced them with two 'M27C1024-15F1' roms.





Etl0ko9U0AEJ3dd.jpg






...and the game doesn't work.
I tried several times checking the connection of each parts but the same thing happened.






Etl0p9AUYAAFy08.jpg





And reconnecting FD1149 and original two EPROMs, it works normally.
I still don't know what's the matter... :(
 
Last edited:

Apocalypse

Staff member
Legendary
Joined
Dec 6, 2017
Messages
3,857
Reaction score
6,697
Location
New-Zealand

yonggarri

Beginner
Joined
Sep 14, 2020
Messages
14
Reaction score
12
Location
South Korea
You know that site got the files from here? :D

Anyway, what you did looks correct to me unless:
- you mistakenly swapped IC8 and IC17
- EPROMs weren't burnt properly
I didn't know that =O
I just swapped IC8 and IC17 and it didn't work again.
There were no specific error message burning roms but maybe there were some problems while burning as you said.
I have some other rom models (10F1, 12F1) so I'll try them
 

Apocalypse

Staff member
Legendary
Joined
Dec 6, 2017
Messages
3,857
Reaction score
6,697
Location
New-Zealand
One more thing, those 27C1024 you used, does 15F1 means 150ns access time? Might be too much. I'd try with 100ns if you have some handy (10F1?).
 

yonggarri

Beginner
Joined
Sep 14, 2020
Messages
14
Reaction score
12
Location
South Korea
One more thing, those 27C1024 you used, does 15F1 means 150ns access time? Might be too much. I'd try with 100ns if you have some handy (10F1?).
I don't know what the behind number means, but I also think they might affect the result.
 

yonggarri

Beginner
Joined
Sep 14, 2020
Messages
14
Reaction score
12
Location
South Korea
One more thing, those 27C1024 you used, does 15F1 means 150ns access time? Might be too much. I'd try with 100ns if you have some handy (10F1?).
I tried again with 10F1, 12F1 and failed :(
and the game doesn't work also when the battery is attached and two roms are replaced.
Maybe I have to replace 27c020 roms(EPR-15780, 15781, 15785)
or use 27c210a rom instead of 27c1024
 
Last edited:

Apocalypse

Staff member
Legendary
Joined
Dec 6, 2017
Messages
3,857
Reaction score
6,697
Location
New-Zealand
I tried again with 10F1, 12F1 and failed :(
and the game doesn't work also when the battery is attached and two roms are replaced.
Maybe I have to replace 27c020 roms(EPR-15780, 15781, 15785)
or use 27c210a rom instead of 27c1024
No, what you did is correct. But you must remove the module when using a patched romset.
 

yonggarri

Beginner
Joined
Sep 14, 2020
Messages
14
Reaction score
12
Location
South Korea
No, what you did is correct. But you must remove the module when using a patched romset.
When I remove the battery and replace two roms, the game doesn't work.
I think there may be some problem with my romwriter...
 

DrBackhands

Beginner
Joined
Jul 11, 2019
Messages
17
Reaction score
8
Location
Central Florida
Did this story have a happy ending? I’m having the exact same issue; I desuicided a SegaSonic board with some ICs from segaressurection and I’m still getting no video or audio…
 

stj

Grand Master
Joined
May 4, 2017
Messages
1,158
Reaction score
448
Location
England
you got the roms, or programmed them yourself?
 

stj

Grand Master
Joined
May 4, 2017
Messages
1,158
Reaction score
448
Location
England
are you sure it's suicided and not just faulty?
did you check the battery voltage?

i'm asking because i remember a whole load of "suicided"l pang boards i was asked to fix in the past that actually had real faults on them.
 

yonggarri

Beginner
Joined
Sep 14, 2020
Messages
14
Reaction score
12
Location
South Korea
Did this story have a happy ending? I’m having the exact same issue; I desuicided a SegaSonic board with some ICs from segaressurection and I’m still getting no video or audio…


1624621571310.png
1624621741414.png




1624621581072.png





Yeah, I got happy ending :D
I bought new eprom programmer and erase & burnt roms once more.
The game works when I replaced just two roms, IC8(15786c) and IC17(15787c).
(You can use 27C1024 or 27C210A, any of them)
I think you'd be better make sure that the programmer works properly or the roms are attached correctly.

and my board didn't suicided yet, so still works fine with original battery (but DO NOT NEED that anymore)
 
Last edited:

DrBackhands

Beginner
Joined
Jul 11, 2019
Messages
17
Reaction score
8
Location
Central Florida
are you sure it's suicided and not just faulty?
did you check the battery voltage?

i'm asking because i remember a whole load of "suicided"l pang boards i was asked to fix in the past that actually had real faults on them.
My battery is registering a whole 0.4 volts. That's low enough to kill the roms, right? I'm actually not 100% sure... I mean, it's not 0 volts, but I'm guessing the board has KO itself.
 

DrBackhands

Beginner
Joined
Jul 11, 2019
Messages
17
Reaction score
8
Location
Central Florida
1624621571310.png
1624621741414.png




1624621581072.png





Yeah, I got happy ending :D
I bought new eprom programmer and erase & burnt roms once more.
The game works when I replaced just two roms, IC8(15786c) and IC17(15787c).
(You can use 27C1024 or 27C201A, any of them)
I think you'd be better make sure that the programmer works properly or the roms are attached correctly.

and my board didn't suicided yet, so still works fine with original battery (but DO NOT NEED that anymore)
You wouldn't be looking to burn 2 more of those boys for a little $cratch, would you? 8) Otherwiiiise, mind me asking what programmer you're using? What were you doing wrong before that caused them to be burning wrong?
 

yonggarri

Beginner
Joined
Sep 14, 2020
Messages
14
Reaction score
12
Location
South Korea
Top