What's new

frsj8112

Enthusiast
Joined
Jul 21, 2015
Messages
169
Reaction score
94
Location
Sweden
I'm working on a P-47 that has faulty sprites. the graphics are missing.
I found this video which shows a RAM test function in P-47, but is it in the original ROM?

 

Hammy

Champion
Joined
Feb 3, 2018
Messages
975
Reaction score
1,746
Location
U.K
The test modes on these games are funny and inconsistent, i think you gotta hold start or something when the board is booting as well as the dip switch.

I have a 'test rom' for the 1c and 1b hardware that gives clear ram errors.
It's more work to port to the 1a system (p47) but will have a look sometime as got 2 faulty p47's here that looking at.

A pic of the fault may give some clues, seen B+C hardware do all kinds craziness.
 

frsj8112

Enthusiast
Joined
Jul 21, 2015
Messages
169
Reaction score
94
Location
Sweden
Hi @Hammy, the ms1 games seem very inconsistent as you said and very little documentation available

Heres a vid of the sprite issues
 

Hammy

Champion
Joined
Feb 3, 2018
Messages
975
Reaction score
1,746
Location
U.K
Sprites go down post 6.
On my board there's some toshiba 6116 and a bunch of 157's close to the post, i'd check them first.
After those check the custom, post connections, 6264 rams etc.

This is assuming you have tested with a known good rom board.
 

sk8er000

Professional
Joined
Mar 1, 2016
Messages
454
Reaction score
352
Location
Italy
I got this board today and trying to figure how to enter in the test menu to see if everything is working (the game seems to run fine from the attract mode). I've tried some combos at startup but only holding the service button I get the squares pattern but nothing else. Am I missin something?
 

sk8er000

Professional
Joined
Mar 1, 2016
Messages
454
Reaction score
352
Location
Italy
The p1 button 2 was always pressed due to a broken JK-03, I've bought and installed 3 repros from @caius and now I'm able to pass the screen by pressing p1 button 1 and run all the tests!
 
Top