What's new

Trol

Enthusiast
Joined
Jul 11, 2016
Messages
245
Reaction score
134
Location
Netherlands
This Naomi 2 mobo had a checkerboard screen and ran very slow.
Did the ram test and it hangs at IC9, this is a pc 100 ram chip also found on pc memory strips.

Went to my local dirty, smokey pc shop to dig through their boxes of old memory and didn't find the right rams...
So I ordered 5 from China and here's where the fun began... the first three gave me a black screen or the same checkerboard screen I had previously.
The fourth one was finally ok and the board booted as it should.

It still showed some minor glitches and carefully bending the board made them come and go, ram test sometimes showed IC20 bad.
Reflowed it and everything is ok now.

Soak testing it the next few days to see if it stays that way.
 

jugu

Professional
Joined
Jul 25, 2015
Messages
842
Reaction score
281
Location
San Jose, CA
Did you try reflowing the memory at IC9 before replacing?
 

MickyMac

Student
Joined
Apr 2, 2019
Messages
33
Reaction score
13
Location
Europe
Hi Trol. I have the same issue on a Naomi 2 board. Slow checkerboard at boot and RAM test hangs at IC9.

I bought a PC100 RAM DIMM on ebay and replaced the RAM at IC9 but sadly have the same slow checkerboard issue and hang at IC9 on the RAM test.

Could it be the RAM underneath IC9 (at IC11S)? I searched online and other forum posts have said it's a GPU fault. Yours is the only post that gives a glimmer of hope.
 

Trol

Enthusiast
Joined
Jul 11, 2016
Messages
245
Reaction score
134
Location
Netherlands
Is the”new” ram exactly the same type as the old ram? Should be exactly the same.
I vaguely remember TylerDurden saying he raplaces ram by the pair, so ic 9 and 11 I think.
 

MickyMac

Student
Joined
Apr 2, 2019
Messages
33
Reaction score
13
Location
Europe
Thanks for the guidance AMS/Trol. Tonight I replaced IC11S on the flip side to IC9 and......................unfortunately the same problem with slow checkerboard and RAM test hang at IC9 :(

I also tried resoldering IC9 & IC11 replacing with another 2x RAM chips and experienced the same problem.

With either RAM chip off the board the Naomi 2 doesn't boot (black screen) so at least the RAM chips are good enough to allow booting and for N1 games to work.

I'll leave the RAM test running overnight. Perhaps it's just really slow to test and will eventually identify a bad RAM but if you have any more guidance to share I'd be super grateful


Edit - I let it run overnight and it was still stuck at IC9 with no result.
 
Last edited:

MickyMac

Student
Joined
Apr 2, 2019
Messages
33
Reaction score
13
Location
Europe
Just a last post for anyone that finds this thread in a search. I picked up another pc100 dimm and swapped ic9 and ic11 below again. Unfortunately it's still checkerboard and hangs at ic9 in tests :(

I actually swapped ic9 and ic11 twice more using up more chips from the dimm but all had the same issue.


So there must be another part failure that can cause this issue. Maybe one day someone far smarter than me will post a solution here :D
 
Top