What's new

hatmoose

Champion
Joined
Mar 25, 2021
Messages
1,104
Reaction score
2,298
Location
New Zealand
Hi Team;

These magnificent beauties arrived in the mail today - accurately described as "untested - assume broken"
1 x CPS3 SF3NG reasonably complete - missing a CD drive cable
1 x CPS3 bare board
IMG_5564.jpg

They both have the same this same kind of bodge wire arrangement attached to a tiny board marked "96682A-S" the board has an LS08 IC on it which is a little AND gate chip of some sort. It does not look particualty well executed, they have thoughtfully epoxied the wires to the board, and didnt clean their flux...
IMG_5569.jpgIMG_5568.jpgIMG_5566.jpg

Any thoughts on this one? I can source a 50 pin SCSI cable reasonably easily. And flashing the superbios onto the security cart is within my capibilities.
Has anyone seen a little board like the "96682-A" before? What is is, what it does? google has almost nothing to say on the subject that I could find?
 
Those jumper wires were done by Capcom at the factory. It is very common to see that on Revision 2 boards.
Brilliant - thanks, I'll get that 50 pin SCSI cable ordered and see what happens next.
 
Who knows what evil lurks in the hearts of.... er... whiteness
IMG_5572.jpg

No evil at all - just an aching emptyness - the echoing nothingness of my soul
IMG_5573.jpg

The cart also has a battery - so I had a look at that too. It was still in there but had been snapped off long ago.
IMG_5576.jpg

I'n no expert on batteries - but this is how a capicator looks before it explodes and spews corrosive electrolitic fluid everywhere
IMG_5581.jpg

And another one of those little 96682A-S boards.
IMG_5577.jpg

This little Phillips chip looks like it has been removed and replaced at some point, the solder job is awful, but looking at images of others on the internet they are all like this.
IMG_5578.jpg

So overall its looking pretty promising! From here I think I'll just plug it in and see what happens.
 

Attachments

  • IMG_5575.jpg
    IMG_5575.jpg
    178.4 KB · Views: 181
Hi Team;

I had a chance to have a closer look at these today - i'm building most of my lab test equipment as I need it, so it's slow going - but getting there.

Has anyone seen issues like these with CPS3 boards before? Any thoughts would be gratefully appreciated.

So what I have is
2 x CPS3 mainboards
1 x CPS3 BIOS cart with the battery removed (UltraBIOS_for_custom_SH2_AUTOSELECT_v1.0_CD.u2 chip on order now)
1 x set of SF3NG SIMMS (1 x 32, 1 x 64, 2 x 128)
1 x SF3NG CD
1 x CD drive, power cables, 50 pin SCSI cable

When I plug it all in and switch it on this is what happens (please ignore the Neo-geo in the pic, that's from another project, these are the graphics outputs from the CPS3 boards.

CPS3 Board 1 = Unresponsive, Optical drive wont open/shut, static garbled graphics. each power cycle shows different graphics
IMG_6195.jpegIMG_6194.jpegIMG_6193.jpegIMG_6192.jpeg

CPS3 Board 2 = Slightly responsive, Optical drive opens/shuts/spins disk, some kind of sync issue makes it impossible to see graphics. each power cycle shows different graphics
and another one of the same thing

So my next steps from here are
1) remove the factory bios chip and replace it with the new burnt ultrabios chip. That probably wont help much with the graphics issues...
2) Scope the JAMMA sync pin on board 2 and check if it is actually sending any sync

Has anyone seen issues like these before? Any idea where I should start with either of these boards?
 
if the cart is dead and not a superbios, which is sounds like it is if the battery is removed, the board will boot garbage graphics. It will boot garbage graphics with the cart absent as well.
 
if the cart is dead and not a superbios, which is sounds like it is if the battery is removed, the board will boot garbage graphics. It will boot garbage graphics with the cart absent as well.
Outstanding, thankyou! The superbios chip is on the way so it sounds like that is my next step
 
Pretty good progress on this today. Huge thanks to everyone for their comments

The board that had no sync was as simple as one of the bodge wires to the 96682A had snapped - big thanks to @benime for the knowledge.

I desoldered the old bios from the cart and replaced with the superduperultra BIOS. I got the new ones from buyicnow because I didn’t have any blank chips or a suitable programmer.
EFAD4E5D-A39F-4189-863A-8B0E152F095B.jpeg
Normally I would just blast away with the hot air, but because I didn’t have another security cart I took a bit more care with this one. Kapton tape to protect the nearby SMD from the worst of it. I used the heat gun at 420c which I find works well for lead solder. I don’t know where it measures 420 from, it’s nowhere near that hot when it comes out. I also painted the pins with flux before I started. Not sure of the flux makes any difference, but it doesn’t seem to do any harm.
4B3214A4-0F9E-4254-BE06-1D3D26C9219E.jpeg4967B30E-A665-4022-93B1-8B20A4FD9AC4.jpeg

Always a balance with hot air between taking it slow so as to not thermally stress the board, and going fast so as to not cook the chip. This took about 4 mins of gentle heating to be able to lift off without tugging.
2813EE3F-2E7D-48F8-8D2F-21D00FBC286B.jpeg
The pins on this are about the smallest pitch I can reliably do. But it was surprisingly easy to hand-solder with a T12 BCM2 tip. That tip has a little “well” in the face, it flows solder where it needs to be and sucks it out of where it should not be - it’s like a magic wand!

And, amazing result! Both of the boards now show a stable picture and boot to the ultrabios screen.
371B51A1-7992-4989-A0D8-C0F3D8915380.jpegD0D58313-206E-4D43-9D46-0CC48017CE64.jpeg

Now I’m getting the “not enough memory” error (it only has a New Generation set of SIMMS)

It also says “press 1P to darksoft menu” but 1P does nothing.

I wonder if I need the full set of SIMMS to get to the darksoft menu?
 
mine as well. You have gotten past the hard part! Just get some SIMM's and you should be in business!!!
 
Yes you are going to need 1 64MB SIMM on slot 2 and 2 128MB SIMMS on slots 5 and 6 to get to the Darksoft menu. You can refer to this page on how may SIMMS you need-

https://wiki.arcadeotaku.com/w/CPS3

Thankyou - man there is a tonne of good info on that site, its a goldmine!

More good news this morning; looks like both of the boards can boot into the superduperultramega bios, report their memory status and read from the CD ROM

If anyone else reads this in future;
Expected behavior for a CPS3 board with the ultrabios that is not fully populated with 4 x 128mb and 2 x 64mb is to boot to the ultrabios screen and ask for more memory. But you can still get into the Ultrabios menu and do tests

By pressing and holding the P1 start button at power on it will instead attempt to read the CD drive, then drop into the Ultrabios menu after about 10 seconds. There is lots of useful "stuff" in the ultrabios menu. These are all things that you would want to know to decide if a CPS3 mobo was a suitable candidate for CPS3 Multi.
1) Check that the ultrabios security cart works as expected - if you are making one yourself (or buying one off ebay) this is an important consideration
2) Check that the P1 controller port works (Directions, B1 and Start buttons) - CPS3 can be a bit tricky if the controls fail
3) Check that the CPS3 mobo can address the SIMMS in each slot - a bad slot would be a major pain
4) Check (a little bit) that the existing SIMMS are good to the point that they can be detected - this isnt such a big deal now with the ultrasimms, but still userful for me
64MB SIMMS will only work in slot 1+2, so if it's showing "FUJITSU" there you are good
128MB simms in slots 3-7 should show as "FUJITSU"
32MB simms in slots 3-7 should show a "FUJITSU 32M"
5) Check that the CPS3 mobo has a functioning SCSI controller and can address external storage - again this is not such a big deal with the ultrasimms, but still useful for me

It looks like both of these boards are fully functional - just need to hunt down some cheap simms. 1 x 64mb and 2 x 128mb would be ideal. But 1 x 64mb and 1x 32mb would also be good too. I'm pretty confident that i can add the extra chips onto the 32mb SIMMs to make 128mb ones. Nearly got there today thanks to the awesome @kuze, but alas NZ being in the middle of nowhere made it unecconomical to ship - I've waited 25 years, I can wait a little longer...

Ultrabios showing SIMMS
IMG_8627.jpegIMG_8626.jpeg

Ultrabios reading table of contents from SF3NG disk
IMG_8630.jpegIMG_8628.jpeg
 
Big thanks to @djsheep for sending me some 32mb SIMMS. I managed to find some normal and some reverse pinout ram chips from a Chinese recycler with some help from my Chinese speaking brother and his lovely wife.

Compared to swapping the bios chip it should only be half as hard to add these new chips to the 32mb Simms. Haha, famous last words…
 

Attachments

  • 4AE5DC71-8D89-4D98-965E-FC1347956948.jpeg
    4AE5DC71-8D89-4D98-965E-FC1347956948.jpeg
    270.7 KB · Views: 102
  • D1BD8D9B-25D6-4F5C-A23E-B728FDDB870D.jpeg
    D1BD8D9B-25D6-4F5C-A23E-B728FDDB870D.jpeg
    201.5 KB · Views: 96
Bought this guy off a local auction site - Street Fighter 3 3rd Strike Asia - No CD.
IMG_9458.jpeg

It was advertised as tested and working; but the actual proper spiders nest in there did not inspire a lot of confidence
IMG_9460.jpegIMG_9459.jpeg

However - works perfectly first time, I couldnt believe my luck.
IMG_9468.jpegIMG_9466.jpeg

Next up I'll crack open that cart and find out by what devilry a 25 year old battery can still be working.
 
My TSOP soldering skills needed some work so I thought I would try my hand converting 32mb Simms into 128mb ones

05FDDCC3-B10C-47CE-8191-422C20D55693.jpeg

The Sims were kindly provided by @djsheep, the chips were sourced by my brother and sister in law who are both fluent in Chinese, Ali chat, wepay, and shady gray-market recyclers

403CA2C5-D3C2-475F-9A5E-FDEB7A984A7A.jpeg

The ultrabios has a robust set of SIMM testing tools built in so I was able to verify that the 32mb Simms worked before I started messing with them, and afterwards in their new life as 128mb Simms

5C335633-53B4-4EF3-9C25-9F3EDF854085.jpeg1CB7D011-B333-4E16-918D-A655EDF94613.jpeg

To my shocked amazement this worked perfectly first time - there were SO many things that could have gone wrong here. The chips could have been fake, my soldering could have been bad.
But by some miracle everything came together and worked as expected.

This is not exactly a cost or labor intensive thing to do. 32mb Simms are expensive despite being useless, the chips are expensive and hard to buy, the soldering takes a while.

Next trick is making my own 64mb Simms from scratch, there don’t seem to be any gerbers for this, might have to learn some PCB design…
 

Attachments

  • 25840116-1703-4D88-8CA0-5677C68D3761.jpeg
    25840116-1703-4D88-8CA0-5677C68D3761.jpeg
    210.7 KB · Views: 125
Today was a good day - CPS3 multi success!

I had to cheat a bit and put a known good 2nd impact board right next to my test subject to iron out all of the wrinkles
04CAE331-18BD-47B7-9373-852917599E00.jpeg

Wrinkles were
1) bad multi-CD, I wrote this with the built in windows 10 software, would not read. Worked fine when I wrote the same thing on OS X using “burn”
2) weak CD drive, one of them did not consistently read burned CDs
3) bad SIMM, two of the 128 mb SIMMS I made worked fine. But I was doing this “blind” without testing the chips before they went on. Third one did not work, I’m guessing a faulty chip
4) loading the game would get stuck, this was because of the bad simm, had to test each simm individually in the known good SF3.2 to find the bad one.
CE70E338-F092-479C-9235-9A12B0A3208F.jpeg

But finally, sweet, sweet multi goodness.
97CD525E-3B15-442F-88CC-E8907C2885CB.jpeg2CC277B9-C5CD-4978-BD6F-B86FCBDAB5E6.jpeg04CAE331-18BD-47B7-9373-852917599E00.jpegFF33DAF4-6C1A-4518-8E03-90A62A965C01.jpeg

So from here I guess I’ll get something like a TL866 to test the chips before I put them on.

Also need to learn how to make SCSI2SD boards
 
So
Board #1 = full working multi - yaaaaaaay!
Board #2 = not so lucky yet
Board #3 = bought this as fully working SF3.2 (CD) so thats cheating and doesnt count
Board #4 = bought this as fully working SF3.3 (no-cd) so thats cheating and doesnt count either

Board #2 will load the games from a known good CD using known good SIMMS, but when the game actually runs it looks like this, words and game assets are fine, sprites are all messed up - I suspect bad sprite ram

The memory tests in the bios confirm that sprite ram = NG (Not Good). And it belches out errors from almost all the (Known good) SIMMS, And there is no sound. So a bit to do on board #2
IMG_9602.jpeg

This site is my new best friend for CPS3 mainboard hardware https://github.com/mamedev/mame/blo...5e4537514e774b/src/mame/drivers/cps3.cpp#L239

And the sprite ram is this, here
"HM514260(2)- Hitachi HM514260CJ7 256k x16 DRAM (SOJ40). This is the 'Sprite RAM' in the test mode memory test"
IMG_9605.jpeg

As much as I'd love to rip and replace the chip I suspect that the problem is actually comms with the absolutely enormous 2729 ASIC rifght next door
"DL-2729 PPU SD10-505 (QFP304) - Graphics chip".

These traces from the sprite ram to the graphics chip dont look too clever. And the little resistor networks right next door look bad too. Also whoever in the factory installed that little sync board (96682A) should hang their head in shame, this is what happens when you dont clean your flux after 25 years
IMG_9607.jpegIMG_9606.jpegIMG_9608.jpeg

Since the sprites are the most obvious problem I'll work on those first, then work on the sound, then the spurious SIMM errors.
 
Last edited:
Back
Top