What's new

BuddyC

Professional
Joined
Sep 17, 2018
Messages
291
Reaction score
558
Location
Oslo, Norway
Hello all!

Got a weird problem I need help figuring out. Far from a crisis, but any tips would be appreciated.

Got a SCSI2SD 5,1 installed with my CPS3 (Revision 2 and 4 motherboard) And Darksoft Superbios.
Writing games with the standard CD-drive works like a charm. All games run fine over long periods of time, so no issues with the SIMMS.
After a game has been written with the standard CD-drive, the SCSI2SD can take over.
Plays all games fine over long periods of time.
No sound of graphical issues.
No problems with booting original games (with original battery) or Superbios.

The weird part is that I can’t write games from the SCSI2SD (with image made from same CD as I use with the CD-drive).
Depending on the game it always stops around 30-50%. That little Capcom dude keeps on dancing, but it never resumes progression. Even after an hour or longer.

Thankfully, Switching to CD-drive always work, but if the CD-drive fails, I’m screwed...

Again. Switching to only SCSI2SD after the game has been written works great. No issues with over 30+ reboots. I only need the original CD-drive to write new games.

Weird...

Could just be a SCSI2SD v5,1 issue, but everything works great besides writing a new game.

Any tips?

Some fun troubleshooting facts.
  • Tried on my Revision 2 and 4 CPS3 motherboard with 2 different SCSI2SD v5,1. Same results
  • Used the guide here at the forum for the correct SCSI2SD settings. Everything works besides writing new games directly from SCSI2SD.
  • Tried with multiple Arcade PSU with stable 5v or up to 5,04 for some extra juice. Same results.
  • Tried with multiple SD cards, hdd raw copy, win32 disk imager, etcher. Same results.
  • Tried standard long SCSI cable and a couple of new, shorter ones bought from amigakit. Same results.
 
Top