What's new

Matan

Student
Joined
Jul 21, 2015
Messages
51
Reaction score
20
Hi all,

I recently purchase Rail Chase, which runs on the SEGA Y-BOARD hardware.
The game is not JAMMA compatible and I'd like to create a Jamma harness for it (to run on my supergun).
Does anyone have the pinout / Service manual of the game/boards?
 

Trol

Enthusiast
Joined
Jul 11, 2016
Messages
241
Reaction score
133
Location
Netherlands
First of all: sell it to me🤣
Did you get the connectors with it?
First is power.....yellow is +5 white is gnd.
Be sure to have a beefy power supply.
This thing sucks 5 volts....
 

Attachments

  • 16379674213805317134078409495977.jpg
    16379674213805317134078409495977.jpg
    161.9 KB · Views: 5

Trol

Enthusiast
Joined
Jul 11, 2016
Messages
241
Reaction score
133
Location
Netherlands
Then rgb...
Fron RIGHT to left....r, g,b sync , video gnd, last one empty
 

Attachments

  • 16379675666911371737608736472290.jpg
    16379675666911371737608736472290.jpg
    184.7 KB · Views: 4
Last edited:

Trol

Enthusiast
Joined
Jul 11, 2016
Messages
241
Reaction score
133
Location
Netherlands
Then sound... you can see speaker L and R, just wire up one....or both.... needs an external amplifier
 

Attachments

  • 16379676995334258618075803479624.jpg
    16379676995334258618075803479624.jpg
    179.1 KB · Views: 1

Trol

Enthusiast
Joined
Jul 11, 2016
Messages
241
Reaction score
133
Location
Netherlands
Try all this and get it working. Controls we'll figure out later.
Remember, its a power hog, so if you get a black screen, 5 volts is too low
 

Trol

Enthusiast
Joined
Jul 11, 2016
Messages
241
Reaction score
133
Location
Netherlands
Yes it is, but you can at least get it running to test.
I think it uses positional guns, so you can hook up 5k pots to play
 

Matan

Student
Joined
Jul 21, 2015
Messages
51
Reaction score
20
Try all this and get it working. Controls we'll figure out later.
Remember, its a power hog, so if you get a black screen, 5 volts is too low
First of all, thank you very much for the pictures.
I’ve arranged the power and video wires but as you said, I do get a blank screen.
I cranked the 5v pot on my poor PSU but still nothing.
I’ll continue investing tomorrow. If you can think of anything, please share
image.jpg
 

Asure

Professional
Joined
Jul 24, 2015
Messages
401
Reaction score
416
Location
Netherlands
The 5v leds are off, did you check for a dead short on the +5v yet?
 

Matan

Student
Joined
Jul 21, 2015
Messages
51
Reaction score
20
Good news !!
I got it to work.
For now, I got the video on screen, still need to wire the sound.
@Trol any ideas about the controls wiring?
 

Matan

Student
Joined
Jul 21, 2015
Messages
51
Reaction score
20
Good news !!
I got it to work.
For now, I got the video on screen, still need to wire the sound.
@Trol any ideas about the controls wiring?
 

Attachments

  • BF3E7B57-48D5-4D8C-BAD3-E2DB7599D77E.jpeg
    BF3E7B57-48D5-4D8C-BAD3-E2DB7599D77E.jpeg
    307.3 KB · Views: 0
  • BBC0F3BE-D7CA-4FB1-B0FB-F6AFE1C24E11.jpeg
    BBC0F3BE-D7CA-4FB1-B0FB-F6AFE1C24E11.jpeg
    332.3 KB · Views: 0
  • D253E1DA-39C9-49EE-9FE0-F08C665002E1.jpeg
    D253E1DA-39C9-49EE-9FE0-F08C665002E1.jpeg
    311.9 KB · Views: 0
  • 5D0E87E4-F15E-47B7-9347-5E4472089D7D.jpeg
    5D0E87E4-F15E-47B7-9347-5E4472089D7D.jpeg
    328.7 KB · Views: 0
  • 4440A6F5-202F-4C4C-AF82-21AFB64C4E45.jpeg
    4440A6F5-202F-4C4C-AF82-21AFB64C4E45.jpeg
    323.9 KB · Views: 0
  • 2867528F-5876-4C3D-BCAB-D7CD77EA51A1.jpeg
    2867528F-5876-4C3D-BCAB-D7CD77EA51A1.jpeg
    338.8 KB · Views: 0
Top