What's new

DickGalactic

Beginner
Joined
Dec 29, 2017
Messages
17
Reaction score
13
Location
Tokyo
So I got a hold of a Rastan PCB some time ago and it has some weird vertical black lines going through the background. You can see them clearly
if you view the pics below at full size.



My troubleshooting skills are still limited. Any idea where to start looking? I did some searching and saw that RAM problems might be a possibility.

One more thing. I was looking at the schematic and noticed that there is a 1K ohm resistor connected to a PAL (IC36) that is not present on my
board. The resistor is connected to +5V and pin 18 which looks like an I/O pin. I have checked pictures of other people's PCBs online and seen
that resistor present. Should I add it? Thank you for any guidance you can provide.
 

DickGalactic

Beginner
Joined
Dec 29, 2017
Messages
17
Reaction score
13
Location
Tokyo
A bit of an update to this. I got another board from a friend of mine and tested it with the same results. So the board is fine but I am not sure what is causing those lines in the background. It could just be brightness or color settings. I am doing some mods to my SuperGun and when those are done I can do some more tests. I still don't know if I need to add that resistor on the IC or not.
 

nem

Enlightened
Joined
May 29, 2016
Messages
3,695
Reaction score
2,744
Location
Finland
They're known as jailbars. It's a common video output related anomaly. Your setup could play into it.
 

ShootTheCore

Champion
Joined
Jan 20, 2016
Messages
1,609
Reaction score
2,284
Location
Logan UT
The video quality on my Rastan board improved when I replaced the capacitors. It got brighter and sharper.
 

DickGalactic

Beginner
Joined
Dec 29, 2017
Messages
17
Reaction score
13
Location
Tokyo
It wold have to be something with my setup, because on a CRT they don't show up. A cap replacement didn't do anything unfortunately. I am going to tweak some more settings and see what happens.

'
 

GeorgeSpinner

Student
Joined
Oct 20, 2020
Messages
60
Reaction score
13
Location
Piscataway NJ USA
I am curious if anyone ever got to the bottom of this.

I have a similar problem with a Rastan PCB I just picked up.

The colors are over-bright and washed out. There are (what I guess) are jailbars as well.

This is on a 65" Plasma display via Supergun.

On a CRT with the same Supergun, the image is perfect.

I have a Rastan bootleg, in addition to this board, that does not exhibit any of these behaviors.

Edit: Adjusting the supergun R,G,B pots helped with the color/brightness. Just really ugly bars running through it on the plasma.

Maybe I can just see them because of the size. I've played other games/systems that have Jailbars and I've never really even noticed them.
 
Last edited:

GeorgeSpinner

Student
Joined
Oct 20, 2020
Messages
60
Reaction score
13
Location
Piscataway NJ USA
Ok - So, I solved my own problem.

It's definitely something related to the Plasma not liking the sync from the Rastan PCB.

I recently purchased an OSSC.

Although I know very little about it, I decided to see if the OSSC could clean up the image some.

It look me several hours (and I kind of stumbled into the solution) but it cleaned it up perfectly.

Before:

Rastan_before_ossc.jpg


After:

rastan_after_ossc.jpg


I have attached the OSSC JSON file (renamed to .txt) in case anyone ever wants to see exactly what I did.

The profile is using 320x240 optimal mode.
 

Attachments

  • ossc_profile_0.88_Rastan.txt
    5.1 KB · Views: 10
Top